aboutsummaryrefslogtreecommitdiff
path: root/science/cgnslib
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2013-07-07 16:23:32 +0000
committerThierry Thomas <thierry@FreeBSD.org>2013-07-07 16:23:32 +0000
commit54ada251777934065e3cda55c61c424c5955641d (patch)
treea963aa747d65f4ad0c9a7c424a33fcdba493b013 /science/cgnslib
parente9d0c5d8caf760093f70c84d3bb805902375a8ba (diff)
downloadports-54ada251777934065e3cda55c61c424c5955641d.tar.gz
ports-54ada251777934065e3cda55c61c424c5955641d.zip
Upgrade to CGNS Version 3.1.4, Release 2.
Notes
Notes: svn path=/head/; revision=322450
Diffstat (limited to 'science/cgnslib')
-rw-r--r--science/cgnslib/Makefile2
-rw-r--r--science/cgnslib/distinfo4
-rw-r--r--science/cgnslib/files/patch-tcl8678
-rw-r--r--science/cgnslib/pkg-plist147
4 files changed, 11 insertions, 220 deletions
diff --git a/science/cgnslib/Makefile b/science/cgnslib/Makefile
index 63a119c6b436..b7b3c9a34a68 100644
--- a/science/cgnslib/Makefile
+++ b/science/cgnslib/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cgnslib
-DISTVERSION= 3.1.3-4
+DISTVERSION= 3.1.4-2
CATEGORIES= science
MASTER_SITES= SF/cgns/${PORTNAME}_${PORTVERSION:R:R}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
diff --git a/science/cgnslib/distinfo b/science/cgnslib/distinfo
index fb4472aef55d..f9fb86a54981 100644
--- a/science/cgnslib/distinfo
+++ b/science/cgnslib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cgnslib_3.1.3-4.tar.gz) = bded38e0b70498f76f1663899bce361344dff16e37d8f8befa2cd0178dc2f810
-SIZE (cgnslib_3.1.3-4.tar.gz) = 1571920
+SHA256 (cgnslib_3.1.4-2.tar.gz) = 327216275ce11e1cbe13b5b6c81ff53c44b24b93f829099233eae103e75be433
+SIZE (cgnslib_3.1.4-2.tar.gz) = 876039
diff --git a/science/cgnslib/files/patch-tcl86 b/science/cgnslib/files/patch-tcl86
deleted file mode 100644
index 2ee2e188b436..000000000000
--- a/science/cgnslib/files/patch-tcl86
+++ /dev/null
@@ -1,78 +0,0 @@
---- src/cgnstools/tkogl/tkogl.c.orig 2011-02-12 23:43:48.000000000 +0100
-+++ src/cgnstools/tkogl/tkogl.c 2013-06-03 18:10:06.000000000 +0200
-@@ -641,7 +641,7 @@
- ARRANGE_REDRAW(glxwinPtr);
- GetAbsXY (glxwinPtr);
-
-- interp->result = Tk_PathName(glxwinPtr->tkwin);
-+ Tcl_SetObjResult(interp, Tcl_NewStringObj(Tk_PathName(glxwinPtr->tkwin), -1));
- return TCL_OK;
- }
-
-@@ -998,7 +998,7 @@
- argv += narg;
- }
- glEndList();
-- if (result == TCL_OK) sprintf (interp->result, "%d", newlist);
-+ if (result == TCL_OK) Tcl_SetObjResult(interp, Tcl_NewIntObj(newlist));
- }
- else if ((c == 'e') && (strncmp(argv[1], "eval", length) == 0)) {
- /* sends the gl commands directly */
-@@ -1090,7 +1090,13 @@
- viewport, &x, &y, &z);
- }
- if (retval) {
-+#if TCL_MAJOR_VERSION < 8 || (TCL_MAJOR_VERSION == 8 && TCL_MINOR_VERSION < 5)
- sprintf (interp->result, "%f %f %f", x, y, z);
-+#else
-+ Tcl_Obj *obj = Tcl_NewObj ();
-+ Tcl_AppendPrintfToObj (obj, "%f %f %f", x, y, z);
-+ Tcl_SetObjResult (interp, obj);
-+#endif
- }
- }
- else if ((c == 'r') && (strncmp(argv[1], "redraw", length) == 0)) {
---- src/cgnstools/tkogl/nurbs.c.orig 2013-06-03 18:05:02.000000000 +0200
-+++ src/cgnstools/tkogl/nurbs.c 2013-06-03 18:05:31.000000000 +0200
-@@ -280,7 +280,7 @@
- DestroyFloatArray (cPoint);
-
- if (result == TCL_OK) {
-- sprintf (interp->result, "%d", dlist);
-+ Tcl_SetObjResult (interp, Tcl_NewIntObj(dlist));
- }
-
- return result;
---- src/cgnstools/tkogl/quadric.c.orig 2013-06-03 18:06:04.000000000 +0200
-+++ src/cgnstools/tkogl/quadric.c 2013-06-03 18:06:28.000000000 +0200
-@@ -147,7 +147,7 @@
- if (dlist != 0) glEndList(); else return result;
-
- if (result == TCL_OK) {
-- sprintf (interp->result, "%d", dlist);
-+ Tcl_SetObjResult (interp, Tcl_NewIntObj (dlist));
- }
- else {
- glDeleteLists (dlist, 1);
---- src/cgnstools/tkogl/tess.c.orig 2013-06-03 18:06:51.000000000 +0200
-+++ src/cgnstools/tkogl/tess.c 2013-06-03 18:07:20.000000000 +0200
-@@ -122,7 +122,7 @@
- }
-
- if (dlist != 0) {
-- sprintf (interp->result, "%d", dlist);
-+ Tcl_SetObjResult (interp, Tcl_NewIntObj (dlist));
- }
- return TCL_OK;
- }
---- src/cgnstools/tkogl/printstr.c.orig 2013-06-03 18:07:44.000000000 +0200
-+++ src/cgnstools/tkogl/printstr.c 2013-06-03 18:08:14.000000000 +0200
-@@ -131,7 +131,7 @@
- return TCL_ERROR;
- }
-
-- sprintf (interp->result, "%d", fontOffset);
-+ Tcl_SetObjResult (interp, Tcl_NewIntObj (fontOffset));
- return TCL_OK;
- }
-
diff --git a/science/cgnslib/pkg-plist b/science/cgnslib/pkg-plist
index bdb36c20e6b7..eab6ef951a83 100644
--- a/science/cgnslib/pkg-plist
+++ b/science/cgnslib/pkg-plist
@@ -1,16 +1,14 @@
bin/adf2hdf
bin/cgconfig
-bin/cgnames
bin/cgnscalc
bin/cgnscheck
+bin/cgnscompress
bin/cgnsconvert
bin/cgnsdiff
bin/cgnslist
+bin/cgnsnames
bin/cgnsnodes
bin/cgnsplot
-bin/cgnsupdate
-bin/cgnsview
-bin/unitconv
%%TOOLS%%bin/cgnstools/calcwish
%%TOOLS%%bin/cgnstools/cgiowish
%%TOOLS%%bin/cgnstools/cgns_to_plot3d
@@ -25,8 +23,13 @@ bin/unitconv
%%TOOLS%%bin/cgnstools/plot3d_to_cgns
%%TOOLS%%bin/cgnstools/plotwish
%%TOOLS%%bin/cgnstools/tecplot_to_cgns
+bin/cgnsreplace
+bin/cgnsupdate
bin/cgnsversion
+bin/cgnsview
bin/hdf2adf
+bin/unitconv
+include/cgnsBuild.defs
include/cgnslib.h
include/cgnswin_f.h
include/cgnslib_f.h
@@ -55,6 +58,7 @@ lib/libcgns.so.3.1
%%TOOLS%%share/cgnstools/cgnsplot.png
%%TOOLS%%share/cgnstools/cgnsplot.tcl
%%TOOLS%%share/cgnstools/cgnsview.tcl
+%%TOOLS%%share/cgnstools/color.tcl
%%TOOLS%%share/cgnstools/combobox.tcl
%%TOOLS%%share/cgnstools/config.tcl
%%TOOLS%%share/cgnstools/conserved.cnv
@@ -67,134 +71,6 @@ lib/libcgns.so.3.1
%%TOOLS%%share/cgnstools/findfile.tcl
%%TOOLS%%share/cgnstools/frame.tcl
%%TOOLS%%share/cgnstools/help.tcl
-%%TOOLS%%share/cgnstools/help/cgnsplot/base.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/cgnsplot.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/cutting.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/defaults.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/display.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/graphics.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/help.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/axes_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/backface_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/base_sel.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/center_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/cgnsplot.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/cutplane.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/cutting_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/cutview.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/display_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/error.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/file_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/graphics.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/help.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/help_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/help_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/lighting_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/open_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/options_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/perspective.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/perspective_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/popup.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/region_info.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/reset_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/separator.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/setup.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/setup_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/status.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/images/tree.gif
-%%TOOLS%%share/cgnstools/help/cgnsplot/menu.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/perspective.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/separator.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/status.html
-%%TOOLS%%share/cgnstools/help/cgnsplot/toolbar.html
-%%TOOLS%%share/cgnstools/help/cgnsview/buttons.html
-%%TOOLS%%share/cgnstools/help/cgnsview/cgnsnodes.html
-%%TOOLS%%share/cgnstools/help/cgnsview/cgnsview.html
-%%TOOLS%%share/cgnstools/help/cgnsview/customize.html
-%%TOOLS%%share/cgnstools/help/cgnsview/datadesc.html
-%%TOOLS%%share/cgnstools/help/cgnsview/dialogs.html
-%%TOOLS%%share/cgnstools/help/cgnsview/images/autosize_dialog.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/calc.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/cgnsview.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/check.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/check_dialog.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/clear_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/collapse.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/command.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/config_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/convert.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/create_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/custom_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/datadesc.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/datasize.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/delete_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/expand.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/export.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/file-link.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/file.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/file_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/fileinfo_dialog.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/find.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/find_dialog.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/findagain.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/folder-link.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/folder.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/follow.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/help.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/help_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/helpsetup_dialog.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/import.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/invalid.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/linkdesc.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/linknode_dialog.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/modify_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/new.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/nodedata.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/nodedesc.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/nodeinfo.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/noderef.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/nodetree.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/open.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/plot.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/popup.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/properties.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/question-link.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/question.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/read_but.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/refresh.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/save.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/separator.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/tools_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/tree_menu.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/unitconv.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/units.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/update.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/utility.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/images/version_dialog.gif
-%%TOOLS%%share/cgnstools/help/cgnsview/linkdesc.html
-%%TOOLS%%share/cgnstools/help/cgnsview/menu.html
-%%TOOLS%%share/cgnstools/help/cgnsview/nodedata.html
-%%TOOLS%%share/cgnstools/help/cgnsview/nodedesc.html
-%%TOOLS%%share/cgnstools/help/cgnsview/nodetree.html
-%%TOOLS%%share/cgnstools/help/cgnsview/separator.html
-%%TOOLS%%share/cgnstools/help/cgnsview/toolbar.html
-%%TOOLS%%share/cgnstools/help/cgnsview/unitconv.html
-%%TOOLS%%share/cgnstools/help/utilities/convert.html
-%%TOOLS%%share/cgnstools/help/utilities/export.html
-%%TOOLS%%share/cgnstools/help/utilities/images/dimensionalization.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/export_plot3d.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/export_tecplot.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/extract_subset.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/import_patran.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/import_plot3d.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/import_tecplot.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/import_user.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/interpolate_solution.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/solution_location.gif
-%%TOOLS%%share/cgnstools/help/utilities/images/solution_variables.gif
-%%TOOLS%%share/cgnstools/help/utilities/import.html
-%%TOOLS%%share/cgnstools/help/utilities/subset.html
-%%TOOLS%%share/cgnstools/help/utilities/utilities.html
%%TOOLS%%share/cgnstools/import.tcl
%%TOOLS%%share/cgnstools/menubar.tcl
%%TOOLS%%share/cgnstools/patran.tcl
@@ -215,11 +91,4 @@ lib/libcgns.so.3.1
%%TOOLS%%share/cgnstools/utilities.mnu
%%TOOLS%%share/cgnstools/vtk.tcl
%%TOOLS%%@dirrm bin/cgnstools
-%%TOOLS%%@dirrm share/cgnstools/help/utilities/images
-%%TOOLS%%@dirrm share/cgnstools/help/utilities
-%%TOOLS%%@dirrm share/cgnstools/help/cgnsview/images
-%%TOOLS%%@dirrm share/cgnstools/help/cgnsview
-%%TOOLS%%@dirrm share/cgnstools/help/cgnsplot/images
-%%TOOLS%%@dirrm share/cgnstools/help/cgnsplot
-%%TOOLS%%@dirrm share/cgnstools/help
%%TOOLS%%@dirrm share/cgnstools