aboutsummaryrefslogtreecommitdiff
path: root/science/cgnslib
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:11:23 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:11:23 +0000
commitf57bc4af665126de839ff734a08e57726e84da84 (patch)
treeb47b12c2614f4db455f6a6733adce11a1cbba4b5 /science/cgnslib
parentce4f70264ae0d02f294cd43745a43b45a8eb4a15 (diff)
downloadports-f57bc4af665126de839ff734a08e57726e84da84.tar.gz
ports-f57bc4af665126de839ff734a08e57726e84da84.zip
After an include, PLIST_SUB must be appended to, not overwritten.
If it is overwritten, many values will be clobbered, and pain will ensue. PR: 230864 Submitted by: mat exp-runs by: antoine
Notes
Notes: svn path=/head/; revision=479405
Diffstat (limited to 'science/cgnslib')
-rw-r--r--science/cgnslib/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/science/cgnslib/Makefile b/science/cgnslib/Makefile
index ff2382e74df4..0c1681cd058d 100644
--- a/science/cgnslib/Makefile
+++ b/science/cgnslib/Makefile
@@ -34,13 +34,13 @@ OPTIONS_DEFAULT=HDF5 TESTS TOOLS
LIB_DEPENDS+= libhdf5.so:science/hdf5
CMAKE_ARGS+= -DCGNS_ENABLE_HDF5:BOOL=TRUE -DHDF5_NEED_ZLIB:BOOL=TRUE \
-DHDF5_INCLUDE_PATH:PATH="${LOCALBASE}/include"
-PLIST_SUB= HDF5=""
+PLIST_SUB+= HDF5=""
. if ${PORT_OPTIONS:MSZIP}
CMAKE_ARGS+= -DHDF5_NEED_SZIP:BOOL=OFF
. endif
.else
CMAKE_ARGS+= -DCGNS_ENABLE_HDF5:BOOL=OFF
-PLIST_SUB= HDF5="@comment "
+PLIST_SUB+= HDF5="@comment "
.endif
.if ${PORT_OPTIONS:MTESTS}
@@ -56,9 +56,9 @@ USE_XORG= x11 xmu
CMAKE_ARGS+= -DCGNS_BUILD_CGNSTOOLS:BOOL=TRUE \
-DTCL_INCLUDE_PATH:STRING="${TCL_INCLUDEDIR}" \
-DTK_INCLUDE_PATH:STRING="${TK_INCLUDEDIR}"
-PLIST_SUB= TOOLS=""
+PLIST_SUB+= TOOLS=""
.else
-PLIST_SUB= TOOLS="@comment "
+PLIST_SUB+= TOOLS="@comment "
.endif
LIBVER= ${PORTVERSION:R}