aboutsummaryrefslogtreecommitdiff
path: root/science/cgribex
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-29 16:04:48 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-29 16:04:48 +0000
commit05eb45c8403e01bcd491a4f9d5089e47d42666b3 (patch)
tree9725c94997a8f8e7f21e6a087b08a3733b441368 /science/cgribex
parent8f6f87b7f0cb1daf7f109dc92c3c304456d79ada (diff)
downloadports-05eb45c8403e01bcd491a4f9d5089e47d42666b3.tar.gz
ports-05eb45c8403e01bcd491a4f9d5089e47d42666b3.zip
Add JASPER and SZLIB options
Notes
Notes: svn path=/head/; revision=432764
Diffstat (limited to 'science/cgribex')
-rw-r--r--science/cgribex/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/science/cgribex/Makefile b/science/cgribex/Makefile
index a4077af2bfef..d924996d3e5d 100644
--- a/science/cgribex/Makefile
+++ b/science/cgribex/Makefile
@@ -13,17 +13,25 @@ COMMENT= Lightweight GRIBEX in C with portable Fortran interface
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libjasper.so:graphics/jasper \
- libsz.so:science/szip
+OPTIONS_DEFINE= JASPER SZIP
+OPTIONS_DEFAULT=JASPER SZIP
-CONFIGURE_ARGS= --with-jasper=${LOCALBASE} \
- --with-szlib=${LOCALBASE}
CPPFLAGS+= -DgFortran
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
USES= libtool
+JASPER_CONFIGURE_OFF= --without-jasper
+JASPER_CONFIGURE_ON= --with-jasper=${LOCALBASE}
+JASPER_LIB_DEPENDS= libjasper.so:graphics/jasper
+SZLIB_CONFIGURE_OFF= --without-szlib
+SZIP_CONFIGURE_ON= --with-szlib=${LOCALBASE}
+SZIP_LIB_DEPENDS= libsz.so:science/szip
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|-Ino/include||; s|-Lno/lib||' ${WRKSRC}/Makefile ${WRKSRC}/*/Makefile
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcgribex.so.0.0.0