aboutsummaryrefslogtreecommitdiff
path: root/science/cgribex
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-19 17:04:33 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-19 17:04:33 +0000
commite17425d385fd76c226064fa15df14bc214bc4603 (patch)
tree49a3b17866835d7c7e9a1f033fdf956c3cd46d4a /science/cgribex
parent744715eeb1f25901d2ad089852c1b6091850b14c (diff)
downloadports-e17425d385fd76c226064fa15df14bc214bc4603.tar.gz
ports-e17425d385fd76c226064fa15df14bc214bc4603.zip
- Update to 1.7.5
- Add LICENSE_FILE - Strip shared library 1.7.5: - encodeBDS: recalculation of binscale (bug fix) [Klaus Wyser] 1.7.4: - encodeBDS: changed if to while in recalculation of binscale (bug fix) [report: Harald Anlauf] - grib_decode.tmpl: force nearest neighbor remapping from reduced gaussian grids (lveggy) - decode_array_2byte: optimisation using gribSwapByteOrder_uint16() - encode_array_2byte: optimisation using gribSwapByteOrder_uint16() 1.7.2: - gribDateTime: set ryear and century to 0 if they are undefined 1.7.1: - define grib_encode_array_2byte_double to select optimized simd version 1.7.0: - added support for time unit 14 (ISEC1_TABLE4_30MINUTES) - decode: added support of single precision floats - encode: added support of single precision floats 1.6.4: - encodeBDS: replaced intpow2(nbpv) by (1ULL << nbpv) - Update to 1.7.5
Notes
Notes: svn path=/head/; revision=426420
Diffstat (limited to 'science/cgribex')
-rw-r--r--science/cgribex/Makefile10
-rw-r--r--science/cgribex/distinfo5
-rw-r--r--science/cgribex/pkg-plist2
3 files changed, 11 insertions, 6 deletions
diff --git a/science/cgribex/Makefile b/science/cgribex/Makefile
index d0a6b661eacc..a4077af2bfef 100644
--- a/science/cgribex/Makefile
+++ b/science/cgribex/Makefile
@@ -2,27 +2,29 @@
# $FreeBSD$
PORTNAME= cgribex
-PORTVERSION= 1.6.3
+PORTVERSION= 1.7.5
CATEGORIES= science
-MASTER_SITES= https://code.zmaw.de/attachments/download/7200/ \
+MASTER_SITES= https://code.zmaw.de/attachments/download/12689/ \
LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Lightweight GRIBEX in C with portable Fortran interface
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libjasper.so:graphics/jasper \
libsz.so:science/szip
CONFIGURE_ARGS= --with-jasper=${LOCALBASE} \
--with-szlib=${LOCALBASE}
+CPPFLAGS+= -DgFortran
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
USES= libtool
-#post-install:
-# ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcgribex.so.0.0.0
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcgribex.so.0.0.0
.include <bsd.port.mk>
diff --git a/science/cgribex/distinfo b/science/cgribex/distinfo
index 4a2cf66d17a4..315247f44e7c 100644
--- a/science/cgribex/distinfo
+++ b/science/cgribex/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cgribex-1.6.3.tar.gz) = 18f197b8113f35323fec3f820ffcee17e737d08d332308b0f6db056a742429c5
-SIZE (cgribex-1.6.3.tar.gz) = 582479
+TIMESTAMP = 1479442282
+SHA256 (cgribex-1.7.5.tar.gz) = abad7ebf65d7bb764c42fad498f17a811486f2c5db943bfbd3c6a2e24cd6707d
+SIZE (cgribex-1.7.5.tar.gz) = 599151
diff --git a/science/cgribex/pkg-plist b/science/cgribex/pkg-plist
index a1d25c0be155..21ce4dbe2ab0 100644
--- a/science/cgribex/pkg-plist
+++ b/science/cgribex/pkg-plist
@@ -1,5 +1,7 @@
bin/grib
bin/grib2
+bin/gribunzip
+bin/gribzip
include/cgribex.h
lib/libcgribex.a
lib/libcgribex.so