aboutsummaryrefslogtreecommitdiff
path: root/science/chemtool-devel
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /science/chemtool-devel
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
downloadports-216b5a285fdcc1456a307fcc60f3507c20d613eb.tar.gz
ports-216b5a285fdcc1456a307fcc60f3507c20d613eb.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=366215
Diffstat (limited to 'science/chemtool-devel')
-rw-r--r--science/chemtool-devel/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/science/chemtool-devel/Makefile b/science/chemtool-devel/Makefile
index dd33f7af783c..4cbee98e48c4 100644
--- a/science/chemtool-devel/Makefile
+++ b/science/chemtool-devel/Makefile
@@ -17,26 +17,22 @@ RUN_DEPENDS= transfig:${PORTSDIR}/print/transfig
WRKSRC= ${WRKDIR}/${PORTNAME}-1.7alpha15/
USE_GNOME= gtk20
-#USE_AUTOTOOLS= autoconf213
+USE_XORG= x11
GNU_CONFIGURE= yes
USES= gettext gmake pkgconfig tar:tgz
CONFIGURE_ARGS= --enable-emf=yes
PKGNAMESUFFIX= -devel
MAKE_ARGS+= MAKE=${MAKE_CMD}
MAKE_JOBS_UNSAFE= yes
-#to include emf
-CFLAGS+= -I${LOCALBASE}/include/libEMF
-CXXFLAGS+= -I${LOCALBASE}/include/libEMF
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libEMF
+LIBS+= -L${LOCALBASE}/lib
post-patch:
- @${REINPLACE_CMD} -e 's+%%LOCALBASE%%+${LOCALBASE}+g;' ${WRKSRC}/configure.in
- @${REINPLACE_CMD} -e 's+%%LOCALBASE%%+${LOCALBASE}+g;' ${WRKSRC}/configure
+ @${REINPLACE_CMD} 's/-lstdc++//' ${WRKSRC}/configure
+ @${REINPLACE_CMD} '/^SYS_LIBRARIES =/s/$$/ -lX11/' ${WRKSRC}/Makefile.in
post-install:
- @(cd ${WRKSRC}; \
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/examples/chemtool/; \
- cd ${WRKSRC}/examples/; \
- ${INSTALL_DATA} * ${STAGEDIR}${PREFIX}/share/examples/chemtool; \
- )
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>