aboutsummaryrefslogtreecommitdiff
path: root/science/chemtool/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2003-07-21 00:57:58 +0000
committerMaho Nakata <maho@FreeBSD.org>2003-07-21 00:57:58 +0000
commit9cb0da02b0fa20d80b4513b6e1590fe122ec2e9c (patch)
tree03624402fe7cae1cd9f62e6562b5b8b297319023 /science/chemtool/Makefile
parentaea1dce716b720f2c13fd4dc24dcd4bb4a36e33b (diff)
downloadports-9cb0da02b0fa20d80b4513b6e1590fe122ec2e9c.tar.gz
ports-9cb0da02b0fa20d80b4513b6e1590fe122ec2e9c.zip
Update to 1.6 and some clean-up.
PR: 54664 Submitted by: KATO Tsuguru <tkato@prontomail.com> aka Ports fury
Notes
Notes: svn path=/head/; revision=85259
Diffstat (limited to 'science/chemtool/Makefile')
-rw-r--r--science/chemtool/Makefile25
1 files changed, 20 insertions, 5 deletions
diff --git a/science/chemtool/Makefile b/science/chemtool/Makefile
index 05f3b25c8d07..7ab9e4095aca 100644
--- a/science/chemtool/Makefile
+++ b/science/chemtool/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= chemtool
-PORTVERSION= 1.5
+PORTVERSION= 1.6
CATEGORIES= science
MASTER_SITES= http://ruby.chemie.uni-freiburg.de/~martin/chemtool/
@@ -15,13 +15,28 @@ COMMENT= Draw organic molecules easily and store them
RUN_DEPENDS= transfig:${PORTSDIR}/print/transfig
USE_GNOME= gtk12
-GNU_CONFIGURE= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN1= chemtool.1 cht.1
-post-install:
- ${MKDIR} ${PREFIX}/share/examples/chemtool
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${PREFIX}/share/examples/chemtool
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/chemtool ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src-cht/cht ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/chemtool.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/cht.1 ${MANPREFIX}/man/man1
+.for lang in cs de fr pl pt_BR ru
+ @${MKDIR} ${PREFIX}/share/locale/${lang}/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/locales/${lang}/chemtool.mo \
+ ${PREFIX}/share/locale/${lang}/LC_MESSAGES
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${FIND} . | \
+ cpio -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+.endif
.include <bsd.port.mk>