aboutsummaryrefslogtreecommitdiff
path: root/science/code_saturne
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-03-02 21:18:43 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-03-02 21:18:43 +0000
commit09bd67d4f4aff85a009b3f87dc054515d60abeb4 (patch)
tree0aace971b73a9af4c5c8c78c41f3050bf875c874 /science/code_saturne
parent4d2c0028d08e66e31439825845d165fb631ef46a (diff)
downloadports-09bd67d4f4aff85a009b3f87dc054515d60abeb4.tar.gz
ports-09bd67d4f4aff85a009b3f87dc054515d60abeb4.zip
Set USES=mpi.
Notes
Notes: svn path=/head/; revision=566986
Diffstat (limited to 'science/code_saturne')
-rw-r--r--science/code_saturne/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/science/code_saturne/Makefile b/science/code_saturne/Makefile
index 06749e0247f0..5439c10675b8 100644
--- a/science/code_saturne/Makefile
+++ b/science/code_saturne/Makefile
@@ -43,8 +43,8 @@ BINARY_ALIAS= python=${PYTHON_CMD} \
pyrcc5=pyrcc5-${PYTHON_VER} \
pyuic5=pyuic5-${PYTHON_VER}
-OPTIONS_DEFINE= DOCS EXAMPLES BATCH BLAS MPI SCOTCH
-OPTIONS_DEFAULT= BATCH BLAS MPI SCOTCH METIS
+OPTIONS_DEFINE= DOCS EXAMPLES BATCH BLAS MPICH SCOTCH
+OPTIONS_DEFAULT= BATCH BLAS MPICH SCOTCH METIS
OPTIONS_RADIO= METIS
OPTIONS_RADIO_METIS= METIS PARMETIS
BLAS_DESC= Support of OpenBLAS
@@ -53,10 +53,10 @@ BLAS_CONFIGURE_ON= --with-blas=yes --with-blas-lib=${LOCALBASE}/lib --with-blas-
BLAS_LIB_DEPENDS= libopenblas.so:math/openblas
BATCH_DESC= Use Torque to submit batches
BATCH_RUN_DEPENDS= pbs-config:sysutils/torque
-MPI_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py>0:net/py-mpi4py@${PY_FLAVOR}
-MPI_LIB_DEPENDS= libmpi.so:net/mpich
-MPI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py>0:net/py-mpi4py@${PY_FLAVOR}
-MPI_CONFIGURE_WITH= mpi
+MPICH_USES= mpi
+MPICH_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py>0:net/py-mpi4py@${PY_FLAVOR}
+MPICH_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py>0:net/py-mpi4py@${PY_FLAVOR}
+MPICH_CONFIGURE_WITH= mpi
METIS_DESC= Support of METIS
METIS_LIB_DEPENDS= libmetis.so:math/metis
METIS_CONFIGURE_ON= --with-metis-include="${LOCALBASE}/include"