aboutsummaryrefslogtreecommitdiff
path: root/science/code_saturne
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2020-05-11 23:51:58 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2020-05-11 23:51:58 +0000
commit75a5f7f0762c1039d83da77f699eed5f26998731 (patch)
treed08289c54ff9db139f0a17e3129c69e9b0ae39b1 /science/code_saturne
parent91dd9e62375f38dcfa9e2214347d9837b18c8810 (diff)
downloadports-75a5f7f0762c1039d83da77f699eed5f26998731.tar.gz
ports-75a5f7f0762c1039d83da77f699eed5f26998731.zip
Update Sphinx
- Repocopy textproc/py-sphinx to textproc/py-sphinx18 Update it to 1.8.5 (latest version from 1.8.X). This version supports Python 2 and 3. Add test target. - textproc/py-sphinx: Update to 3.0.2 Python 3 only (3.5+). Add test target. - Mk/Uses/python.mk: Add PY_SPHINX Shared macro to use with flavors and not break ports with USES=python (all versions). Python >=3.5 --> textproc/py-sphinx (v3.0.2) Python < 3.5 --> textproc/py-sphinx18 (v1.8.5) All ports that uses sphinx were changed to use the new variable ${PY_SPHINX} in the dependency line, exceptions: * Ports that fails to build with sphinx 3.0.2 because of code. They are pointing to textproc/py-sphinx18 directly. There aren't many ports. * Ports that doesn't know Python flavors. - Add several patches to fix Sphinx consumers The most common issues are related with pkg-plist, the output files from Sphinx changes between versions, keep this dynamically is the better approach. This will save time in future sphinx updates. PR: 245629 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=534966
Diffstat (limited to 'science/code_saturne')
-rw-r--r--science/code_saturne/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/science/code_saturne/Makefile b/science/code_saturne/Makefile
index 363601cfa66c..9ae220ba7dd4 100644
--- a/science/code_saturne/Makefile
+++ b/science/code_saturne/Makefile
@@ -86,7 +86,7 @@ USE_TEX= tex:build
BUILD_DEPENDS+= fig2dev:print/transfig \
doxygen:devel/doxygen \
dot:graphics/graphviz \
- sphinx-build-${PYTHON_VER}:textproc/py-sphinx@${PY_FLAVOR}
+ ${PY_SPHINX}
BINARY_ALIAS+= sphinx-build=sphinx-build-${PYTHON_VER}
ALL_TARGET= all pdf
DOCS= AUTHORS ChangeLog README