aboutsummaryrefslogtreecommitdiff
path: root/science/cp2k
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-01-26 05:20:14 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-01-26 05:20:14 +0000
commit7a4ad01d7a57a1379f0f64b174fe78817bdef137 (patch)
treee50270291977a4bb84572b57aa486f535bdbefae /science/cp2k
parentf022f448cf7e53bb92dcf81fd1a8f783fce06124 (diff)
downloadports-7a4ad01d7a57a1379f0f64b174fe78817bdef137.tar.gz
ports-7a4ad01d7a57a1379f0f64b174fe78817bdef137.zip
science/cp2k: Add missing executables that should be installed
Notes
Notes: svn path=/head/; revision=491234
Diffstat (limited to 'science/cp2k')
-rw-r--r--science/cp2k/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/science/cp2k/Makefile b/science/cp2k/Makefile
index e686f8da1202..603bf3c2069d 100644
--- a/science/cp2k/Makefile
+++ b/science/cp2k/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cp2k
DISTVERSION= 6.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= science
MASTER_SITES= SF/${PORTNAME}/
@@ -54,7 +54,10 @@ OPENMP_MPI_VARS= VERSION=psmp
OPENMP_MPI_LIB_DEPENDS= ${MPI_LIB_DEPENDS}
OPENMP_MPI_LDFLAGS= ${MPI_LDFLAGS}
-PLIST_FILES= bin/${PORTNAME}
+
+EXECUTABLES= cp2k graph cp2k_shell dbcsr_performance_driver
+
+PLIST_FILES= ${EXECUTABLES:C/(.*)/bin\/\1.${VERSION}/}
.include <bsd.port.options.mk>
@@ -74,6 +77,8 @@ pre-build:
@${MKDIR} ${BUILD_WRKSRC}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/exe/*/${PORTNAME}.* ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+.for e in ${EXECUTABLES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/exe/*/${e}.${VERSION} ${STAGEDIR}${PREFIX}/bin
+.endfor
.include <bsd.port.mk>