aboutsummaryrefslogtreecommitdiff
path: root/science/dkh
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-11-13 06:08:40 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-11-13 06:08:40 +0000
commit40006c879ce311ccae27a714441890854e320537 (patch)
tree3a876537849c7393f6389f9737244b260c7e78e2 /science/dkh
parent1fd59c0aa86822bb92a5a766f87d41c43b853093 (diff)
downloadports-40006c879ce311ccae27a714441890854e320537.tar.gz
ports-40006c879ce311ccae27a714441890854e320537.zip
Notes
Diffstat (limited to 'science/dkh')
-rw-r--r--science/dkh/Makefile20
-rw-r--r--science/dkh/distinfo3
-rw-r--r--science/dkh/pkg-descr10
-rw-r--r--science/dkh/pkg-plist6
4 files changed, 39 insertions, 0 deletions
diff --git a/science/dkh/Makefile b/science/dkh/Makefile
new file mode 100644
index 000000000000..381924e10743
--- /dev/null
+++ b/science/dkh/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= dkh
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Wolf, Reiher, and Hess's Douglas-Kroll-Hess relativistic correction
+
+LICENSE= GPLv3
+
+USES= cmake:outsource fortran
+USE_GITHUB= yes
+GH_ACCOUNT= psi4
+USE_LDCONFIG= yes
+
+CMAKE_ARGS= -DBUILD_SHARED_LIBS:BOOL=ON
+
+.include <bsd.port.mk>
diff --git a/science/dkh/distinfo b/science/dkh/distinfo
new file mode 100644
index 000000000000..57ed6c844ca4
--- /dev/null
+++ b/science/dkh/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1510543279
+SHA256 (psi4-dkh-v1.2_GH0.tar.gz) = 757cd4f9c1bf9a1c63c980e4478115b5a2a750b80b477522d7090d2326e43a1d
+SIZE (psi4-dkh-v1.2_GH0.tar.gz) = 15669
diff --git a/science/dkh/pkg-descr b/science/dkh/pkg-descr
new file mode 100644
index 000000000000..cdcc6247f05d
--- /dev/null
+++ b/science/dkh/pkg-descr
@@ -0,0 +1,10 @@
+Computation of Wolf, Reiher, and Hess's Douglas-Kroll-Hess relativistic
+correction at 2nd-4th order wrapped in CMake for the Psi4 project.
+
+It is based on these publications:
+* A. Wolf, M. Reiher, B. A. Hess, J. Chem. Phys. 117, 9215 (2002);
+ http://dx.doi.org/10.1063/1.1515314
+* M. Reiher, A. Wolf, J. Chem. Phys. 121, 10945 (2004);
+ http://dx.doi.org/10.1063/1.1818681
+
+WWW: http://www.reiher.ethz.ch/software/dkh-x2c.html
diff --git a/science/dkh/pkg-plist b/science/dkh/pkg-plist
new file mode 100644
index 000000000000..11e4b160a5f9
--- /dev/null
+++ b/science/dkh/pkg-plist
@@ -0,0 +1,6 @@
+include/DKH/DKH_MANGLE.h
+lib/libdkh.so
+share/cmake/dkh/dkhConfig.cmake
+share/cmake/dkh/dkhConfigVersion.cmake
+share/cmake/dkh/dkhTargets-%%CMAKE_BUILD_TYPE%%.cmake
+share/cmake/dkh/dkhTargets.cmake