aboutsummaryrefslogtreecommitdiff
path: root/science/dlib-cpp
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2020-11-03 08:03:19 +0000
committerGleb Popov <arrowd@FreeBSD.org>2020-11-03 08:03:19 +0000
commit21ebe03c3aada693e1126895955c8f1e5f90ac71 (patch)
treeda4519e96e401043b673308bdb45ecf5023b6ce7 /science/dlib-cpp
parent5389e7759e287e4475854173fa94cee9c71455dc (diff)
downloadports-21ebe03c3aada693e1126895955c8f1e5f90ac71.tar.gz
ports-21ebe03c3aada693e1126895955c8f1e5f90ac71.zip
Notes
Diffstat (limited to 'science/dlib-cpp')
-rw-r--r--science/dlib-cpp/Makefile6
-rw-r--r--science/dlib-cpp/pkg-plist3
2 files changed, 7 insertions, 2 deletions
diff --git a/science/dlib-cpp/Makefile b/science/dlib-cpp/Makefile
index 0741038629a7..367d4c16cd51 100644
--- a/science/dlib-cpp/Makefile
+++ b/science/dlib-cpp/Makefile
@@ -2,6 +2,7 @@
PORTNAME= dlib
DISTVERSION= 19.21
+PORTREVISION= 1
CATEGORIES= science devel math
MASTER_SITES= http://dlib.net/files/
PKGNAMESUFFIX= -cpp
@@ -15,14 +16,17 @@ LICENSE_FILE= ${WRKSRC}/dlib/LICENSE.txt
USES= cmake compiler:c++11-lang pkgconfig tar:bzip2
USE_LDCONFIG= yes
+CMAKE_ON= BUILD_SHARED_LIBS
+
OPTIONS_DEFINE= X11 JPEG PNG GIF SQLITE BLASLAPACK PYTHON AVX
OPTIONS_DEFAULT= X11 JPEG PNG GIF SQLITE
BLASLAPACK_DESC= Use Blas and Lapack libraries from ports
AVX_DESC= Use AVX instructions if supported by CPU
+PYTHON_DESC= Add dependency on science/py-dlib
X11_USES= xorg
-X11_USE= xorg=x11
+X11_USE= xorg=ice,sm,x11,xext
X11_CMAKE_OFF= -DDLIB_NO_GUI_SUPPORT=1
JPEG_USES= jpeg
diff --git a/science/dlib-cpp/pkg-plist b/science/dlib-cpp/pkg-plist
index 8fec1b11ae70..87fe1ed3f5c4 100644
--- a/science/dlib-cpp/pkg-plist
+++ b/science/dlib-cpp/pkg-plist
@@ -1028,7 +1028,8 @@ lib/cmake/dlib/dlib-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/dlib/dlib.cmake
lib/cmake/dlib/dlibConfig.cmake
lib/cmake/dlib/dlibConfigVersion.cmake
-lib/libdlib.a
+lib/libdlib.so
+lib/libdlib.so.19.21.0
libdata/pkgconfig/dlib-1.pc
@dir include/dlib/all
@dir include/dlib/appveyor