aboutsummaryrefslogtreecommitdiff
path: root/science/dlib-cpp
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-03-13 05:10:05 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-03-13 05:10:05 +0000
commit68fe12fc41cf8d6c4219fac6b65dd0e17cbc5b8b (patch)
treec8291b04f88f5fe9aad911ff1339cf110c922e32 /science/dlib-cpp
parent2a08c8fce68f2305a28cbcd5338f102c617bf303 (diff)
downloadports-68fe12fc41cf8d6c4219fac6b65dd0e17cbc5b8b.tar.gz
ports-68fe12fc41cf8d6c4219fac6b65dd0e17cbc5b8b.zip
Fix build on gcc-based architectures:
C++11 is required to use dlib, but the version of GCC you are using is too old and doesn't support C++11. You need GCC 4.8 or newer. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=495552
Diffstat (limited to 'science/dlib-cpp')
-rw-r--r--science/dlib-cpp/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/science/dlib-cpp/Makefile b/science/dlib-cpp/Makefile
index d639745921d2..163cb5445ae2 100644
--- a/science/dlib-cpp/Makefile
+++ b/science/dlib-cpp/Makefile
@@ -12,7 +12,7 @@ COMMENT= Machine learning framework written in C++
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/dlib/LICENSE.txt
-USES= cmake pkgconfig tar:bzip2
+USES= cmake compiler:c++11-lang pkgconfig tar:bzip2
USE_LDCONFIG= yes
OPTIONS_DEFINE= X11 JPEG PNG GIF SQLITE BLASLAPACK PYTHON AVX