aboutsummaryrefslogtreecommitdiff
path: root/science/dlib-cpp
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /science/dlib-cpp
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'science/dlib-cpp')
-rw-r--r--science/dlib-cpp/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/science/dlib-cpp/Makefile b/science/dlib-cpp/Makefile
index 40555918ebef..d013a9c39c4b 100644
--- a/science/dlib-cpp/Makefile
+++ b/science/dlib-cpp/Makefile
@@ -13,7 +13,7 @@ COMMENT= Machine learning framework written in C++
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/dlib/LICENSE.txt
-USES= cmake:outsource pkgconfig tar:bzip2
+USES= cmake pkgconfig tar:bzip2
USE_LDCONFIG= yes
OPTIONS_DEFINE= X11 JPEG PNG GIF SQLITE BLASLAPACK PYTHON AVX