aboutsummaryrefslogtreecommitdiff
path: root/science/elmerfem
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2021-01-13 23:03:31 +0000
committerMark Linimon <linimon@FreeBSD.org>2021-01-13 23:03:31 +0000
commitf86c964117b6a3ebf2cbf7bb69821dfb8a74f1c2 (patch)
treedee6818341bc298df429631dc617ddfaf949f1e5 /science/elmerfem
parent671839de5f6867f1f9e48aa527390d7495cbb750 (diff)
downloadports-f86c964117b6a3ebf2cbf7bb69821dfb8a74f1c2.tar.gz
ports-f86c964117b6a3ebf2cbf7bb69821dfb8a74f1c2.zip
Update GCC_DEFAULT from 9 to 10.
A few (mostly Fortran-based) ports need to be patched because GCC 10 is stricter. A handful of ports need to be restricted to GCC 9 because they fail with 10. 5 ports still fail with GCC 10. However, seeing as this work has been ongoing since 2020-05-24, it is simply time to make the commit and notify the affected maintainers. While here, pet portlint (Makevar order). PR: 246700 Submitted by: gerald Approved by: antoine (after many, many, -exp runs)
Notes
Notes: svn path=/head/; revision=561520
Diffstat (limited to 'science/elmerfem')
-rw-r--r--science/elmerfem/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/science/elmerfem/Makefile b/science/elmerfem/Makefile
index 412309457bc4..95038bdbe6c9 100644
--- a/science/elmerfem/Makefile
+++ b/science/elmerfem/Makefile
@@ -74,6 +74,12 @@ FCFLAGS+= -fPIC
FFLAGS+= -fPIC
.endif
+.if ${GCC_DEFAULT} >= 10
+# workaround for Type mismatch between actual argument at (1) and actual argument at (2) (REAL(8)/COMPLEX(8)).
+# in theory, this should set FCFLAGS, but the port does not conform
+FFLAGS+= -fallow-argument-mismatch
+.endif
+
post-patch:
@${RM} -r ${WRKSRC}/elmergrid/src/metis-5.1.0
@${REINPLACE_CMD} -e 's,"metis.*/metis\.h",<metis.h>,' \