aboutsummaryrefslogtreecommitdiff
path: root/science/fastcap
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-08-20 11:28:54 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-08-20 11:28:54 +0000
commit81711c866dcb6a62da0aa5a18af8a32b33dc659a (patch)
treeceeecce8d4be02f1e6f260498d90fbd2cc3a986d /science/fastcap
parent509a931849bfff34f19cd5c504082e1d8cc56386 (diff)
downloadports-81711c866dcb6a62da0aa5a18af8a32b33dc659a.tar.gz
ports-81711c866dcb6a62da0aa5a18af8a32b33dc659a.zip
fix the clang build
Notes
Notes: svn path=/head/; revision=280064
Diffstat (limited to 'science/fastcap')
-rw-r--r--science/fastcap/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/science/fastcap/Makefile b/science/fastcap/Makefile
index c4d547f794cb..34051281d94a 100644
--- a/science/fastcap/Makefile
+++ b/science/fastcap/Makefile
@@ -22,8 +22,17 @@ BINFILES= busgen capgen cubegen fastcap pipedgen pyragen
post-patch:
@${REINPLACE_CMD} -e 's,TYPE=other,TYPE=4,' \
${WRKSRC}/config
- @${REINPLACE_CMD} -e 's,CFLAGS =,CFLAGS +=,' \
+ @${REINPLACE_CMD} -Ee '/CFLAGS =/{s/=/+=/;s/-O[[:digit:]]*//;}' \
${WRKSRC}/src/Makefile.4
+#minimal changes to fix the clang build (there should be a more thorough
+#clean-up, to correct types of functions, remove implicit declarations, fix
+#formatting, add missing returns, etc.)
+ @${REINPLACE_CMD} -E -e 's,^mul(Up|Down),void &,' \
+ ${WRKSRC}/src/mulDo.c
+ @${REINPLACE_CMD} -e 's,^mulMatUp,void &,' \
+ ${WRKSRC}/src/mulMats.c
+ @${REINPLACE_CMD} -e 's,^static getnbrs,static void getnbrs,' \
+ ${WRKSRC}/src/mulSetup.c
do-install:
.for b in ${BINFILES}