aboutsummaryrefslogtreecommitdiff
path: root/science/fasthenry
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-03-31 16:03:03 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-03-31 16:03:03 +0000
commit1e56df8489addc4eae2b0a1c30d4a104ec7ee5ae (patch)
treef52ab596ac19979c5a557c3650892b572b7079c3 /science/fasthenry
parente4946cb514128be83854178ea50ab2e921eaf578 (diff)
Notes
Diffstat (limited to 'science/fasthenry')
-rw-r--r--science/fasthenry/Makefile15
-rw-r--r--science/fasthenry/distinfo5
-rw-r--r--science/fasthenry/files/patch-src+fasthenry+parse_command_line.c15
-rw-r--r--science/fasthenry/files/patch-src+fasthenry+sparse+spDefs.h8
-rw-r--r--science/fasthenry/files/patch-src+zbuf+input.c17
-rw-r--r--science/fasthenry/pkg-plist60
6 files changed, 49 insertions, 71 deletions
diff --git a/science/fasthenry/Makefile b/science/fasthenry/Makefile
index dcc6d9a426dd..ff74b3139945 100644
--- a/science/fasthenry/Makefile
+++ b/science/fasthenry/Makefile
@@ -6,21 +6,16 @@
#
PORTNAME= fasthenry
-DISTVERSION= ${P_VERSION}wr
+DISTVERSION= 3.0wr-011109
CATEGORIES= science cad
-MASTER_SITES= ftp://ftp.srware.com/pub/ \
- http://www.wrcad.com/ftp/pub/
+MASTER_SITES= http://www.wrcad.com/ftp/pub/ LOCAL/bf
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bf@FreeBSD.org
COMMENT= A multipole-accelerated inductance analysis program
-DEPRECATED= Upstream disapear and distfile is no more available
-EXPIRATION_DATE= 2011-05-01
-
-P_VERSION= 3.0
-
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= config
+WRKSRC = ${WRKDIR}/fasthenry-3.0wr
post-patch:
@${REINPLACE_CMD} -e 's,CFLAGS =, CFLAGS +=,' \
@@ -37,6 +32,8 @@ do-install:
${CAT} ${WRKSRC}/doc/nonuniform_manual_*.ps > ${DOCSDIR}/nonuniform_manual.ps
${INSTALL_DATA} ${WRKSRC}/doc/ms_thesis.ps ${DOCSDIR}
${GZIP_CMD} ${DOCSDIR}/*
+.endif
+.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
diff --git a/science/fasthenry/distinfo b/science/fasthenry/distinfo
index 90d6fddd3361..a79acb01f23d 100644
--- a/science/fasthenry/distinfo
+++ b/science/fasthenry/distinfo
@@ -1,3 +1,2 @@
-MD5 (fasthenry-3.0wr.tar.gz) = 27eceb7a70bebd2b3bbca2b81534351f
-SHA256 (fasthenry-3.0wr.tar.gz) = 44941e6e3dcbeeed9dd12467a6aadb6bb9eb06dea3e9967ce3c59447870beb77
-SIZE (fasthenry-3.0wr.tar.gz) = 1447130
+SHA256 (fasthenry-3.0wr-011109.tar.gz) = 229d14823cc91a657a719b8732c1f06c94077cb3d27aa27b403d42ade1c69f9a
+SIZE (fasthenry-3.0wr-011109.tar.gz) = 1438672
diff --git a/science/fasthenry/files/patch-src+fasthenry+parse_command_line.c b/science/fasthenry/files/patch-src+fasthenry+parse_command_line.c
index 8148d5ab2202..3e68d8c202e4 100644
--- a/science/fasthenry/files/patch-src+fasthenry+parse_command_line.c
+++ b/science/fasthenry/files/patch-src+fasthenry+parse_command_line.c
@@ -1,6 +1,6 @@
---- src/fasthenry/parse_command_line.c.orig Sat Feb 25 22:17:54 2006
-+++ src/fasthenry/parse_command_line.c Sat Feb 25 22:19:14 2006
-@@ -38,6 +38,7 @@
+--- src/fasthenry/parse_command_line.c.orig 2009-01-11 14:21:26.000000000 -0500
++++ src/fasthenry/parse_command_line.c 2011-03-31 10:56:27.000000000 -0400
+@@ -4,6 +4,7 @@
#include "induct.h"
#include <string.h>
@@ -8,12 +8,3 @@
#ifdef SOLARIS
#include <sys/systeminfo.h>
#endif
-@@ -558,7 +559,7 @@
- fix_and_print_opts(opts)
- ind_opts *opts;
- {
-- long clock;
-+ time_t clock;
- char hostname[BUFSIZ];
-
- fprintf(stdout, "Running FastHenry %s (%s)\n", FHVERSION, FHDATE);
diff --git a/science/fasthenry/files/patch-src+fasthenry+sparse+spDefs.h b/science/fasthenry/files/patch-src+fasthenry+sparse+spDefs.h
index e9257f162ba4..96d6fef8775b 100644
--- a/science/fasthenry/files/patch-src+fasthenry+sparse+spDefs.h
+++ b/science/fasthenry/files/patch-src+fasthenry+sparse+spDefs.h
@@ -1,9 +1,9 @@
---- src/fasthenry/sparse/spDefs.h.orig Sat Feb 25 22:50:35 2006
-+++ src/fasthenry/sparse/spDefs.h Sat Feb 25 22:51:00 2006
-@@ -462,7 +462,7 @@
- * MEMORY ALLOCATION
+--- src/fasthenry/sparse/spDefs.h.orig 2009-01-11 14:25:17.000000000 -0500
++++ src/fasthenry/sparse/spDefs.h 2011-03-31 11:38:42.000000000 -0400
+@@ -431,7 +431,7 @@
*/
+ /*
-extern char *malloc(), *calloc(), *realloc();
+extern void *malloc(), *calloc(), *realloc();
#ifdef ultrix
diff --git a/science/fasthenry/files/patch-src+zbuf+input.c b/science/fasthenry/files/patch-src+zbuf+input.c
index d28f0fb5d506..f190e3013700 100644
--- a/science/fasthenry/files/patch-src+zbuf+input.c
+++ b/science/fasthenry/files/patch-src+zbuf+input.c
@@ -1,19 +1,10 @@
---- src/zbuf/input.c.orig Sat Feb 25 22:33:42 2006
-+++ src/zbuf/input.c Sat Feb 25 22:34:26 2006
-@@ -34,6 +34,7 @@
-
+--- src/zbuf/input.c.orig 2009-01-11 14:29:55.000000000 -0500
++++ src/zbuf/input.c 2011-03-31 11:40:20.000000000 -0400
+@@ -32,6 +32,7 @@
+ of this software.
*/
+#include <string.h>
#include "mulGlobal.h"
#include "zbufGlobal.h"
-@@ -1462,7 +1463,7 @@
- surface *surf_list, *input_surfaces();
- char infile[BUFSIZ], *ctime(), hostname[BUFSIZ];
- charge *read_panels(), *chglist;
-- long clock;
-+ time_t clock;
- extern ITER *kill_num_list, *qpic_num_list, *kinp_num_list, *kq_num_list;
- extern char *kill_name_list, *qpic_name_list, *kinp_name_list;
- extern char *kq_name_list;
diff --git a/science/fasthenry/pkg-plist b/science/fasthenry/pkg-plist
index 70bf6440fb9d..1050850e7406 100644
--- a/science/fasthenry/pkg-plist
+++ b/science/fasthenry/pkg-plist
@@ -5,33 +5,33 @@ bin/zbuf
%%PORTDOCS%%%%DOCSDIR%%/nonuniform_manual.ps.gz
%%PORTDOCS%%%%DOCSDIR%%/readme.gz
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%%%EXAMPLESDIR%%/30pin.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/3d_example2.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/3d_example2_coarse.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/Zc_3d_examp2.mat
-%%PORTDOCS%%%%EXAMPLESDIR%%/Zc_pin_con7.mat
-%%PORTDOCS%%%%EXAMPLESDIR%%/broken.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/gpexamp_copper.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/hole.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/holey_gp.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/make_nonuniform.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/msm.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/nonuni01.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/onebargp.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/pin-con2seg.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/pin-con7.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/pin-connect.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/plane.in
-%%PORTDOCS%%%%EXAMPLESDIR%%/rom_check_con7_r20.ckt
-%%PORTDOCS%%%%EXAMPLESDIR%%/sline1.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/sline2.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/simple_gp.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/template.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/together.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/together_nonuni.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/trace.test.release
-%%PORTDOCS%%%%EXAMPLESDIR%%/trace_over_mesh_new.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/tree_sample.hier
-%%PORTDOCS%%%%EXAMPLESDIR%%/tree_sample.inp
-%%PORTDOCS%%%%EXAMPLESDIR%%/vias.inp
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/30pin.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/3d_example2.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/3d_example2_coarse.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Zc_3d_examp2.mat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Zc_pin_con7.mat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/broken.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gpexamp_copper.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hole.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/holey_gp.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/make_nonuniform.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/msm.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nonuni01.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/onebargp.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pin-con2seg.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pin-con7.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pin-connect.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plane.in
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rom_check_con7_r20.ckt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sline1.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sline2.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple_gp.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/template.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/together.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/together_nonuni.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/trace.test.release
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/trace_over_mesh_new.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tree_sample.hier
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tree_sample.inp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vias.inp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%