aboutsummaryrefslogtreecommitdiff
path: root/science/fasthenry
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-08-08 09:01:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-08-08 09:01:03 +0000
commit5bebac4b575c5ce595e0d6961883bab542eaa569 (patch)
tree9520bead56c508785aaa2d80fdf87ce920838dc7 /science/fasthenry
parentb45d93c8f2b0ad6c1a11209efb73a1d4c3b136d9 (diff)
downloadports-5bebac4b575c5ce595e0d6961883bab542eaa569.tar.gz
ports-5bebac4b575c5ce595e0d6961883bab542eaa569.zip
- Switch to options helpers
- Cosmetic fixes
Notes
Notes: svn path=/head/; revision=419803
Diffstat (limited to 'science/fasthenry')
-rw-r--r--science/fasthenry/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/science/fasthenry/Makefile b/science/fasthenry/Makefile
index 57eb29e55126..b9731a675438 100644
--- a/science/fasthenry/Makefile
+++ b/science/fasthenry/Makefile
@@ -9,12 +9,12 @@ MASTER_SITES= http://www.wrcad.com/ftp/pub/ LOCAL/bf
MAINTAINER= ports@FreeBSD.org
COMMENT= Multipole-accelerated inductance analysis program
-OPTIONS_DEFINE= DOCS EXAMPLES
-
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= config
WRKSRC= ${WRKDIR}/fasthenry-3.0wr
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-patch:
@${REINPLACE_CMD} -Ee '/CFLAGS =/{s/=/+=/;s/-O[[:digit:]]*//;}' \
${WRKSRC}/src/fasthenry/Makefile.default \
@@ -48,15 +48,19 @@ post-patch:
${WRKSRC}/src/fasthenry/mulMats.c
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/bin/fasthenry ${STAGEDIR}${PREFIX}/bin/
- @${INSTALL_PROGRAM} ${WRKSRC}/bin/zbuf ${STAGEDIR}${PREFIX}/bin
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/fasthenry ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/zbuf ${STAGEDIR}${PREFIX}/bin
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${CAT} ${WRKSRC}/README ${WRKSRC}/README.mit > ${STAGEDIR}${DOCSDIR}/readme
${CAT} ${WRKSRC}/doc/manual_*.ps > ${STAGEDIR}${DOCSDIR}/manual.ps
${CAT} ${WRKSRC}/doc/nonuniform_manual_*.ps > ${STAGEDIR}${DOCSDIR}/nonuniform_manual.ps
${INSTALL_DATA} ${WRKSRC}/doc/ms_thesis.ps ${STAGEDIR}${DOCSDIR}
${GZIP_CMD} ${STAGEDIR}${DOCSDIR}/*
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+
+do-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>