aboutsummaryrefslogtreecommitdiff
path: root/science/fasthenry
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-03-15 10:38:00 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-03-15 10:38:00 +0000
commit7a0ae732aa11b821cec55a53e42c706ae8a8ccdf (patch)
treeb86488f36ffc2f1fe6561fc314349c2eabd667f4 /science/fasthenry
parent838dd9cdaf0af7124e9fd42634a27fc6b7c5febc (diff)
downloadports-7a0ae732aa11b821cec55a53e42c706ae8a8ccdf.tar.gz
ports-7a0ae732aa11b821cec55a53e42c706ae8a8ccdf.zip
Add fasthenry , a multipole-accelerated inductance analysis program.
PR: ports/93969 Submitted by: Pedro Giffuni <giffunip@asme.org>
Notes
Notes: svn path=/head/; revision=157201
Diffstat (limited to 'science/fasthenry')
-rw-r--r--science/fasthenry/Makefile41
-rw-r--r--science/fasthenry/distinfo3
-rw-r--r--science/fasthenry/files/patch-src+fasthenry+parse_command_line.c19
-rw-r--r--science/fasthenry/files/patch-src+fasthenry+savemat_mod.c11
-rw-r--r--science/fasthenry/files/patch-src+fasthenry+sparse+spDefs.h11
-rw-r--r--science/fasthenry/files/patch-src+zbuf+input.c19
-rw-r--r--science/fasthenry/files/patch-src+zbuf+savemat_mod.c12
-rw-r--r--science/fasthenry/pkg-descr16
-rw-r--r--science/fasthenry/pkg-plist37
9 files changed, 169 insertions, 0 deletions
diff --git a/science/fasthenry/Makefile b/science/fasthenry/Makefile
new file mode 100644
index 000000000000..dc6551c061b5
--- /dev/null
+++ b/science/fasthenry/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: FastHenry
+# Date created: 5 Jan 2006
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fasthenry
+DISTVERSION= ${P_VERSION}wr
+CATEGORIES= science cad
+MASTER_SITES= ftp://ftp.srware.com/pub/ \
+ http://www.wrcad.com/ftp/pub/
+
+MAINTAINER= giffunip@asme.org
+COMMENT= A multipole-accelerated inductance analysis program
+
+P_VERSION= 3.0
+
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= config
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,CFLAGS =, CFLAGS +=,' \
+ ${WRKSRC}/src/fasthenry/Makefile.default \
+ ${WRKSRC}/src/zbuf/Makefile.default
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/fasthenry ${PREFIX}/bin/
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/zbuf ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CAT} ${WRKSRC}/README ${WRKSRC}/README.mit > ${DOCSDIR}/readme
+ ${CAT} ${WRKSRC}/doc/manual_*.ps > ${DOCSDIR}/manual.ps
+ ${CAT} ${WRKSRC}/doc/nonuniform_manual_*.ps > ${DOCSDIR}/nonuniform_manual.ps
+ ${INSTALL_DATA} ${WRKSRC}/doc/ms_thesis.ps ${DOCSDIR}
+ ${GZIP_CMD} ${DOCSDIR}/*
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/science/fasthenry/distinfo b/science/fasthenry/distinfo
new file mode 100644
index 000000000000..90d6fddd3361
--- /dev/null
+++ b/science/fasthenry/distinfo
@@ -0,0 +1,3 @@
+MD5 (fasthenry-3.0wr.tar.gz) = 27eceb7a70bebd2b3bbca2b81534351f
+SHA256 (fasthenry-3.0wr.tar.gz) = 44941e6e3dcbeeed9dd12467a6aadb6bb9eb06dea3e9967ce3c59447870beb77
+SIZE (fasthenry-3.0wr.tar.gz) = 1447130
diff --git a/science/fasthenry/files/patch-src+fasthenry+parse_command_line.c b/science/fasthenry/files/patch-src+fasthenry+parse_command_line.c
new file mode 100644
index 000000000000..8148d5ab2202
--- /dev/null
+++ b/science/fasthenry/files/patch-src+fasthenry+parse_command_line.c
@@ -0,0 +1,19 @@
+--- src/fasthenry/parse_command_line.c.orig Sat Feb 25 22:17:54 2006
++++ src/fasthenry/parse_command_line.c Sat Feb 25 22:19:14 2006
+@@ -38,6 +38,7 @@
+
+ #include "induct.h"
+ #include <string.h>
++#include <time.h>
+ #ifdef SOLARIS
+ #include <sys/systeminfo.h>
+ #endif
+@@ -558,7 +559,7 @@
+ fix_and_print_opts(opts)
+ ind_opts *opts;
+ {
+- long clock;
++ time_t clock;
+ char hostname[BUFSIZ];
+
+ fprintf(stdout, "Running FastHenry %s (%s)\n", FHVERSION, FHDATE);
diff --git a/science/fasthenry/files/patch-src+fasthenry+savemat_mod.c b/science/fasthenry/files/patch-src+fasthenry+savemat_mod.c
new file mode 100644
index 000000000000..026df719a02d
--- /dev/null
+++ b/science/fasthenry/files/patch-src+fasthenry+savemat_mod.c
@@ -0,0 +1,11 @@
+--- src/fasthenry/savemat_mod.c.orig Sat Feb 25 22:21:09 2006
++++ src/fasthenry/savemat_mod.c Sat Feb 25 22:26:29 2006
+@@ -57,7 +57,7 @@
+ */
+ #include <stdio.h>
+
+-#ifdef ALPHA
++#ifdef ALPHA || defined(__alpha__) || defined(__amd64__) || defined(___sparc64__) || defined(__ia64__)
+ typedef struct {
+ int type; /* type */
+ int mrows; /* row dimension */
diff --git a/science/fasthenry/files/patch-src+fasthenry+sparse+spDefs.h b/science/fasthenry/files/patch-src+fasthenry+sparse+spDefs.h
new file mode 100644
index 000000000000..e9257f162ba4
--- /dev/null
+++ b/science/fasthenry/files/patch-src+fasthenry+sparse+spDefs.h
@@ -0,0 +1,11 @@
+--- src/fasthenry/sparse/spDefs.h.orig Sat Feb 25 22:50:35 2006
++++ src/fasthenry/sparse/spDefs.h Sat Feb 25 22:51:00 2006
+@@ -462,7 +462,7 @@
+ * MEMORY ALLOCATION
+ */
+
+-extern char *malloc(), *calloc(), *realloc();
++extern void *malloc(), *calloc(), *realloc();
+ #ifdef ultrix
+ extern void free();
+ extern void abort();
diff --git a/science/fasthenry/files/patch-src+zbuf+input.c b/science/fasthenry/files/patch-src+zbuf+input.c
new file mode 100644
index 000000000000..d28f0fb5d506
--- /dev/null
+++ b/science/fasthenry/files/patch-src+zbuf+input.c
@@ -0,0 +1,19 @@
+--- src/zbuf/input.c.orig Sat Feb 25 22:33:42 2006
++++ src/zbuf/input.c Sat Feb 25 22:34:26 2006
+@@ -34,6 +34,7 @@
+
+ */
+
++#include <string.h>
+ #include "mulGlobal.h"
+ #include "zbufGlobal.h"
+
+@@ -1462,7 +1463,7 @@
+ surface *surf_list, *input_surfaces();
+ char infile[BUFSIZ], *ctime(), hostname[BUFSIZ];
+ charge *read_panels(), *chglist;
+- long clock;
++ time_t clock;
+ extern ITER *kill_num_list, *qpic_num_list, *kinp_num_list, *kq_num_list;
+ extern char *kill_name_list, *qpic_name_list, *kinp_name_list;
+ extern char *kq_name_list;
diff --git a/science/fasthenry/files/patch-src+zbuf+savemat_mod.c b/science/fasthenry/files/patch-src+zbuf+savemat_mod.c
new file mode 100644
index 000000000000..2208fe2d647c
--- /dev/null
+++ b/science/fasthenry/files/patch-src+zbuf+savemat_mod.c
@@ -0,0 +1,12 @@
+--- src/zbuf/savemat_mod.c.orig Tue Feb 28 21:04:21 2006
++++ src/zbuf/savemat_mod.c Tue Feb 28 21:06:27 2006
+@@ -23,7 +23,8 @@
+ */
+ #include <stdio.h>
+
+-#ifdef ALPHA
++#if defined(ALPHA) || defined(__alpha__) || defined(__amd64__) || defined(___sparc64__) || defined(__ia64__)
++
+ typedef struct {
+ int type; /* type */
+ int mrows; /* row dimension */
diff --git a/science/fasthenry/pkg-descr b/science/fasthenry/pkg-descr
new file mode 100644
index 000000000000..e02c2c234c6d
--- /dev/null
+++ b/science/fasthenry/pkg-descr
@@ -0,0 +1,16 @@
+FastHenry computes the frequency dependent self and mutual inductances and
+resistances between conductors of complex shape. The algorithm used in
+FastHenry is an acceleration of rge mesh formulation approach. The linear system
+resulting from the mesh formulation is solved using a generalized minimal
+residual algorithm with a fast multipole algorithm to efficiently compute the
+iterates.
+
+WWW: http://www.rle.mit.edu/cpg/research_codes.htm
+
+--------------------- Superconductivity Support -------------------------
+
+This version of fasthenry has been modified to support superconducting
+segments and ground planes by Stephen R. Whiteley of Whitleley Research Inc.
+The analysis used is based on the London equations and the two-fluid
+model. Both reactive and lossy components of the superconductor complex
+conductivity are employed in obtaining the impedance matrix.
diff --git a/science/fasthenry/pkg-plist b/science/fasthenry/pkg-plist
new file mode 100644
index 000000000000..70bf6440fb9d
--- /dev/null
+++ b/science/fasthenry/pkg-plist
@@ -0,0 +1,37 @@
+bin/fasthenry
+bin/zbuf
+%%PORTDOCS%%%%DOCSDIR%%/manual.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/ms_thesis.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/nonuniform_manual.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/readme.gz
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%EXAMPLESDIR%%/30pin.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/3d_example2.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/3d_example2_coarse.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/Zc_3d_examp2.mat
+%%PORTDOCS%%%%EXAMPLESDIR%%/Zc_pin_con7.mat
+%%PORTDOCS%%%%EXAMPLESDIR%%/broken.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/gpexamp_copper.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/hole.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/holey_gp.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/make_nonuniform.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/msm.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/nonuni01.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/onebargp.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/pin-con2seg.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/pin-con7.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/pin-connect.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/plane.in
+%%PORTDOCS%%%%EXAMPLESDIR%%/rom_check_con7_r20.ckt
+%%PORTDOCS%%%%EXAMPLESDIR%%/sline1.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/sline2.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/simple_gp.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/template.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/together.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/together_nonuni.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/trace.test.release
+%%PORTDOCS%%%%EXAMPLESDIR%%/trace_over_mesh_new.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/tree_sample.hier
+%%PORTDOCS%%%%EXAMPLESDIR%%/tree_sample.inp
+%%PORTDOCS%%%%EXAMPLESDIR%%/vias.inp
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%