aboutsummaryrefslogtreecommitdiff
path: root/science/gabedit
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-08-25 19:48:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-08-25 19:48:48 +0000
commitcad6c8d73672a0a16096f73dfd2377450018b49e (patch)
treebe5a739a02792cd3af01c39b6ab9f1de0515b00d /science/gabedit
parent2c3042c58b7f1c7af78d3860b86abfc2eecd256d (diff)
downloadports-cad6c8d73672a0a16096f73dfd2377450018b49e.tar.gz
ports-cad6c8d73672a0a16096f73dfd2377450018b49e.zip
science/gabedit: Add the option OPENMP
Also remove WRKSRC which isn't needed.
Notes
Notes: svn path=/head/; revision=478086
Diffstat (limited to 'science/gabedit')
-rw-r--r--science/gabedit/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/science/gabedit/Makefile b/science/gabedit/Makefile
index 1b8c80afb8a3..6862c3fe8227 100644
--- a/science/gabedit/Makefile
+++ b/science/gabedit/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gabedit
DISTVERSION= 2.5.0
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= http://prdownloads.sourceforge.net/${PORTNAME}/
DISTNAME= GabeditSrc${DISTVERSION:S/.//g}
@@ -14,8 +15,7 @@ LICENSE_FILE= ${WRKSRC}/License
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
- libgtkglext-x11-1.0.so:x11-toolkits/gtkglext \
- libomp.so:devel/openmp
+ libgtkglext-x11-1.0.so:x11-toolkits/gtkglext
USES= gettext-runtime gmake pkgconfig
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 pango pangox-compat
@@ -23,8 +23,6 @@ USE_GL= gl glu
USE_XORG= x11
INSTALLS_ICONS= yes
-WRKSRC= ${WRKDIR}/GabeditSrc250
-
BINARY_ALIAS= make=gmake
PLIST_FILES= bin/gabedit \
@@ -35,9 +33,17 @@ ICON_SIZES= 16 24 32 48
PLIST_FILES+= share/icons/hicolor/${SZ}x${SZ}/apps/gabedit.png
.endfor
+OPTIONS_DEFINE= OPENMP
+OPTIONS_DEFAULT= OPENMP
+
+OPENMP_LIB_DEPENDS= libomp.so:devel/openmp
+
post-patch:
@${REINPLACE_CMD} 's|/usr/|${PREFIX}/|; s| -O2| ${CFLAGS}|; s|gcc|${CC}|' ${WRKSRC}/CONFIG
+post-patch-OPENMP-off:
+ @${REINPLACE_CMD} 's|enable_omp = 1|enable_omp = 0|' ${WRKSRC}/CONFIG
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
${INSTALL_DATA} ${WRKSRC}/utils/Others/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}