aboutsummaryrefslogtreecommitdiff
path: root/science/gramps/Makefile
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2019-12-10 13:54:03 +0000
committerBen Woods <woodsb02@FreeBSD.org>2019-12-10 13:54:03 +0000
commitf6e6c22cc914cab74fe454354faa26cc9b0a738a (patch)
tree8298400e354516798da624200892d5e47066f8af /science/gramps/Makefile
parent8d3718274ac8cf32cbb5688735b80b888c299cc7 (diff)
downloadports-f6e6c22cc914cab74fe454354faa26cc9b0a738a.tar.gz
ports-f6e6c22cc914cab74fe454354faa26cc9b0a738a.zip
Notes
Diffstat (limited to 'science/gramps/Makefile')
-rw-r--r--science/gramps/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/science/gramps/Makefile b/science/gramps/Makefile
index 94dd1de54244..20fd9cdf7633 100644
--- a/science/gramps/Makefile
+++ b/science/gramps/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gramps
-PORTVERSION= 5.0.1
+PORTVERSION= 5.1.1
DISTVERSIONPREFIX= v
CATEGORIES= science gnome python
@@ -12,13 +12,15 @@ COMMENT= GTK3-based genealogy program
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libosmgpsmap-1.0.so:x11-toolkits/osm-gps-map
+LIB_DEPENDS= libgeocode-glib.so:net/geocode-glib \
+ libosmgpsmap-1.0.so:x11-toolkits/osm-gps-map
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsddb3>0:databases/py-bsddb3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyicu>=1.8:devel/py-pyicu@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pygraphviz>=0:graphics/py-pygraphviz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVOR} \
xdg-open:devel/xdg-utils
-USES= desktop-file-utils gettext gnome python:3.2+ shared-mime-info
+USES= desktop-file-utils gettext gnome python:3.3+ shared-mime-info
USE_GITHUB= yes
GH_ACCOUNT= gramps-project
USE_GNOME= cairo gtk30 intltool librsvg2 pango pygobject3