aboutsummaryrefslogtreecommitdiff
path: root/science/gromacs/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-12-27 16:39:52 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-12-27 16:39:52 +0000
commit7f997ad80c4a46a9d6ba763a283b83d54e3ecec2 (patch)
treef1e32cbda2fe4ba96893f684d968d74dbd7b7746 /science/gromacs/Makefile
parent38139d5b659c0bcd62b981c875a133223ffbee9a (diff)
downloadports-7f997ad80c4a46a9d6ba763a283b83d54e3ecec2.tar.gz
ports-7f997ad80c4a46a9d6ba763a283b83d54e3ecec2.zip
Notes
Diffstat (limited to 'science/gromacs/Makefile')
-rw-r--r--science/gromacs/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/science/gromacs/Makefile b/science/gromacs/Makefile
index 73d404744a7b..7077678cc298 100644
--- a/science/gromacs/Makefile
+++ b/science/gromacs/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gromacs
PORTVERSION= 4.6.5
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= ftp://ftp.gromacs.org/pub/gromacs/
@@ -24,10 +25,9 @@ GSL_DESC= Extra analysis using math/gsl
MPICH_DESC= MPI support using net/mpich2
OMPI_DESC= MPI support using net/openmpi
-USES= cmake perl5 pkgconfig shebangfix
+USES= cmake fortran perl5 pkgconfig shebangfix
SHEBANG_FILES= admin/*.pl scripts/*.pl scripts/*.sh src/gmxlib/selection/*.sh
bash_CMD= ${SH}
-USE_FORTRAN= yes
CMAKE_ARGS= -DBLAS_LIBRARIES:FILEPATH="${BLAS_LIBS}" \
-DLAPACK_LIBRARIES:FILEPATH="${LAPACK_LIBS}"
USE_LDCONFIG= yes
@@ -96,5 +96,7 @@ post-patch:
@${FIND} ${WRKSRC} -name "GMXRC.*" | ${XARGS} ${REINPLACE_CMD} -e \
's|LDLIB/pkgconfig|LDLIB/../libdata/pkgconfig| ; \
s|LDLIB}/pkgconfig|LDLIB}/../libdata/pkgconfig|'
+ @${REINPLACE_CMD} -e '/CMAKE_REQUIRED_LIBRARIES/d' \
+ ${WRKSRC}/cmake/gmxTestdlopen.cmake
.include <bsd.port.mk>