aboutsummaryrefslogtreecommitdiff
path: root/science/gromacs
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-07-14 00:19:40 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-07-14 00:21:33 +0000
commit038e81ab5346f6b11831ae76cda937d7c41811cd (patch)
treea595d6c85f38c1b5b2c49147dbd0568f5d434212 /science/gromacs
parentbc59c09bd5e672a7de674e7a64cacd813720ecab (diff)
downloadports-038e81ab5346f6b11831ae76cda937d7c41811cd.tar.gz
ports-038e81ab5346f6b11831ae76cda937d7c41811cd.zip
Diffstat (limited to 'science/gromacs')
-rw-r--r--science/gromacs/Makefile13
-rw-r--r--science/gromacs/distinfo4
2 files changed, 13 insertions, 4 deletions
diff --git a/science/gromacs/Makefile b/science/gromacs/Makefile
index cf150eb41fad..ce462cf73082 100644
--- a/science/gromacs/Makefile
+++ b/science/gromacs/Makefile
@@ -2,6 +2,7 @@ PORTNAME= gromacs
DISTVERSION= 2023.2
CATEGORIES= science
MASTER_SITES= ftp://ftp.gromacs.org/pub/gromacs/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} # only for googletest
MAINTAINER= yuri@FreeBSD.org
COMMENT= Compute molecular dynamics
@@ -14,12 +15,14 @@ BROKEN_i386= undefined reference to `__atomic_load' and `__atomic_compare_exchan
BUILD_DEPENDS= boost-libs>=1.44:devel/boost-libs
LIB_DEPENDS= libhwloc.so:devel/hwloc2
-TEST_DEPENDS= googletest>0:devel/googletest
-USES= cmake compiler:c++17-lang fortran gnome perl5 pkgconfig python:build shebangfix xorg
+USES= cmake compiler:c++17-lang gnome perl5 pkgconfig python:build shebangfix xorg
USE_GNOME= libxml2
USE_LDCONFIG= yes
+USE_GITHUB= nodefault
+GH_TUPLE= google:googletest:v1.13.0:googletest
+
SHEBANG_FILES= admin/*.sh scripts/*.pl scripts/*.sh src/gromacs/selection/*.sh
bash_CMD= ${SH}
@@ -32,7 +35,7 @@ TEST_TARGET= check
OPTIONS_DEFINE= ATLAS FLOAT LEGACY OPENCL OPENMP SIMD X11
OPTIONS_SINGLE= MP
OPTIONS_SINGLE_MP= NOMP MPICH OPENMPI THREAD_MPI
-OPTIONS_DEFAULT= LEGACY OPENMP THREAD_MPI X11 # FLOAT should not a default because science/votca needs double precision. This is likely the same for many other uses.
+OPTIONS_DEFAULT= LEGACY OPENMP THREAD_MPI X11 # FLOAT should not be a default because science/votca needs double precision. This is likely the same for many other uses.
OPTIONS_SUB= yes
ATLAS_DESC= Use ATLAS for BLAS and LAPACK
@@ -88,6 +91,10 @@ THREAD_MPI_DESC= Build a thread-MPI-based multithreaded version of GROMACS
THREAD_MPI_CMAKE_BOOL= GMX_THREAD_MPI
THREAD_MPI_PLIST_SUB= SUFFIX_MPI=""
+post-extract: # replace outdated bundled googletest with a newer version to fix tests build, see https://gitlab.com/gromacs/gromacs/-/issues/4825
+ @${RM} -r ${WRKSRC}/src/external/googletest
+ @${RLN} ${WRKSRC_googletest} ${WRKSRC}/src/external/googletest
+
post-patch:
@${FIND} ${WRKSRC} -name "GMXRC.*" | ${XARGS} ${REINPLACE_CMD} -e \
's|LDLIB/pkgconfig|LDLIB/../libdata/pkgconfig| ; \
diff --git a/science/gromacs/distinfo b/science/gromacs/distinfo
index 0cec71219d3a..1b7c30fa9b05 100644
--- a/science/gromacs/distinfo
+++ b/science/gromacs/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1689223634
+TIMESTAMP = 1689290012
SHA256 (gromacs-2023.2.tar.gz) = bce1480727e4b2bb900413b75d99a3266f3507877da4f5b2d491df798f9fcdae
SIZE (gromacs-2023.2.tar.gz) = 41930578
+SHA256 (google-googletest-v1.13.0_GH0.tar.gz) = ad7fdba11ea011c1d925b3289cf4af2c66a352e18d4c7264392fead75e919363
+SIZE (google-googletest-v1.13.0_GH0.tar.gz) = 862871