aboutsummaryrefslogtreecommitdiff
path: root/science/gromacs
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-02-05 15:52:41 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-02-05 15:52:41 +0000
commit21e9da30adecc8bbac2435e52da50f39fb7019f2 (patch)
tree6b4e7b82a9a217148218ef427d16e30b5463ee0d /science/gromacs
parentfe99c3d6b97559edab8bf316dd6c884ef8ed8229 (diff)
downloadports-21e9da30adecc8bbac2435e52da50f39fb7019f2.tar.gz
ports-21e9da30adecc8bbac2435e52da50f39fb7019f2.zip
science/gromacs: Fix build on systems with older clang (clang-6)
Reported by: fallout
Notes
Notes: svn path=/head/; revision=525280
Diffstat (limited to 'science/gromacs')
-rw-r--r--science/gromacs/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/science/gromacs/Makefile b/science/gromacs/Makefile
index 0c4154de20ef..3a3719be9937 100644
--- a/science/gromacs/Makefile
+++ b/science/gromacs/Makefile
@@ -18,7 +18,7 @@ BROKEN_i386= undefined reference to `__atomic_load' and `__atomic_compare_exchan
BUILD_DEPENDS= boost-libs>=1.44:devel/boost-libs
LIB_DEPENDS= libhwloc.so:devel/hwloc
-USES= cmake compiler:c++14-lang fortran gnome perl5 pkgconfig shebangfix xorg
+USES= cmake fortran gnome perl5 pkgconfig shebangfix xorg # should be compiler:c++14-lang
SHEBANG_FILES= admin/*.sh scripts/*.pl scripts/*.sh src/gromacs/selection/*.sh
bash_CMD= ${SH}
USE_GNOME= libxml2
@@ -83,6 +83,12 @@ THREAD_MPI_DESC= Build a thread-MPI-based multithreaded version of GROMACS
THREAD_MPI_CMAKE_BOOL= GMX_THREAD_MPI
THREAD_MPI_PLIST_SUB= SUFFIX_MPI=""
+# build fails on 12.0 with clang-6, so force a newer compiler
+BUILD_DEPENDS+= clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
+CPP= clang-cpp${LLVM_DEFAULT}
+CC= clang${LLVM_DEFAULT}
+CXX= clang++${LLVM_DEFAULT}
+
post-patch:
@${FIND} ${WRKSRC} -name "CMakeLists.txt" | ${XARGS} \
${REINPLACE_CMD} -e \