aboutsummaryrefslogtreecommitdiff
path: root/science/gromacs
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-12-18 01:21:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-12-18 01:21:01 +0000
commit28e07230d303b64511a7830edca7bb8191a00a64 (patch)
tree4b65bdae2cbadfdff560310f9d7868544ad16dc6 /science/gromacs
parentae6d9c39b70d2c52d1a492f4100da62c287294a6 (diff)
downloadports-28e07230d303b64511a7830edca7bb8191a00a64.tar.gz
ports-28e07230d303b64511a7830edca7bb8191a00a64.zip
science/gromacs: Add the LEGACY option that installs legacy API needed by some users
Notes
Notes: svn path=/head/; revision=558341
Diffstat (limited to 'science/gromacs')
-rw-r--r--science/gromacs/Makefile8
-rw-r--r--science/gromacs/pkg-plist78
2 files changed, 84 insertions, 2 deletions
diff --git a/science/gromacs/Makefile b/science/gromacs/Makefile
index b2c7507977a0..74ad7150967c 100644
--- a/science/gromacs/Makefile
+++ b/science/gromacs/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gromacs
DISTVERSION= 2020.4
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= ftp://ftp.gromacs.org/pub/gromacs/
@@ -25,10 +26,10 @@ CMAKE_OFF= GMX_USE_RDTSCP \
USE_PYTHON_SCRIPTS
USE_LDCONFIG= yes
-OPTIONS_DEFINE= ATLAS FLOAT OPENCL OPENMP SIMD X11
+OPTIONS_DEFINE= ATLAS FLOAT LEGACY OPENCL OPENMP SIMD X11
OPTIONS_SINGLE= MP
OPTIONS_SINGLE_MP= NOMP MPICH OPENMPI THREAD_MPI
-OPTIONS_DEFAULT= FLOAT OPENMP THREAD_MPI X11
+OPTIONS_DEFAULT= FLOAT LEGACY OPENMP THREAD_MPI X11
OPTIONS_SUB= yes
ATLAS_DESC= Use ATLAS for BLAS and LAPACK
@@ -48,6 +49,9 @@ FLOAT_CMAKE_OFF= -DGMX_DOUBLE:BOOL=ON
FLOAT_PLIST_SUB= SUFFIX_D=""
FLOAT_PLIST_SUB_OFF= SUFFIX_D="_d"
+LEGACY_DESC= Install legacy API # expected by science/votca
+LEGACY_CMAKE_BOOL= GMX_INSTALL_LEGACY_API
+
OPENCL_CMAKE_BOOL= GMX_USE_OPENCL GMX_GPU
OPENCL_LIB_DEPENDS= libOpenCL.so:devel/ocl-icd
diff --git a/science/gromacs/pkg-plist b/science/gromacs/pkg-plist
index fae0baf67524..98114930daa5 100644
--- a/science/gromacs/pkg-plist
+++ b/science/gromacs/pkg-plist
@@ -22,17 +22,90 @@ include/gmxapi/session/resources.h
include/gmxapi/status.h
include/gmxapi/system.h
include/gmxapi/version.h
+%%LEGACY%%include/gromacs/analysisdata.h
+%%LEGACY%%include/gromacs/analysisdata/abstractdata.h
+%%LEGACY%%include/gromacs/analysisdata/analysisdata.h
+%%LEGACY%%include/gromacs/analysisdata/arraydata.h
+%%LEGACY%%include/gromacs/analysisdata/dataframe.h
+%%LEGACY%%include/gromacs/analysisdata/datamodule.h
+%%LEGACY%%include/gromacs/analysisdata/modules/average.h
+%%LEGACY%%include/gromacs/analysisdata/modules/displacement.h
+%%LEGACY%%include/gromacs/analysisdata/modules/histogram.h
+%%LEGACY%%include/gromacs/analysisdata/modules/lifetime.h
+%%LEGACY%%include/gromacs/analysisdata/modules/plot.h
+%%LEGACY%%include/gromacs/fileio/confio.h
+%%LEGACY%%include/gromacs/fileio/filetypes.h
+%%LEGACY%%include/gromacs/fileio/oenv.h
+%%LEGACY%%include/gromacs/fileio/pdbio.h
+%%LEGACY%%include/gromacs/fileio/tpxio.h
+%%LEGACY%%include/gromacs/fileio/trxio.h
include/gromacs/math/do_fit.h
include/gromacs/math/functions.h
include/gromacs/math/units.h
include/gromacs/math/utilities.h
include/gromacs/math/vec.h
include/gromacs/math/vectypes.h
+%%LEGACY%%include/gromacs/mdtypes/inputrec.h
+%%LEGACY%%include/gromacs/mdtypes/md_enums.h
+%%LEGACY%%include/gromacs/options.h
+%%LEGACY%%include/gromacs/options/abstractoption.h
+%%LEGACY%%include/gromacs/options/basicoptions.h
+%%LEGACY%%include/gromacs/options/filenameoption.h
+%%LEGACY%%include/gromacs/options/filenameoptionmanager.h
+%%LEGACY%%include/gromacs/options/ioptionsbehavior.h
+%%LEGACY%%include/gromacs/options/ioptionscontainer.h
+%%LEGACY%%include/gromacs/options/ioptionscontainerwithsections.h
+%%LEGACY%%include/gromacs/options/ivaluestore.h
+%%LEGACY%%include/gromacs/options/optionfiletype.h
+%%LEGACY%%include/gromacs/options/optionflags.h
+%%LEGACY%%include/gromacs/options/options.h
+%%LEGACY%%include/gromacs/options/timeunitmanager.h
+%%LEGACY%%include/gromacs/pbcutil/pbc.h
include/gromacs/restraint/restraintpotential.h
+%%LEGACY%%include/gromacs/selection.h
+%%LEGACY%%include/gromacs/selection/indexutil.h
+%%LEGACY%%include/gromacs/selection/nbsearch.h
+%%LEGACY%%include/gromacs/selection/position.h
+%%LEGACY%%include/gromacs/selection/selection.h
+%%LEGACY%%include/gromacs/selection/selectioncollection.h
+%%LEGACY%%include/gromacs/selection/selectionenums.h
+%%LEGACY%%include/gromacs/selection/selectionoption.h
+%%LEGACY%%include/gromacs/selection/selectionoptionbehavior.h
+%%LEGACY%%include/gromacs/selection/selectionoptionmanager.h
+%%LEGACY%%include/gromacs/topology/atomprop.h
+%%LEGACY%%include/gromacs/topology/atoms.h
+%%LEGACY%%include/gromacs/topology/block.h
+%%LEGACY%%include/gromacs/topology/forcefieldparameters.h
+%%LEGACY%%include/gromacs/topology/idef.h
+%%LEGACY%%include/gromacs/topology/ifunc.h
+%%LEGACY%%include/gromacs/topology/index.h
+%%LEGACY%%include/gromacs/topology/symtab.h
+%%LEGACY%%include/gromacs/topology/topology.h
+%%LEGACY%%include/gromacs/trajectory/trajectoryframe.h
+%%LEGACY%%include/gromacs/trajectoryanalysis.h
+%%LEGACY%%include/gromacs/trajectoryanalysis/analysismodule.h
+%%LEGACY%%include/gromacs/trajectoryanalysis/analysissettings.h
+%%LEGACY%%include/gromacs/trajectoryanalysis/cmdlinerunner.h
+%%LEGACY%%include/gromacs/trajectoryanalysis/topologyinformation.h
+%%LEGACY%%include/gromacs/utility/arrayref.h
include/gromacs/utility/basedefinitions.h
+%%LEGACY%%%%LEGACY%%include/gromacs/utility/baseversion.h
+%%LEGACY%%%%LEGACY%%include/gromacs/utility/classhelpers.h
include/gromacs/utility/current_function.h
+%%LEGACY%%include/gromacs/utility/enumerationhelpers.h
+%%LEGACY%%include/gromacs/utility/exceptions.h
+%%LEGACY%%include/gromacs/utility/fileptr.h
+%%LEGACY%%include/gromacs/utility/flags.h
+%%LEGACY%%include/gromacs/utility/futil.h
include/gromacs/utility/gmxassert.h
+%%LEGACY%%include/gromacs/utility/pleasecite.h
+%%LEGACY%%include/gromacs/utility/programcontext.h
+%%LEGACY%%include/gromacs/utility/range.h
include/gromacs/utility/real.h
+%%LEGACY%%include/gromacs/utility/smalloc.h
+%%LEGACY%%include/gromacs/utility/stringutil.h
+%%LEGACY%%include/gromacs/utility/unique_cptr.h
+%%LEGACY%%include/gromacs/version.h
lib/libgmxapi%%SUFFIX_MPI%%.so
lib/libgmxapi%%SUFFIX_MPI%%.so.0
lib/libgmxapi%%SUFFIX_MPI%%.so.0.1.0
@@ -62,6 +135,11 @@ share/cmake/gromacs%%SUFFIX_MPI%%%%SUFFIX_D%%/libgromacs.cmake
%%OPENCL%%%%DATADIR%%/opencl/nbnxn_ocl_kernels_fastgen.clh
%%OPENCL%%%%DATADIR%%/opencl/nbnxn_ocl_kernels_fastgen_add_twincut.clh
%%OPENCL%%%%DATADIR%%/opencl/vectype_ops.clh
+%%LEGACY%%%%DATADIR%%/template/CMakeLists.txt
+%%LEGACY%%%%DATADIR%%/template/Makefile.pkg
+%%LEGACY%%%%DATADIR%%/template/README
+%%LEGACY%%%%DATADIR%%/template/cmake/FindGROMACS.cmake
+%%LEGACY%%%%DATADIR%%/template/template.cpp
%%DATADIR%%/top/README
%%DATADIR%%/top/amber03.ff/aminoacids.arn
%%DATADIR%%/top/amber03.ff/aminoacids.c.tdb