aboutsummaryrefslogtreecommitdiff
path: root/science/h5utils
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2017-07-26 13:42:00 +0000
committerWen Heping <wen@FreeBSD.org>2017-07-26 13:42:00 +0000
commit2762b94d604f1b94096e10c22a444f68955d6f6b (patch)
treed9692d03e6d6646ac6982bd5c79dfa872c4cca9f /science/h5utils
parent8e7e7b1b84cd3ab4063a16ac89ad62bfe829bffd (diff)
downloadports-2762b94d604f1b94096e10c22a444f68955d6f6b.tar.gz
ports-2762b94d604f1b94096e10c22a444f68955d6f6b.zip
Notes
Diffstat (limited to 'science/h5utils')
-rw-r--r--science/h5utils/Makefile13
-rw-r--r--science/h5utils/distinfo5
-rw-r--r--science/h5utils/files/patch-configure.ac11
-rw-r--r--science/h5utils/files/patch-writepng.c42
-rw-r--r--science/h5utils/pkg-descr2
-rw-r--r--science/h5utils/pkg-plist4
6 files changed, 28 insertions, 49 deletions
diff --git a/science/h5utils/Makefile b/science/h5utils/Makefile
index 1372cadc24e7..a0aceb2c9b1f 100644
--- a/science/h5utils/Makefile
+++ b/science/h5utils/Makefile
@@ -2,17 +2,15 @@
# $FreeBSD$
PORTNAME= h5utils
-PORTVERSION= 1.12.1
-PORTREVISION= 7
+PORTVERSION= 1.13
CATEGORIES= science
-MASTER_SITES= http://ab-initio.mit.edu/${PORTNAME}/
MAINTAINER= aehlig@linta.de
COMMENT= Set of utilities for visualization and conversion of HDF5 format
LICENSE= MIT GPLv2
LICENSE_COMB= multi
-LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= YES
CFLAGS += -L${LOCALBASE}/lib -I${LOCALBASE}/include -lpthread
@@ -22,4 +20,11 @@ LIB_DEPENDS+= libhdf5.so:science/hdf5 \
libpng.so:graphics/png \
libmatheval.so:devel/libmatheval
+USES= autoreconf
+GNU_CONFIGURE= yes
+
+
+USE_GITHUB= yes
+GH_ACCOUNT= stevengj
+
.include <bsd.port.mk>
diff --git a/science/h5utils/distinfo b/science/h5utils/distinfo
index d3ab6dc973ca..5a39dfdcbe37 100644
--- a/science/h5utils/distinfo
+++ b/science/h5utils/distinfo
@@ -1,2 +1,3 @@
-SHA256 (h5utils-1.12.1.tar.gz) = 7290290ca5d5d4451d757a70c86baaa70d23a28edb09c951b6b77c22b924a38d
-SIZE (h5utils-1.12.1.tar.gz) = 156785
+TIMESTAMP = 1500963131
+SHA256 (stevengj-h5utils-1.13_GH0.tar.gz) = 894849f6d107b224bb1694029ad7d469695b0a6f47b564fe16c40f3d20c0b452
+SIZE (stevengj-h5utils-1.13_GH0.tar.gz) = 113735
diff --git a/science/h5utils/files/patch-configure.ac b/science/h5utils/files/patch-configure.ac
new file mode 100644
index 000000000000..82a53a1daa76
--- /dev/null
+++ b/science/h5utils/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2017-07-25 06:31:48 UTC
++++ configure.ac
+@@ -68,7 +68,7 @@ AC_CHECK_LIB(matheval, evaluator_get_var
+
+ if test $H5MATH = yes; then
+ MORE_H5UTILS="h5math\$(EXEEXT) $MORE_H5UTILS"
+- MORE_H5UTILS_MANS="h5math.1 $MORE_H5UTILS_MANS"
++ MORE_H5UTILS_MANS="doc/man/h5math.1 $MORE_H5UTILS_MANS"
+ else
+ AC_MSG_WARN([can't find libmatheval: won't be able to compile h5math])
+ fi
diff --git a/science/h5utils/files/patch-writepng.c b/science/h5utils/files/patch-writepng.c
deleted file mode 100644
index 42543c2938fe..000000000000
--- a/science/h5utils/files/patch-writepng.c
+++ /dev/null
@@ -1,42 +0,0 @@
-$NetBSD: patch-writepng.c,v 1.1 2011/02/01 09:05:31 wiz Exp $
-
-Fix build with png-1.5.
-
---- writepng.c.orig 2009-06-12 20:58:50.000000000 +0000
-+++ writepng.c
-@@ -240,6 +240,8 @@ void writepng(char *filename,
- double skewsin = sin(skew), skewcos = cos(skew);
- REAL minoverlay = 0, maxoverlay = 0;
- png_byte mask_byte;
-+ png_colorp palette = NULL;
-+
-
- /* we must use direct color for translucent overlays */
- if (overlay)
-@@ -309,7 +311,7 @@ void writepng(char *filename,
- }
- /* Set error handling. REQUIRED if you aren't supplying your own *
- * error hadnling functions in the png_create_write_struct() call. */
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- /* If we get here, we had a problem reading the file */
- fclose(fp);
- png_destroy_write_struct(&png_ptr, (png_infopp) NULL);
-@@ -334,8 +336,6 @@ void writepng(char *filename,
- PNG_INTERLACE_NONE,
- PNG_COMPRESSION_TYPE_BASE, PNG_FILTER_TYPE_BASE);
- else {
-- png_colorp palette;
--
- png_set_IHDR(png_ptr, info_ptr, width, height, 8 /* bit_depth */ ,
- PNG_COLOR_TYPE_PALETTE,
- PNG_INTERLACE_NONE,
-@@ -434,7 +434,7 @@ void writepng(char *filename,
- png_write_end(png_ptr, info_ptr);
-
- /* if you malloced the palette, free it here */
-- free(info_ptr->palette);
-+ free(palette);
-
- /* if you allocated any text comments, free them here */
-
diff --git a/science/h5utils/pkg-descr b/science/h5utils/pkg-descr
index 675cd1ba6885..26211f0d71f8 100644
--- a/science/h5utils/pkg-descr
+++ b/science/h5utils/pkg-descr
@@ -6,4 +6,4 @@ h5utils also includes programs to convert HDF5 datasets into the formats
required by other free visualization software (e.g. plain text, Vis5d,
and VTK).
-WWW: http://ab-initio.mit.edu/wiki/index.php/H5utils
+WWW: https://github.com/stevengj/h5utils
diff --git a/science/h5utils/pkg-plist b/science/h5utils/pkg-plist
index 2524dd0c4ef5..f6a4317d49c5 100644
--- a/science/h5utils/pkg-plist
+++ b/science/h5utils/pkg-plist
@@ -8,6 +8,8 @@ man/man1/h5math.1.gz
man/man1/h5topng.1.gz
man/man1/h5totxt.1.gz
man/man1/h5tovtk.1.gz
+%%DATADIR%%/colormaps/BrBG
+%%DATADIR%%/colormaps/RdBu
%%DATADIR%%/colormaps/autumn
%%DATADIR%%/colormaps/bluered
%%DATADIR%%/colormaps/bone
@@ -19,6 +21,7 @@ man/man1/h5tovtk.1.gz
%%DATADIR%%/colormaps/green
%%DATADIR%%/colormaps/hot
%%DATADIR%%/colormaps/hsv
+%%DATADIR%%/colormaps/inferno
%%DATADIR%%/colormaps/jet
%%DATADIR%%/colormaps/lines
%%DATADIR%%/colormaps/pink
@@ -26,6 +29,7 @@ man/man1/h5tovtk.1.gz
%%DATADIR%%/colormaps/spring
%%DATADIR%%/colormaps/summer
%%DATADIR%%/colormaps/vga
+%%DATADIR%%/colormaps/viridis
%%DATADIR%%/colormaps/winter
%%DATADIR%%/colormaps/yarg
%%DATADIR%%/colormaps/yellow