aboutsummaryrefslogtreecommitdiff
path: root/science/harminv
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-01-02 02:54:00 +0000
committerWen Heping <wen@FreeBSD.org>2010-01-02 02:54:00 +0000
commit085fe92c9327478b15a9dc42124eb4d384087f57 (patch)
tree0cdcf5c0285720626393943aa5df670bf4efd900 /science/harminv
parentd4b0f87dfc1fc50527806d6a3cd8eaa5bfd983d5 (diff)
downloadports-085fe92c9327478b15a9dc42124eb4d384087f57.tar.gz
ports-085fe92c9327478b15a9dc42124eb4d384087f57.zip
Harminv is a free program (and accompanying library) to solve the problem
of harmonic inversion - given a discrete-time, finite-length signal that consists of a sum of finitely-many sinusoids (possibly exponentially decaying) in a given bandwidth, it determines the frequencies, decay constants, amplitudes, and phases of those sinusoids. WWW: http://ab-initio.mit.edu/wiki/index.php/Harminv PR: ports/142154 Submitted by: Stas Timokhin <devel@stasyan.com>
Notes
Notes: svn path=/head/; revision=246972
Diffstat (limited to 'science/harminv')
-rw-r--r--science/harminv/Makefile36
-rw-r--r--science/harminv/distinfo3
-rw-r--r--science/harminv/files/patch-Makefile.in11
-rw-r--r--science/harminv/pkg-descr7
-rw-r--r--science/harminv/pkg-plist6
5 files changed, 63 insertions, 0 deletions
diff --git a/science/harminv/Makefile b/science/harminv/Makefile
new file mode 100644
index 000000000000..584e68aa69f3
--- /dev/null
+++ b/science/harminv/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: science/harminv
+# Date created: 26 Dec 2009
+# Whom: Stas Timokhin <devel@stasyan.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= harminv
+PORTVERSION= 1.3.1
+CATEGORIES= science
+MASTER_SITES= http://ab-initio.mit.edu/harminv/
+
+MAINTAINER= devel@stasyan.com
+COMMENT= Solver of harmonic inversion
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_FORTRAN= yes
+USE_GCC= 4.4+
+CPPFLAGS+= -I${LOCALBASE}/include
+LD_LIBRARY_PATH= -L${LOCALBASE}/lib -L/usr/lib
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LD_LIBRARY_PATH="${LD_LIBRARY_PATH}" LDFLAGS="${LDFLAGS}"
+USE_LDCONFIG= yes
+
+MAN1= harminv.1
+
+LIB_DEPENDS+= guile.20:${PORTSDIR}/lang/guile \
+ blas.2:${PORTSDIR}/math/blas \
+ lapack.4:${PORTSDIR}/math/lapack
+
+post-patch:
+ ${REINPLACE_CMD} -e 's#%%PKGDIR%%#${PREFIX}/libdata#g' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/science/harminv/distinfo b/science/harminv/distinfo
new file mode 100644
index 000000000000..97e1216d50f3
--- /dev/null
+++ b/science/harminv/distinfo
@@ -0,0 +1,3 @@
+MD5 (harminv-1.3.1.tar.gz) = d3f49f1c90856b3b2e8b77dc4a99c37a
+SHA256 (harminv-1.3.1.tar.gz) = 245778c16390c22850de3fb716c3db19514d40415ee3693293bfe59c66536583
+SIZE (harminv-1.3.1.tar.gz) = 327832
diff --git a/science/harminv/files/patch-Makefile.in b/science/harminv/files/patch-Makefile.in
new file mode 100644
index 000000000000..6c09d1937286
--- /dev/null
+++ b/science/harminv/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2010-01-02 09:36:55.000000000 +0800
++++ Makefile.in 2010-01-02 09:38:14.000000000 +0800
+@@ -221,7 +221,7 @@
+ lib_LTLIBRARIES = libharminv.la
+ include_HEADERS = harminv.h
+ dist_man_MANS = harminv.1
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = %%PKGDIR%%/pkgconfig
+ pkgconfig_DATA = harminv.pc
+ ACLOCAL_AMFLAGS = -I .
+ EXTRA_DIST = COPYRIGHT harminv.pc.in acx_blas.m4 acx_lapack.m4
diff --git a/science/harminv/pkg-descr b/science/harminv/pkg-descr
new file mode 100644
index 000000000000..4fcc8ff5d5e7
--- /dev/null
+++ b/science/harminv/pkg-descr
@@ -0,0 +1,7 @@
+Harminv is a free program (and accompanying library) to solve the problem
+of harmonic inversion - given a discrete-time, finite-length signal
+that consists of a sum of finitely-many sinusoids (possibly exponentially
+decaying) in a given bandwidth, it determines the frequencies, decay
+constants, amplitudes, and phases of those sinusoids.
+
+WWW: http://ab-initio.mit.edu/wiki/index.php/Harminv
diff --git a/science/harminv/pkg-plist b/science/harminv/pkg-plist
new file mode 100644
index 000000000000..f18372394a0d
--- /dev/null
+++ b/science/harminv/pkg-plist
@@ -0,0 +1,6 @@
+bin/harminv
+include/harminv.h
+lib/libharminv.a
+lib/libharminv.la
+libdata/pkgconfig/harminv.pc
+@dirrmtry libdata/pkgconfig