aboutsummaryrefslogtreecommitdiff
path: root/science/hdf5-110/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-07 16:03:16 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-07 16:03:16 +0000
commit9f76fc7c279337c70785676a5b50dc9749d28a95 (patch)
tree415ea5508af999d058391b55219464829862c5f5 /science/hdf5-110/Makefile
parentb63c215e57802cb23ea8b5f3a691946dd83bc1a2 (diff)
downloadports-9f76fc7c279337c70785676a5b50dc9749d28a95.tar.gz
ports-9f76fc7c279337c70785676a5b50dc9749d28a95.zip
Diffstat (limited to 'science/hdf5-110/Makefile')
-rw-r--r--science/hdf5-110/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/science/hdf5-110/Makefile b/science/hdf5-110/Makefile
index de07b0c1bdbb..3fa2fec7d3f8 100644
--- a/science/hdf5-110/Makefile
+++ b/science/hdf5-110/Makefile
@@ -1,5 +1,5 @@
PORTNAME= hdf5
-PORTVERSION= 1.10.9
+PORTVERSION= 1.10.10
CATEGORIES= science archivers graphics
MASTER_SITES= https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-${PORTVERSION:R}/${DISTNAME}/src/ \
LOCAL/sunpoet
@@ -14,6 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= compiler:c11 cpe libtool localbase tar:bzip2
+CFLAGS+= -D__LONG_LONG_SUPPORTED
CONFIGURE_ARGS= --enable-hl \
--enable-instrument \
--enable-strict-format-checks \
@@ -38,6 +39,7 @@ OPTIONS_DEFINE= DEBUG EXAMPLES FORTRAN SZIP
OPTIONS_RADIO= SUPPORT
OPTIONS_RADIO_SUPPORT= CXX PARALLEL
OPTIONS_DEFAULT=CXX SZIP
+OPTIONS_DEFAULT+=FORTRAN
OPTIONS_SUB= yes
PARALLEL_DESC= Parallel support
@@ -64,7 +66,7 @@ post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e 's|libhdf5|libhdf5${PKGNAMESUFFIX}|g' \
-e 's|libhdf5${PKGNAMESUFFIX}.settings|libhdf5.settings|g'
- @${REINPLACE_CMD} -e 's|libhdf5|libhdf5${PKGNAMESUFFIX}|g' ${WRKSRC}/test/testlibinfo.sh.in
+ @${REINPLACE_CMD} -e 's|libhdf5|libhdf5${PKGNAMESUFFIX}|g' ${WRKSRC}/test/test_libinfo.sh.in
post-install:
${MV} ${STAGEDIR}${PREFIX}/lib/libhdf5.settings ${STAGEDIR}${PREFIX}/lib/libhdf5${PKGNAMESUFFIX}.settings