aboutsummaryrefslogtreecommitdiff
path: root/science/hdf5
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-04-20 20:42:39 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-04-20 20:42:39 +0000
commit9a1f45d861fd9951b415a972e56137a34b4bd1be (patch)
tree0d93d8b3173ba1999f1a826b0d19eaa1e23c4444 /science/hdf5
parentba20428c5fdd737d85129b8c53e1219a5e2a2d09 (diff)
downloadports-9a1f45d861fd9951b415a972e56137a34b4bd1be.tar.gz
ports-9a1f45d861fd9951b415a972e56137a34b4bd1be.zip
Notes
Diffstat (limited to 'science/hdf5')
-rw-r--r--science/hdf5/Makefile22
-rw-r--r--science/hdf5/distinfo4
-rw-r--r--science/hdf5/pkg-plist45
3 files changed, 31 insertions, 40 deletions
diff --git a/science/hdf5/Makefile b/science/hdf5/Makefile
index d4ae97cb768f..a8dbdb981970 100644
--- a/science/hdf5/Makefile
+++ b/science/hdf5/Makefile
@@ -2,27 +2,22 @@
# $FreeBSD$
PORTNAME= hdf5
-PORTVERSION= 1.8.15
-DISTVERSIONSUFFIX= -patch1
-PORTREVISION= 1
+PORTVERSION= 1.10.0
CATEGORIES= science archivers graphics
-MASTER_SITES= http://www.hdfgroup.org/ftp/HDF5/current/src/ \
- ftp://ftp.hdfgroup.org/HDF5/current/src/ \
- http://www.hdfgroup.org/ftp/HDF5/releases/${DISTNAME}/src/ \
- ftp://ftp.hdfgroup.org/HDF5/releases/${DISTNAME}/src/ \
+MASTER_SITES= https://www.hdfgroup.org/ftp/HDF5/releases/hdf5-${PORTVERSION:R}/${DISTNAME}/src/ \
+ ftp://www.hdfgroup.org/HDF5/releases/hdf5-${PORTVERSION:R}/${DISTNAME}/src/ \
LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Hierarchical Data Format library (from NCSA)
LICENSE= BSD4CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS_INSTALL= hdf-4.[0-9]* hdf5-1.6.[0-9]*
-PORTSCOUT= skipv:1.8.15-patch1
-
OPTIONS_DEFINE= DEBUG EXAMPLES FORTRAN SZIP
-#OPTIONS_DEFAULT=SZIP
+OPTIONS_DEFAULT=SZIP
OPTIONS_SUB= yes
CONFIGURE_ARGS= --enable-cxx \
@@ -41,11 +36,10 @@ PORTEXAMPLES= *
NOT_FOR_ARCHS= sparc64
NOT_FOR_ARCHS_REASON= does not compile
-DEBUG_CONFIGURE_OFF= --enable-production
-DEBUG_CONFIGURE_ON= --disable-production --enable-debug=all
+DEBUG_CONFIGURE_OFF= --enable-build-mode=production
+DEBUG_CONFIGURE_ON= --enable-build-mode=debug
+FORTRAN_CONFIGURE_ENABLE= fortran
FORTRAN_CONFIGURE_ENV= F9X=${FC}
-FORTRAN_CONFIGURE_OFF= --disable-fortran --disable-fortran2003
-FORTRAN_CONFIGURE_ON= --enable-fortran --enable-fortran2003
FORTRAN_USES= fortran
SZIP_CONFIGURE_ON= --with-szlib=${LOCALBASE}
SZIP_LIB_DEPENDS= libsz.so:science/szip
diff --git a/science/hdf5/distinfo b/science/hdf5/distinfo
index 5d54379cc3a1..ff09f8e78c8e 100644
--- a/science/hdf5/distinfo
+++ b/science/hdf5/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hdf5-1.8.15-patch1.tar.bz2) = a5afc630c4443547fff15e9637b5b10404adbed4c00206d89517d32d6668fb32
-SIZE (hdf5-1.8.15-patch1.tar.bz2) = 10006036
+SHA256 (hdf5-1.10.0.tar.bz2) = 31ff70dc7c7317066ab3bda3eec4498a8b099c69c1271b008ed3df388e743d28
+SIZE (hdf5-1.10.0.tar.bz2) = 11239053
diff --git a/science/hdf5/pkg-plist b/science/hdf5/pkg-plist
index 243b7b74cd1e..64807b2e02cf 100644
--- a/science/hdf5/pkg-plist
+++ b/science/hdf5/pkg-plist
@@ -2,11 +2,13 @@ bin/gif2h5
bin/h52gif
bin/h5c++
bin/h5cc
+bin/h5clear
bin/h5copy
bin/h5debug
bin/h5diff
bin/h5dump
%%FORTRAN%%bin/h5fc
+bin/h5format_convert
bin/h5import
bin/h5jam
bin/h5ls
@@ -17,6 +19,7 @@ bin/h5repack
bin/h5repart
bin/h5stat
bin/h5unjam
+bin/h5watch
include/H5ACpublic.h
include/H5AbstractDs.h
include/H5Apublic.h
@@ -63,12 +66,14 @@ include/H5IdComponent.h
include/H5Include.h
include/H5IntType.h
include/H5Ipublic.h
+include/H5LDpublic.h
include/H5LTpublic.h
include/H5Library.h
include/H5Location.h
include/H5Lpublic.h
include/H5MMpublic.h
include/H5Object.h
+include/H5OcreatProp.h
include/H5Opublic.h
include/H5PLextern.h
include/H5PLpublic.h
@@ -91,37 +96,29 @@ include/H5overflow.h
include/H5pubconf.h
include/H5public.h
include/H5version.h
-%%FORTRAN%%include/h5_dble_interface.mod
+%%FORTRAN%%include/h5_gen.mod
%%FORTRAN%%include/h5a.mod
-%%FORTRAN%%include/h5a_provisional.mod
%%FORTRAN%%include/h5d.mod
-%%FORTRAN%%include/h5d_provisional.mod
%%FORTRAN%%include/h5ds.mod
%%FORTRAN%%include/h5e.mod
-%%FORTRAN%%include/h5e_provisional.mod
%%FORTRAN%%include/h5f.mod
-%%FORTRAN%%include/h5f_provisional.mod
+%%FORTRAN%%include/h5fortkit.mod
%%FORTRAN%%include/h5fortran_types.mod
%%FORTRAN%%include/h5g.mod
%%FORTRAN%%include/h5global.mod
%%FORTRAN%%include/h5i.mod
%%FORTRAN%%include/h5im.mod
%%FORTRAN%%include/h5l.mod
-%%FORTRAN%%include/h5l_provisional.mod
%%FORTRAN%%include/h5lib.mod
-%%FORTRAN%%include/h5lib_provisional.mod
%%FORTRAN%%include/h5lt.mod
+%%FORTRAN%%include/h5lt_const.mod
%%FORTRAN%%include/h5o.mod
-%%FORTRAN%%include/h5o_provisional.mod
%%FORTRAN%%include/h5p.mod
-%%FORTRAN%%include/h5p_provisional.mod
%%FORTRAN%%include/h5r.mod
-%%FORTRAN%%include/h5r_provisional.mod
%%FORTRAN%%include/h5s.mod
%%FORTRAN%%include/h5t.mod
-%%FORTRAN%%include/h5t_provisional.mod
%%FORTRAN%%include/h5tb.mod
-%%FORTRAN%%include/h5test_kind_storage_size_mod.mod
+%%FORTRAN%%include/h5tb_const.mod
%%FORTRAN%%include/h5z.mod
include/hdf5.h
%%FORTRAN%%include/hdf5.mod
@@ -129,25 +126,25 @@ include/hdf5_hl.h
lib/libhdf5.a
lib/libhdf5.settings
lib/libhdf5.so
-lib/libhdf5.so.10
-lib/libhdf5.so.10.0.1
+lib/libhdf5.so.100
+lib/libhdf5.so.100.0.0
lib/libhdf5_cpp.a
lib/libhdf5_cpp.so
-lib/libhdf5_cpp.so.10
-lib/libhdf5_cpp.so.10.0.1
+lib/libhdf5_cpp.so.100
+lib/libhdf5_cpp.so.100.0.0
%%FORTRAN%%lib/libhdf5_fortran.a
%%FORTRAN%%lib/libhdf5_fortran.so
-%%FORTRAN%%lib/libhdf5_fortran.so.10
-%%FORTRAN%%lib/libhdf5_fortran.so.10.0.1
+%%FORTRAN%%lib/libhdf5_fortran.so.100
+%%FORTRAN%%lib/libhdf5_fortran.so.100.0.0
lib/libhdf5_hl.a
lib/libhdf5_hl.so
-lib/libhdf5_hl.so.10
-lib/libhdf5_hl.so.10.0.1
+lib/libhdf5_hl.so.100
+lib/libhdf5_hl.so.100.0.0
lib/libhdf5_hl_cpp.a
lib/libhdf5_hl_cpp.so
-lib/libhdf5_hl_cpp.so.10
-lib/libhdf5_hl_cpp.so.10.0.1
+lib/libhdf5_hl_cpp.so.100
+lib/libhdf5_hl_cpp.so.100.0.0
%%FORTRAN%%lib/libhdf5hl_fortran.a
%%FORTRAN%%lib/libhdf5hl_fortran.so
-%%FORTRAN%%lib/libhdf5hl_fortran.so.10
-%%FORTRAN%%lib/libhdf5hl_fortran.so.10.0.1
+%%FORTRAN%%lib/libhdf5hl_fortran.so.100
+%%FORTRAN%%lib/libhdf5hl_fortran.so.100.0.0