aboutsummaryrefslogtreecommitdiff
path: root/science/hdf
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-18 15:25:37 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-18 15:25:37 +0000
commit03cb6183c5e041a06e569599e607b1a50429af18 (patch)
treee65cdf81b6ee6e26fa9f749061a2767f6c43d366 /science/hdf
parent7c152f8a0526afbbb4eadb72f8167a8ddd853603 (diff)
downloadports-03cb6183c5e041a06e569599e607b1a50429af18.tar.gz
ports-03cb6183c5e041a06e569599e607b1a50429af18.zip
Notes
Diffstat (limited to 'science/hdf')
-rw-r--r--science/hdf/Makefile28
-rw-r--r--science/hdf/distinfo4
-rw-r--r--science/hdf/files/patch-hdf-examples-Makefile.in13
-rw-r--r--science/hdf/files/patch-hdf-fortran-examples-Makefile.in11
-rw-r--r--science/hdf/files/patch-hdf-src-Makefile.in (renamed from science/hdf/files/patch-hdf__src__Makefile.in)18
-rw-r--r--science/hdf/files/patch-mfhdf-examples-Makefile.in11
-rw-r--r--science/hdf/files/patch-mfhdf-fortran-examples-Makefile.in11
-rw-r--r--science/hdf/files/patch-mfhdf-libsrc-Makefile.in (renamed from science/hdf/files/patch-mfhdf__libsrc__Makefile.in)18
-rw-r--r--science/hdf/pkg-descr32
-rw-r--r--science/hdf/pkg-plist6
10 files changed, 95 insertions, 57 deletions
diff --git a/science/hdf/Makefile b/science/hdf/Makefile
index 41bd19b4c239..df05283de599 100644
--- a/science/hdf/Makefile
+++ b/science/hdf/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= hdf
-DISTVERSION= 4.2.8
-PORTREVISION= 4
+PORTVERSION= 4.2.11
PORTEPOCH= 1
CATEGORIES= science archivers graphics
-MASTER_SITES= http://www.hdfgroup.org/ftp/HDF/releases/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${PORTNAME:tu}${PORTVERSION}/src/
+MASTER_SITES= http://www.hdfgroup.org/ftp/HDF/releases/HDF${PORTVERSION}/src/ \
+ ftp://ftp.hdfgroup.org/HDF/releases/HDF${PORTVERSION}/src/
MAINTAINER= ports@FreeBSD.org
COMMENT= Hierarchical Data Format library (from NCSA)
@@ -18,25 +17,24 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
CONFLICTS= netcdf-*
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-jpeg="${LOCALBASE}" \
- --with-szlib="${LOCALBASE}" \
- --enable-shared
+CONFIGURE_ARGS= --enable-shared --with-jpeg=${LOCALBASE} --with-szlib=${LOCALBASE}
INSTALL_TARGET= install-strip
-USES= fortran libtool tar:bzip2
USE_LDCONFIG= yes
+USES= fortran libtool tar:bzip2
+
+PORTDATA= *
+PORTEXAMPLES= *
BROKEN_powerpc= Does not compile on powerpc
post-patch:
- @${REINPLACE_CMD} -e \
- '/PROD_/s|=.*|=""|' ${WRKSRC}/config/freebsd
+ @${REINPLACE_CMD} -e '/PROD_/ s|=.*|=""|' ${WRKSRC}/config/freebsd
post-install:
- ${INSTALL_MAN} ${WRKSRC}/man/hdfunpac.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/man/gr_chunk.3 ${STAGEDIR}${MAN3PREFIX}/man/man3
+ ${INSTALL_MAN} ${WRKSRC}/man/hdfunpac.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/man/gr_chunk.3 ${STAGEDIR}${MAN3PREFIX}/man/man3/
-check regression-test test: build
- @(cd ${WRKSRC}/hdf/test && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
- ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+regression-test test: build
+ cd ${WRKSRC}/hdf/test/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
.include <bsd.port.mk>
diff --git a/science/hdf/distinfo b/science/hdf/distinfo
index 08fab9c0bd35..de47ed8f66f0 100644
--- a/science/hdf/distinfo
+++ b/science/hdf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hdf-4.2.8.tar.bz2) = e8a94ae2c838007ccdd55bb3cd9684adba3ded367c09803ffc84a2704f83c00f
-SIZE (hdf-4.2.8.tar.bz2) = 3027253
+SHA256 (hdf-4.2.11.tar.bz2) = bb0e900b8cc6bc89a5730abc97e654e7705e8e1fbc4e0d4477f417822428d99b
+SIZE (hdf-4.2.11.tar.bz2) = 3173535
diff --git a/science/hdf/files/patch-hdf-examples-Makefile.in b/science/hdf/files/patch-hdf-examples-Makefile.in
new file mode 100644
index 000000000000..85f4a1451715
--- /dev/null
+++ b/science/hdf/files/patch-hdf-examples-Makefile.in
@@ -0,0 +1,13 @@
+--- hdf/examples/Makefile.in.orig 2015-02-10 00:43:49.000000000 +0800
++++ hdf/examples/Makefile.in 2015-03-16 23:05:52.348877136 +0800
+@@ -530,8 +530,8 @@
+ INSTALL_TOP_FILES = README
+
+ # Where to install example files
+-EXAMPLEDIR = $(prefix)/examples/c
+-EXAMPLETOPDIR = $(prefix)/examples
++EXAMPLEDIR = $(DESTDIR)$(prefix)/share/examples/hdf/c
++EXAMPLETOPDIR = $(DESTDIR)$(prefix)/share/examples/hdf
+ DISTCLEANFILES = *.chkexe *.chklog
+ @BUILD_SHARED_SZIP_CONDITIONAL_TRUE@LD_LIBRARY_PATH = $(LL_PATH)
+
diff --git a/science/hdf/files/patch-hdf-fortran-examples-Makefile.in b/science/hdf/files/patch-hdf-fortran-examples-Makefile.in
new file mode 100644
index 000000000000..5a3e51d42b56
--- /dev/null
+++ b/science/hdf/files/patch-hdf-fortran-examples-Makefile.in
@@ -0,0 +1,11 @@
+--- hdf/fortran/examples/Makefile.in.orig 2015-02-10 00:43:49.000000000 +0800
++++ hdf/fortran/examples/Makefile.in 2015-03-16 23:41:52.776730245 +0800
+@@ -525,7 +525,7 @@
+ INSTALL_SCRIPT_FILES = run-fortran-ex.sh
+
+ # Where to install Fortran example files
+-EXAMPLEDIR = $(prefix)/examples/fortran
++EXAMPLEDIR = $(DESTDIR)$(prefix)/share/hdf/examples/fortran
+ DISTCLEANFILES = *.chkexe *.chklog
+ @BUILD_SHARED_SZIP_CONDITIONAL_TRUE@LD_LIBRARY_PATH = $(LL_PATH)
+
diff --git a/science/hdf/files/patch-hdf__src__Makefile.in b/science/hdf/files/patch-hdf-src-Makefile.in
index 2e2a080ebc0d..64cd97670426 100644
--- a/science/hdf/files/patch-hdf__src__Makefile.in
+++ b/science/hdf/files/patch-hdf-src-Makefile.in
@@ -1,6 +1,6 @@
---- hdf/src/Makefile.in.orig 2012-08-07 13:11:36.000000000 +0900
-+++ hdf/src/Makefile.in 2012-08-14 21:08:53.000000000 +0900
-@@ -187,7 +187,7 @@
+--- hdf/src/Makefile.in.orig 2015-02-10 00:43:49.000000000 +0800
++++ hdf/src/Makefile.in 2015-03-16 23:48:46.316696873 +0800
+@@ -296,7 +296,7 @@
INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
LD = @LD@
@@ -9,12 +9,12 @@
LEX = @LEX@
LIBOBJS = @LIBOBJS@
LIBS = @LIBS@
-@@ -290,8 +290,6 @@
- CP = cp
- H4CC = $(bindir)/h4cc
- H4FC = $(bindir)/h4fc
+@@ -408,8 +408,6 @@
+ LIBMFHDF = $(top_builddir)/mfhdf/libsrc/libmfhdf.la
+ H4CC = ${DESTDIR}$(bindir)/h4cc
+ H4FC = ${DESTDIR}$(bindir)/h4fc
-@HDF_BUILD_XDR_TRUE@XDR_ADD = -R$(abs_top_builddir)/mfhdf/xdr/.libs
-@HDF_BUILD_SHARED_TRUE@AM_LDFLAGS = -R$(abs_top_builddir)/mfhdf/libsrc/.libs -R$(abs_top_builddir)/hdf/src/.libs $(XDR_ADD)
ACLOCAL_AMFLAGS = "-I m4"
- lib_LTLIBRARIES = libdf.la
- FSOURCES = df24ff.f dfanf.c dfanff.f dff.c dfff.f dfpf.c dfpff.f dfr8f.c \
+
+ # .chkexe files are used to mark tests that have run successfully.
diff --git a/science/hdf/files/patch-mfhdf-examples-Makefile.in b/science/hdf/files/patch-mfhdf-examples-Makefile.in
new file mode 100644
index 000000000000..8fb080a5c523
--- /dev/null
+++ b/science/hdf/files/patch-mfhdf-examples-Makefile.in
@@ -0,0 +1,11 @@
+--- mfhdf/examples/Makefile.in.orig 2015-02-10 00:43:50.000000000 +0800
++++ mfhdf/examples/Makefile.in 2015-03-16 23:43:17.287721940 +0800
+@@ -507,7 +507,7 @@
+ SD_get_info.c SD_find_sds_by_name.c SD_set_get_dim_info.c \
+ SD_dimscale_vs_sds.c SD_set_attr.c SD_get_attr.c SD_chunking_example.c
+
+-EXAMPLEDIR = $(prefix)/examples/c
++EXAMPLEDIR = $(DESTDIR)$(prefix)/share/examples/hdf/c
+ DISTCLEANFILES = *.chklog *.chkexe .deps
+ @BUILD_SHARED_SZIP_CONDITIONAL_TRUE@LD_LIBRARY_PATH = $(LL_PATH)
+
diff --git a/science/hdf/files/patch-mfhdf-fortran-examples-Makefile.in b/science/hdf/files/patch-mfhdf-fortran-examples-Makefile.in
new file mode 100644
index 000000000000..8687c46b5547
--- /dev/null
+++ b/science/hdf/files/patch-mfhdf-fortran-examples-Makefile.in
@@ -0,0 +1,11 @@
+--- mfhdf/fortran/examples/Makefile.in.orig 2015-02-10 00:43:50.000000000 +0800
++++ mfhdf/fortran/examples/Makefile.in 2015-03-16 23:44:30.846716566 +0800
+@@ -511,7 +511,7 @@
+
+
+ # Where to install example files
+-EXAMPLEDIR = $(prefix)/examples/fortran
++EXAMPLEDIR = $(DESTDIR)$(prefix)/share/examples/hdf/fortran
+ DISTCLEANFILES = *.chkexe *.chklog
+ @BUILD_SHARED_SZIP_CONDITIONAL_TRUE@LD_LIBRARY_PATH = $(LL_PATH)
+
diff --git a/science/hdf/files/patch-mfhdf__libsrc__Makefile.in b/science/hdf/files/patch-mfhdf-libsrc-Makefile.in
index 5d4fb5c78576..e9ca8914a248 100644
--- a/science/hdf/files/patch-mfhdf__libsrc__Makefile.in
+++ b/science/hdf/files/patch-mfhdf-libsrc-Makefile.in
@@ -1,6 +1,6 @@
---- mfhdf/libsrc/Makefile.in.orig 2012-08-07 13:11:12.000000000 +0900
-+++ mfhdf/libsrc/Makefile.in 2012-08-14 21:08:58.000000000 +0900
-@@ -161,7 +161,7 @@
+--- mfhdf/libsrc/Makefile.in.orig 2015-02-10 00:43:51.000000000 +0800
++++ mfhdf/libsrc/Makefile.in 2015-03-16 23:48:46.325704247 +0800
+@@ -272,7 +272,7 @@
INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
LD = @LD@
@@ -9,12 +9,12 @@
LEX = @LEX@
LIBOBJS = @LIBOBJS@
LIBS = @LIBS@
-@@ -264,8 +264,6 @@
- CP = cp
- H4CC = $(bindir)/h4cc
- H4FC = $(bindir)/h4fc
+@@ -384,8 +384,6 @@
+ LIBMFHDF = $(top_builddir)/mfhdf/libsrc/libmfhdf.la
+ H4CC = ${DESTDIR}$(bindir)/h4cc
+ H4FC = ${DESTDIR}$(bindir)/h4fc
-@HDF_BUILD_XDR_TRUE@XDR_ADD = -R$(abs_top_builddir)/mfhdf/xdr/.libs
-@HDF_BUILD_SHARED_TRUE@AM_LDFLAGS = -R$(abs_top_builddir)/mfhdf/libsrc/.libs -R$(abs_top_builddir)/hdf/src/.libs $(XDR_ADD)
ACLOCAL_AMFLAGS = "-I m4"
- INCLUDES = -I$(top_srcdir)/hdf/src \
- -I$(top_srcdir)/mfhdf/libsrc
+
+ # .chkexe files are used to mark tests that have run successfully.
diff --git a/science/hdf/pkg-descr b/science/hdf/pkg-descr
index 065c8914e037..7d41fbe24a52 100644
--- a/science/hdf/pkg-descr
+++ b/science/hdf/pkg-descr
@@ -1,22 +1,16 @@
-From HDF's manpage:
+HDF4 (originally known as HDF) is a file format for storing scientific data and
+a software library that provides high-level APIs and a low-level data interface.
- hdf - Hierarchical Data Format library
-
-Description:
- HDF is a multi-object file format that facilitates the
- transfer of various types of scientific data between
- machines and operating systems. Machines currently sup-
- ported include the Cray, Convex, HP, Vax, Sun, IBM
- RS/6000, Silicon Graphics, Macintosh, and IBM PC comput-
- ers. HDF allows self-definitions of data content and easy
- extensibility for future enhancements or compatibility
- with other standard formats. HDF includes Fortran and C
- calling interfaces,and utilities to prepare raw image of
- data files or for use with other NCSA software. The HDF
- library contains interfaces for storing and retrieving
- compressed or uncompressed 8-bit and 24-bit raster images
- with palettes, n-Dimensional scientific datasets and
- binary tables. An interface is also included that allows
- arbitray grouping of other HDF objects.
+HDF technologies at present include two data management formats (HDF4 and HDF5)
+and libraries, a modular data browser/editor, associated tools and utilities,
+and a conversion library. Both HDF4 and HDF5 were designed to be a general
+scientific format, adaptable to virtually any scientific or engineering
+application, and also have been used successfully in non-technical areas. The
+Open Source format is a key technological foundation for HDF core technologies.
+It allows users to collaborate with The HDF Group regarding functionality
+requirements and permits users' experience and knowledge to be incorporated into
+the HDF product when appropriate. It also permits users and organizations
+without adequate technology resources to use a sophisticated and robust data
+management tool for no charge.
WWW: http://www.hdfgroup.org/products/hdf4/
diff --git a/science/hdf/pkg-plist b/science/hdf/pkg-plist
index 87438b88a5f5..9c3d6a6b5f04 100644
--- a/science/hdf/pkg-plist
+++ b/science/hdf/pkg-plist
@@ -91,7 +91,7 @@ lib/libmfhdf.so
lib/libmfhdf.so.3
lib/libmfhdf.so.3.0.0
man/man1/hdf.1.gz
-man/man1/hdfunpac.1.gz
-man/man1/ncdump.1.gz
-man/man1/ncgen.1.gz
+man/man1/hdfunpac.1.gz
+man/man1/ncdump.1.gz
+man/man1/ncgen.1.gz
man/man3/gr_chunk.3.gz