aboutsummaryrefslogtreecommitdiff
path: root/science/hdf
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-12-27 16:55:28 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-12-27 16:55:28 +0000
commitf49d65ec2b7049e13207227280a89b6d72e787d1 (patch)
treea6bc9210d8e7826216924828c04b3e51f331e5d0 /science/hdf
parent2a51b2182ad0b57bacbb854e03d7ee3be79c35b4 (diff)
downloadports-f49d65ec2b7049e13207227280a89b6d72e787d1.tar.gz
ports-f49d65ec2b7049e13207227280a89b6d72e787d1.zip
Notes
Diffstat (limited to 'science/hdf')
-rw-r--r--science/hdf/Makefile22
-rw-r--r--science/hdf/pkg-plist5
2 files changed, 12 insertions, 15 deletions
diff --git a/science/hdf/Makefile b/science/hdf/Makefile
index 6b6c7225085c..e177abb71240 100644
--- a/science/hdf/Makefile
+++ b/science/hdf/Makefile
@@ -12,38 +12,30 @@ MASTER_SITE_SUBDIR= ${PORTNAME:U}${PORTVERSION}/src/
MAINTAINER= ports@FreeBSD.org
COMMENT= Hierarchical Data Format library (from NCSA)
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- sz:${PORTSDIR}/science/szip
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libsz.so:${PORTSDIR}/science/szip
CONFLICTS= netcdf-*
+USES= fortran
USE_BZIP2= yes
-USE_FORTRAN= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-jpeg="${LOCALBASE}" \
--with-szlib="${LOCALBASE}" \
--enable-shared
USE_LDCONFIG= yes
-MAN1= hdf.1 hdfunpac.1 ncdump.1 ncgen.1
-MAN3= gr_chunk.3
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc
-.endif
+BROKEN_powerpc= Does not compile on powerpc
post-patch:
@${REINPLACE_CMD} -e \
'/PROD_/s|=.*|=""|' ${WRKSRC}/config/freebsd
post-install:
- ${INSTALL_MAN} ${WRKSRC}/man/hdfunpac.1 ${MAN1PREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/man/gr_chunk.3 ${MAN3PREFIX}/man/man3
+ ${INSTALL_MAN} ${WRKSRC}/man/hdfunpac.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/man/gr_chunk.3 ${STAGEDIR}${MAN3PREFIX}/man/man3
check regression-test test: build
${MAKE} -C ${WRKSRC}/hdf/test check
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/hdf/pkg-plist b/science/hdf/pkg-plist
index 20e1eb275db1..5d4e1faeb518 100644
--- a/science/hdf/pkg-plist
+++ b/science/hdf/pkg-plist
@@ -90,3 +90,8 @@ lib/libmfhdf.a
lib/libmfhdf.la
lib/libmfhdf.so
lib/libmfhdf.so.3
+man/man1/hdf.1.gz
+man/man1/hdfunpac.1.gz
+man/man1/ncdump.1.gz
+man/man1/ncgen.1.gz
+man/man3/gr_chunk.3.gz