aboutsummaryrefslogtreecommitdiff
path: root/science/healpix/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-01-28 09:33:12 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-01-28 09:33:12 +0000
commit5208f41bde16bfce55afb75b2ce6aa192603f230 (patch)
tree9c7f3c93c3e9741c85dd6d47510b6b5da20eb56f /science/healpix/Makefile
parent8943d08100fd394bbf04a18c204319c597367906 (diff)
downloadports-5208f41bde16bfce55afb75b2ce6aa192603f230.tar.gz
ports-5208f41bde16bfce55afb75b2ce6aa192603f230.zip
Notes
Diffstat (limited to 'science/healpix/Makefile')
-rw-r--r--science/healpix/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/science/healpix/Makefile b/science/healpix/Makefile
new file mode 100644
index 000000000000..ef78469e1ddb
--- /dev/null
+++ b/science/healpix/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= healpix
+DISTVERSION= 3.50
+DISTVERSIONSUFFIX= _2018Dec10
+CATEGORIES= science
+MASTER_SITES= SF/${PORTNAME}/Healpix_${DISTVERSION}/
+DISTNAME= Healpix_${DISTVERSIONFULL}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Software for pixelization, visualization, etc of data on the sphere
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
+ libcurl.so:ftp/curl
+
+FLAVORS= cxx c
+FLAVOR?= ${FLAVORS:[1]}
+c_PKGNAMESUFFIX= -c
+cxx_PLIST= ${.CURDIR}/pkg-plist-cxx
+c_PLIST= ${.CURDIR}/pkg-plist-c
+
+USES= autoreconf gmake libtool pkgconfig
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/Healpix_${DISTVERSION}
+AUTORECONF_WRKSRC= ${WRKSRC}/src/${FLAVOR:S/^c$/C/}/autotools
+CONFIGURE_WRKSRC= ${AUTORECONF_WRKSRC}
+BUILD_WRKSRC= ${AUTORECONF_WRKSRC}
+INSTALL_WRKSRC= ${AUTORECONF_WRKSRC}
+
+.include <bsd.port.mk>