aboutsummaryrefslogtreecommitdiff
path: root/science/hypre
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2017-06-08 03:22:39 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2017-06-08 03:22:39 +0000
commit16600d0c13ebb140a18e1e559ddf3ae9c0ed9f6d (patch)
tree644d8f4522e41375f690ddf9bda015b0596caa35 /science/hypre
parentfb0bb89695700709462792c4d47e4da9dbe8eaa6 (diff)
downloadports-16600d0c13ebb140a18e1e559ddf3ae9c0ed9f6d.tar.gz
ports-16600d0c13ebb140a18e1e559ddf3ae9c0ed9f6d.zip
New port, science/hypre: Scalable Linear Solvers and Multigrid Methods
WWW: http://www.llnl.gov/casc/hypre/ PR: 219709 Submitted by: pfg (maintainer) Differential Revision: https://reviews.freebsd.org/D11048
Notes
Notes: svn path=/head/; revision=442906
Diffstat (limited to 'science/hypre')
-rw-r--r--science/hypre/Makefile53
-rw-r--r--science/hypre/distinfo3
-rw-r--r--science/hypre/pkg-descr7
-rw-r--r--science/hypre/pkg-plist79
4 files changed, 142 insertions, 0 deletions
diff --git a/science/hypre/Makefile b/science/hypre/Makefile
new file mode 100644
index 000000000000..96f9cb75f679
--- /dev/null
+++ b/science/hypre/Makefile
@@ -0,0 +1,53 @@
+# Created by: Pedro Giffuni
+# $FreeBSD$
+
+PORTNAME= hypre
+DISTVERSION= 2.11.2
+CATEGORIES= science
+MASTER_SITES= https://computation.llnl.gov/projects/hypre-scalable-linear-solvers-multigrid-methods/download/
+
+MAINTAINER= pfg@FreeBSD.org
+COMMENT= Scalable Linear Solvers and Multigrid Methods
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKDIR}/${DISTNAME}/COPYING.LESSER
+
+USES= blaslapack fortran localbase
+
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --with-blas --with-blas-lib=${BLASLIB} \
+ --with-lapack --with-lapack-lib=${LAPACKLIB} \
+ --enable-shared
+CONFIGURE_ENV= CC=mpicc CXX=mpicxx
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SINGLE= MPI
+OPTIONS_SINGLE_MPI= MPICH2 OPENMPI
+OPTIONS_DEFAULT= MPICH2
+
+MPICH2_LIB_DEPENDS= libmpich.so.8:net/mpich2
+OPENMPI_LIB_DEPENDS= libmpi.so:net/openmpi
+
+.ifdef MAINTAINER_MODE
+TEST_TARGET= check
+.endif
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/hypre/include/* ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_LIB} ${WRKSRC}/hypre/lib/libHYPRE-2.11.2.so \
+ ${STAGEDIR}${PREFIX}/lib/libHYPRE.so.2.11
+ ${RLN} ${STAGEDIR}${PREFIX}/lib/libHYPRE.so.2.11 \
+ ${STAGEDIR}${PREFIX}/lib/libHYPRE.so.2
+ ${RLN} ${STAGEDIR}${PREFIX}/lib/libHYPRE.so.2.11 \
+ ${STAGEDIR}${PREFIX}/lib/libHYPRE.so
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/docs/*.pdf \
+ ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/science/hypre/distinfo b/science/hypre/distinfo
new file mode 100644
index 000000000000..a8dc726cc31c
--- /dev/null
+++ b/science/hypre/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1496033213
+SHA256 (hypre-2.11.2.tar.gz) = 25b6c1226411593f71bb5cf3891431afaa8c3fd487bdfe4faeeb55c6fdfb269e
+SIZE (hypre-2.11.2.tar.gz) = 8077407
diff --git a/science/hypre/pkg-descr b/science/hypre/pkg-descr
new file mode 100644
index 000000000000..746df823f6c4
--- /dev/null
+++ b/science/hypre/pkg-descr
@@ -0,0 +1,7 @@
+HYPRE: Scalable Linear Solvers and Multigrid Methods
+
+HYPRE is a library of high performance preconditioners and solvers featuring
+multigrid methods for the solution of large, sparse linear systems of equations
+on massively parallel computers.
+
+WWW: http://www.llnl.gov/casc/hypre/
diff --git a/science/hypre/pkg-plist b/science/hypre/pkg-plist
new file mode 100644
index 000000000000..1f90df2486de
--- /dev/null
+++ b/science/hypre/pkg-plist
@@ -0,0 +1,79 @@
+include/Cnames.h
+include/HYPRE.h
+include/HYPRE_DistributedMatrixPilutSolver_protos.h
+include/HYPRE_DistributedMatrixPilutSolver_types.h
+include/HYPRE_FEI.h
+include/HYPRE_FEI_includes.h
+include/HYPRE_IJ_mv.h
+include/HYPRE_LinSysCore.h
+include/HYPRE_MatvecFunctions.h
+include/HYPRE_config.h
+include/HYPRE_error_f.h
+include/HYPRE_krylov.h
+include/HYPRE_lobpcg.h
+include/HYPRE_matrix_matrix_protos.h
+include/HYPRE_parcsr_ls.h
+include/HYPRE_parcsr_mv.h
+include/HYPRE_seq_mv.h
+include/HYPRE_sstruct_ls.h
+include/HYPRE_sstruct_mv.h
+include/HYPRE_struct_ls.h
+include/HYPRE_struct_mv.h
+include/HYPRE_utilities.h
+include/HYPREf.h
+include/LLNL_FEI_Fei.h
+include/LLNL_FEI_Impl.h
+include/LLNL_FEI_LSCore.h
+include/LLNL_FEI_Matrix.h
+include/LLNL_FEI_Solver.h
+include/_hypre_IJ_mv.h
+include/_hypre_parcsr_ls.h
+include/_hypre_parcsr_mv.h
+include/_hypre_sstruct_ls.h
+include/_hypre_sstruct_mv.h
+include/_hypre_struct_ls.h
+include/_hypre_struct_mv.h
+include/_hypre_utilities.h
+include/cfei-hypre.h
+include/cfei.h
+include/cfei_hypre.h
+include/colamd.h
+include/csr_block_matrix.h
+include/csr_matmultivec.h
+include/distributed_matrix.h
+include/fei_Data.hpp
+include/fei_LinearSystemCore.hpp
+include/fei_Lookup.hpp
+include/fei_bool.h
+include/fei_defs.h
+include/fei_mpi.h
+include/fortran.h
+include/fortran_matrix.h
+include/hypre_cfei.h
+include/hypre_hopscotch_hash.h
+include/interpreter.h
+include/krylov.h
+include/lobpcg.h
+include/multivector.h
+include/old_colamd.h
+include/par_csr_block_matrix.h
+include/par_csr_matmultivec.h
+include/par_csr_pmvcomm.h
+include/par_multivector.h
+include/seq_multivector.h
+include/seq_mv.h
+include/slu_Cnames.h
+include/slu_cdefs.h
+include/slu_dcomplex.h
+include/slu_ddefs.h
+include/slu_scomplex.h
+include/slu_sdefs.h
+include/slu_util.h
+include/slu_zdefs.h
+include/supermatrix.h
+include/temp_multivector.h
+lib/libHYPRE.so
+lib/libHYPRE.so.2
+lib/libHYPRE.so.2.11
+%%PORTDOCS%%%%DOCSDIR%%/HYPRE_ref_manual.pdf
+%%PORTDOCS%%%%DOCSDIR%%/HYPRE_usr_manual.pdf