aboutsummaryrefslogtreecommitdiff
path: root/science/kst2/Makefile
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2004-04-30 15:44:32 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2004-04-30 15:44:32 +0000
commitbeb87d6ad8e479ac8150062716ad5d36ec514283 (patch)
tree9a205442189157cdab1790aa3b6bfa63b36973d1 /science/kst2/Makefile
parent4ce007b1f58bb7705fe9240bc1abf918cbb28172 (diff)
downloadports-beb87d6ad8e479ac8150062716ad5d36ec514283.tar.gz
ports-beb87d6ad8e479ac8150062716ad5d36ec514283.zip
Notes
Diffstat (limited to 'science/kst2/Makefile')
-rw-r--r--science/kst2/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
new file mode 100644
index 000000000000..844a3f052030
--- /dev/null
+++ b/science/kst2/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: kst
+# Date created: Fri Apr 30 17:28:56 CEST 2004
+# Whom: Markus Brueffer <markus@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= kst
+PORTVERSION= 0.97
+CATEGORIES= science kde
+MASTER_SITES= ${MASTER_SITE_KDE} \
+ http://omega.astro.utoronto.ca/${PORTNAME}/
+MASTER_SITE_SUBDIR= stable/apps/KDE3.x/scientific
+
+MAINTAINER= markus@FreeBSD.org
+COMMENT= Data viewing program for KDE
+
+LIB_DEPENDS= cfitsio.0:${PORTSDIR}/astro/cfitsio \
+ gsl.5:${PORTSDIR}/math/gsl
+
+USE_KDELIBS_VER=3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g; s|^tagnames=|#tagnames=|g;' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/x11/kde3/Makefile.kde"
+.include <bsd.port.post.mk>