aboutsummaryrefslogtreecommitdiff
path: root/science/lammps
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-06 06:31:27 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-06 06:31:27 +0000
commitdde7024024a7220404d4d1fb6d0a83238801f7a7 (patch)
tree2e76109d897bc0fc123bfc5b93c1a7162696ddfe /science/lammps
parent78dd05eb3b61053bdc555358e441eb0bbd205328 (diff)
downloadports-dde7024024a7220404d4d1fb6d0a83238801f7a7.tar.gz
ports-dde7024024a7220404d4d1fb6d0a83238801f7a7.zip
Notes
Diffstat (limited to 'science/lammps')
-rw-r--r--science/lammps/Makefile33
-rw-r--r--science/lammps/distinfo3
-rw-r--r--science/lammps/pkg-descr16
-rw-r--r--science/lammps/pkg-plist146
4 files changed, 198 insertions, 0 deletions
diff --git a/science/lammps/Makefile b/science/lammps/Makefile
new file mode 100644
index 000000000000..99f2e2764a0d
--- /dev/null
+++ b/science/lammps/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= lammps
+PORTVERSION= ${GH_TAGNAME:C/stable_([0-9]{1,2})([A-Z][a-z][a-z])([0-9]{4})/\3.\2.\1/S/Jan/01/S/Feb/02/S/Mar/03/S/Apr/04/S/May/05/S/Jun/06/S/Jul/07/S/Aug/08/S/Sep/09/S/Oct/10/S/Nov/11/S/Dec/12/}
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Classical molecular dynamics code with a focus on materials modeling
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libpng16.so:graphics/png \
+ libmpi_cxx.so:net/openmpi
+
+USES= cmake:outsource eigen:3 jpeg shebangfix
+USE_GITHUB= yes
+GH_TAGNAME= stable_22Aug2018
+SHEBANG_GLOB= *.sh *.bash
+SHEBANG_FILES= lib/kokkos/bin/nvcc_wrapper
+
+CMAKE_SOURCE_PATH= ${WRKSRC}/cmake
+
+OPTIONS_DEFINE= FFMPEG
+OPTIONS_DEFAULT= FFMPEG
+
+FFMPEG_BUILD_DEPENDS= ffmpeg:multimedia/ffmpeg
+FFMPEG_RUN_DEPENDS= ffmpeg:multimedia/ffmpeg
+
+post-patch-FFMPEG-off:
+ @${REINPLACE_CMD} 's|find_program(FFMPEG_EXECUTABLE|#&|' ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/science/lammps/distinfo b/science/lammps/distinfo
new file mode 100644
index 000000000000..57f11abc5c11
--- /dev/null
+++ b/science/lammps/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536211844
+SHA256 (lammps-lammps-2018.08.22-stable_22Aug2018_GH0.tar.gz) = 78e7b389523d2fd5243a6f2daab72667907980d31bee22e44b64122c3afc9f04
+SIZE (lammps-lammps-2018.08.22-stable_22Aug2018_GH0.tar.gz) = 108761541
diff --git a/science/lammps/pkg-descr b/science/lammps/pkg-descr
new file mode 100644
index 000000000000..30f08f3087c9
--- /dev/null
+++ b/science/lammps/pkg-descr
@@ -0,0 +1,16 @@
+LAMMPS is a classical molecular dynamics code with a focus on materials
+modeling. It's an acronym for Large-scale Atomic/Molecular Massively Parallel
+Simulator.
+
+LAMMPS has potentials for solid-state materials (metals, semiconductors) and
+soft matter (biomolecules, polymers) and coarse-grained or mesoscopic systems.
+It can be used to model atoms or, more generically, as a parallel particle
+simulator at the atomic, meso, or continuum scale.
+
+LAMMPS runs on single processors or in parallel using message-passing techniques
+and a spatial-decomposition of the simulation domain. Many of its models have
+versions that provide accelerated performance on CPUs, GPUs, and Intel Xeon
+Phis. The code is designed to be easy to modify or extend with new
+functionality.
+
+WWW: https://lammps.sandia.gov/
diff --git a/science/lammps/pkg-plist b/science/lammps/pkg-plist
new file mode 100644
index 000000000000..7189458470dc
--- /dev/null
+++ b/science/lammps/pkg-plist
@@ -0,0 +1,146 @@
+bin/lmp
+etc/profile.d/lammps.csh
+etc/profile.d/lammps.sh
+%%DATADIR%%/potentials/potentials/Ag_u3.eam
+%%DATADIR%%/potentials/potentials/AlCu.adp
+%%DATADIR%%/potentials/potentials/AlCu.bop.table
+%%DATADIR%%/potentials/potentials/AlCu.eam.alloy
+%%DATADIR%%/potentials/potentials/AlFe_mm.eam.fs
+%%DATADIR%%/potentials/potentials/AlO.eam.alloy
+%%DATADIR%%/potentials/potentials/AlO.streitz
+%%DATADIR%%/potentials/potentials/AlSiMgCuFe.meam
+%%DATADIR%%/potentials/potentials/Al_jnp.eam
+%%DATADIR%%/potentials/potentials/Al_jpc.agni
+%%DATADIR%%/potentials/potentials/Al_mm.eam.fs
+%%DATADIR%%/potentials/potentials/Al_prb.agni
+%%DATADIR%%/potentials/potentials/Al_zhou.eam.alloy
+%%DATADIR%%/potentials/potentials/Au_u3.eam
+%%DATADIR%%/potentials/potentials/BN.extep
+%%DATADIR%%/potentials/potentials/BNC.tersoff
+%%DATADIR%%/potentials/potentials/BNCH-old.ILP
+%%DATADIR%%/potentials/potentials/BNCH.ILP
+%%DATADIR%%/potentials/potentials/C.lcbop
+%%DATADIR%%/potentials/potentials/CC.KC
+%%DATADIR%%/potentials/potentials/CC.KC-full
+%%DATADIR%%/potentials/potentials/CCu_v2.bop.table
+%%DATADIR%%/potentials/potentials/CH.KC
+%%DATADIR%%/potentials/potentials/CH.airebo
+%%DATADIR%%/potentials/potentials/CH.airebo-m
+%%DATADIR%%/potentials/potentials/CdTe.bop.table
+%%DATADIR%%/potentials/potentials/CdTe.sw
+%%DATADIR%%/potentials/potentials/CdTeSe.bop.table
+%%DATADIR%%/potentials/potentials/CdTeZnSeHgS0.sw
+%%DATADIR%%/potentials/potentials/CdZnTe_v1.bop.table
+%%DATADIR%%/potentials/potentials/CdZnTe_v2.bop.table
+%%DATADIR%%/potentials/potentials/CoAl.eam.alloy
+%%DATADIR%%/potentials/potentials/Cu.meam
+%%DATADIR%%/potentials/potentials/CuH.bop.table
+%%DATADIR%%/potentials/potentials/CuNi.eam.alloy
+%%DATADIR%%/potentials/potentials/CuTa.eam.alloy
+%%DATADIR%%/potentials/potentials/CuTa_eam.poly
+%%DATADIR%%/potentials/potentials/CuZr_mm.eam.fs
+%%DATADIR%%/potentials/potentials/Cu_mishin1.eam.alloy
+%%DATADIR%%/potentials/potentials/Cu_smf7.eam
+%%DATADIR%%/potentials/potentials/Cu_u3.eam
+%%DATADIR%%/potentials/potentials/Cu_u6.eam
+%%DATADIR%%/potentials/potentials/Cu_zhou.eam.alloy
+%%DATADIR%%/potentials/potentials/FeCr.cdeam
+%%DATADIR%%/potentials/potentials/FeP_mm.eam.fs
+%%DATADIR%%/potentials/potentials/Fe_mm.eam.fs
+%%DATADIR%%/potentials/potentials/GaAs.bop.table
+%%DATADIR%%/potentials/potentials/GaN.sw
+%%DATADIR%%/potentials/potentials/GaN.tersoff
+%%DATADIR%%/potentials/potentials/GaN_sw.poly
+%%DATADIR%%/potentials/potentials/GaN_tersoff.poly
+%%DATADIR%%/potentials/potentials/Ge.tersoff
+%%DATADIR%%/potentials/potentials/He_He_JW2013.table
+%%DATADIR%%/potentials/potentials/InP.vashishta
+%%DATADIR%%/potentials/potentials/MOH.nb3b.harmonic
+%%DATADIR%%/potentials/potentials/Mg_mm.eam.fs
+%%DATADIR%%/potentials/potentials/Mo5.2.mgpt.README
+%%DATADIR%%/potentials/potentials/Mo5.2.mgpt.parmin
+%%DATADIR%%/potentials/potentials/Mo5.2.mgpt.potin
+%%DATADIR%%/potentials/potentials/Mo_Chen_PRM2017.snap
+%%DATADIR%%/potentials/potentials/Mo_Chen_PRM2017.snapcoeff
+%%DATADIR%%/potentials/potentials/Mo_Chen_PRM2017.snapparam
+%%DATADIR%%/potentials/potentials/Ni.adp
+%%DATADIR%%/potentials/potentials/Ni.meam
+%%DATADIR%%/potentials/potentials/NiAlH_jea.eam.alloy
+%%DATADIR%%/potentials/potentials/NiAlH_jea.eam.fs
+%%DATADIR%%/potentials/potentials/Ni_smf7.eam
+%%DATADIR%%/potentials/potentials/Ni_u3.eam
+%%DATADIR%%/potentials/potentials/Pd_u3.eam
+%%DATADIR%%/potentials/potentials/Pt_u3.eam
+%%DATADIR%%/potentials/potentials/README
+%%DATADIR%%/potentials/potentials/README.reax
+%%DATADIR%%/potentials/potentials/Si.b.meam.sw.spline
+%%DATADIR%%/potentials/potentials/Si.edip
+%%DATADIR%%/potentials/potentials/Si.sw
+%%DATADIR%%/potentials/potentials/Si.tersoff
+%%DATADIR%%/potentials/potentials/Si.tersoff.mod
+%%DATADIR%%/potentials/potentials/Si.tersoff.modc
+%%DATADIR%%/potentials/potentials/SiC.edip
+%%DATADIR%%/potentials/potentials/SiC.gw
+%%DATADIR%%/potentials/potentials/SiC.gw.zbl
+%%DATADIR%%/potentials/potentials/SiC.meam
+%%DATADIR%%/potentials/potentials/SiC.tersoff
+%%DATADIR%%/potentials/potentials/SiC.tersoff.zbl
+%%DATADIR%%/potentials/potentials/SiC.vashishta
+%%DATADIR%%/potentials/potentials/SiCGe.tersoff
+%%DATADIR%%/potentials/potentials/SiC_1989.tersoff
+%%DATADIR%%/potentials/potentials/SiC_1990.tersoff
+%%DATADIR%%/potentials/potentials/SiC_1994.tersoff
+%%DATADIR%%/potentials/potentials/SiC_Erhart-Albe.tersoff
+%%DATADIR%%/potentials/potentials/SiO.1990.vashishta
+%%DATADIR%%/potentials/potentials/SiO.1994.vashishta
+%%DATADIR%%/potentials/potentials/SiO.1997.vashishta
+%%DATADIR%%/potentials/potentials/SiO.tersoff
+%%DATADIR%%/potentials/potentials/Si_1.meam.spline
+%%DATADIR%%/potentials/potentials/Si_2.meam.spline
+%%DATADIR%%/potentials/potentials/Ta06A.snap
+%%DATADIR%%/potentials/potentials/Ta06A.snapcoeff
+%%DATADIR%%/potentials/potentials/Ta06A.snapparam
+%%DATADIR%%/potentials/potentials/Ta4.mgpt.README
+%%DATADIR%%/potentials/potentials/Ta4.mgpt.parmin
+%%DATADIR%%/potentials/potentials/Ta4.mgpt.potin
+%%DATADIR%%/potentials/potentials/Ta6.8x.mgpt.README
+%%DATADIR%%/potentials/potentials/Ta6.8x.mgpt.parmin
+%%DATADIR%%/potentials/potentials/Ta6.8x.mgpt.potin
+%%DATADIR%%/potentials/potentials/Ti.meam.spline
+%%DATADIR%%/potentials/potentials/Ti.meam.sw.spline
+%%DATADIR%%/potentials/potentials/TiO.meam.spline
+%%DATADIR%%/potentials/potentials/V6.1.mgpt.README
+%%DATADIR%%/potentials/potentials/V6.1.mgpt.parmin
+%%DATADIR%%/potentials/potentials/V6.1.mgpt.potin
+%%DATADIR%%/potentials/potentials/VFe_mm.eam.fs
+%%DATADIR%%/potentials/potentials/WL.meam
+%%DATADIR%%/potentials/potentials/W_2940_2017_2.snap
+%%DATADIR%%/potentials/potentials/W_2940_2017_2.snapcoeff
+%%DATADIR%%/potentials/potentials/W_2940_2017_2.snapparam
+%%DATADIR%%/potentials/potentials/W_2940_2017_2_He_JW2013.snap
+%%DATADIR%%/potentials/potentials/W_He_JW2013.table
+%%DATADIR%%/potentials/potentials/W_zhou.eam.alloy
+%%DATADIR%%/potentials/potentials/Zr_mm.eam.fs
+%%DATADIR%%/potentials/potentials/charmm22.cmap
+%%DATADIR%%/potentials/potentials/charmm36.cmap
+%%DATADIR%%/potentials/potentials/ci-reaxFF_ZBL.dat
+%%DATADIR%%/potentials/potentials/ffield.ci-reax.CH
+%%DATADIR%%/potentials/potentials/ffield.comb
+%%DATADIR%%/potentials/potentials/ffield.comb3
+%%DATADIR%%/potentials/potentials/ffield.eim
+%%DATADIR%%/potentials/potentials/ffield.reax.AB
+%%DATADIR%%/potentials/potentials/ffield.reax.AuO
+%%DATADIR%%/potentials/potentials/ffield.reax.FC
+%%DATADIR%%/potentials/potentials/ffield.reax.Fe_O_C_H
+%%DATADIR%%/potentials/potentials/ffield.reax.V_O_C_H
+%%DATADIR%%/potentials/potentials/ffield.reax.ZnOH
+%%DATADIR%%/potentials/potentials/ffield.reax.budzien
+%%DATADIR%%/potentials/potentials/ffield.reax.cho
+%%DATADIR%%/potentials/potentials/ffield.reax.lg
+%%DATADIR%%/potentials/potentials/ffield.reax.mattsson
+%%DATADIR%%/potentials/potentials/ffield.reax.rdx
+%%DATADIR%%/potentials/potentials/ffield.smtbq.Al
+%%DATADIR%%/potentials/potentials/ffield.smtbq.Al2O3
+%%DATADIR%%/potentials/potentials/ffield.smtbq.TiO2
+%%DATADIR%%/potentials/potentials/lib.comb3
+%%DATADIR%%/potentials/potentials/library.meam