aboutsummaryrefslogtreecommitdiff
path: root/science/lamprop
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2018-12-19 11:42:06 +0000
committerWen Heping <wen@FreeBSD.org>2018-12-19 11:42:06 +0000
commitd48a252009943564e796b383e1e32d276e22abd1 (patch)
tree4f520f5141399f4e510d6d3348c202717aedc4e3 /science/lamprop
parentc7bfb5f9f0901be62ddb95ed949639abd43a3495 (diff)
downloadports-d48a252009943564e796b383e1e32d276e22abd1.tar.gz
ports-d48a252009943564e796b383e1e32d276e22abd1.zip
- Update to 3.8
PR: 233809 Submitted by: rsmith@xs4all.nl(maintainer)
Notes
Notes: svn path=/head/; revision=487795
Diffstat (limited to 'science/lamprop')
-rw-r--r--science/lamprop/Makefile23
-rw-r--r--science/lamprop/distinfo4
-rw-r--r--science/lamprop/files/patch-build.py11
3 files changed, 13 insertions, 25 deletions
diff --git a/science/lamprop/Makefile b/science/lamprop/Makefile
index 153bf0d2abad..9873c42d41ce 100644
--- a/science/lamprop/Makefile
+++ b/science/lamprop/Makefile
@@ -1,32 +1,31 @@
# $FreeBSD$
PORTNAME= lamprop
-PORTVERSION= 3.4
-PORTREVISION= 2
+PORTVERSION= 3.8
CATEGORIES= science python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= rsmith@xs4all.nl
COMMENT= Calculates properties of fiber reinforced composites
LICENSE= BSD2CLAUSE
+BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY}
-USES= python:3.4+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
USE_GITHUB= yes
GH_ACCOUNT= rsmith-nl
+
NO_ARCH= yes
-PLIST_FILES= bin/lamprop \
- man/man1/lamprop.1.gz \
- man/man5/lamprop.5.gz
+PORTDOCS= lamprop-manual.pdf
-do-build:
- cd ${WRKSRC} && ${PYTHON_VERSION} build.py
+OPTIONS_DEFINE= DOCS
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/lamprop ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/doc/lamprop.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/doc/lamprop.5 ${STAGEDIR}${MAN5PREFIX}/man/man5
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/lamprop-manual.pdf ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/science/lamprop/distinfo b/science/lamprop/distinfo
index e2948aefd64b..d7b56c976886 100644
--- a/science/lamprop/distinfo
+++ b/science/lamprop/distinfo
@@ -1,3 +1,3 @@
TIMESTAMP = 1513686957
-SHA256 (rsmith-nl-lamprop-3.4_GH0.tar.gz) = 25ddfe2e110d01a9894f8d4694352377903b7a24df4f5a6127acfe3fc1eb82dc
-SIZE (rsmith-nl-lamprop-3.4_GH0.tar.gz) = 53081
+SHA256 (rsmith-nl-lamprop-3.8_GH0.tar.gz) = 486baf72e0b94f27a31926611a155da6df26cd04a79517d53480083be5da574f
+SIZE (rsmith-nl-lamprop-3.8_GH0.tar.gz) = 221538
diff --git a/science/lamprop/files/patch-build.py b/science/lamprop/files/patch-build.py
deleted file mode 100644
index c28f7ccca128..000000000000
--- a/science/lamprop/files/patch-build.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- build.py.orig 2018-03-13 08:20:32 UTC
-+++ build.py
-@@ -28,7 +28,7 @@ def mkarchive(name, modules, main='__mai
- """
- std = '__main__.py'
- vi = sys.version_info
-- shebang = '#!/usr/bin/env python{}\n'.format(vi.major).encode('ascii')
-+ shebang = '#!/usr/bin/env python{}.{}\n'.format(vi.major, vi.minor).encode('ascii')
- if isinstance(modules, str):
- modules = [modules]
- if main != std: