aboutsummaryrefslogtreecommitdiff
path: root/science/libctl
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-07-21 04:45:54 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-07-21 04:45:54 +0000
commit153e80e9e5f918f89d9ceec96de7f8f28798f175 (patch)
treeaf13c78649430008a024df9091291657dced6f76 /science/libctl
parentf5e0c389e070554994f26f24d480c3859200cfb9 (diff)
downloadports-153e80e9e5f918f89d9ceec96de7f8f28798f175.tar.gz
ports-153e80e9e5f918f89d9ceec96de7f8f28798f175.zip
- Fix plist when NOPORTDOCS and NOPORTEXAMPLES
Notes
Notes: svn path=/head/; revision=217239
Diffstat (limited to 'science/libctl')
-rw-r--r--science/libctl/Makefile4
-rw-r--r--science/libctl/pkg-plist68
2 files changed, 37 insertions, 35 deletions
diff --git a/science/libctl/Makefile b/science/libctl/Makefile
index 5a3853561e89..ffb5c4db9dd7 100644
--- a/science/libctl/Makefile
+++ b/science/libctl/Makefile
@@ -24,10 +24,12 @@ USE_LDCONFIG= yes
MAN1= gen-ctl-io.1
-.if !defined(NOPORTDOCS)
post-install:
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${CP} -R ${WRKSRC}/doc/ ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
.endif
diff --git a/science/libctl/pkg-plist b/science/libctl/pkg-plist
index 32781bf86fb0..0280e25ade2e 100644
--- a/science/libctl/pkg-plist
+++ b/science/libctl/pkg-plist
@@ -10,36 +10,36 @@ lib/libctlgeom.a
lib/libctlgeom.la
lib/libctlgeom.so
lib/libctlgeom.so.3
-%%DOCSDIR%%/advanced-user.html
-%%DOCSDIR%%/basic-user.html
-%%DOCSDIR%%/developer.html
-%%DOCSDIR%%/guile-links.html
-%%DOCSDIR%%/index.html
-%%DOCSDIR%%/introduction.html
-%%DOCSDIR%%/license.html
-%%DOCSDIR%%/user-ref.html
-%%EXAMPLESDIR%%/.deps/example-ctl-io.Po
-%%EXAMPLESDIR%%/.deps/example-example.Po
-%%EXAMPLESDIR%%/.deps/example-geom.Po
-%%EXAMPLESDIR%%/.deps/example-main.Po
-%%EXAMPLESDIR%%/.libs/example
-%%EXAMPLESDIR%%/Makefile
-%%EXAMPLESDIR%%/Makefile.am
-%%EXAMPLESDIR%%/Makefile.in
-%%EXAMPLESDIR%%/README
-%%EXAMPLESDIR%%/ctl-io.c
-%%EXAMPLESDIR%%/ctl-io.h
-%%EXAMPLESDIR%%/example
-%%EXAMPLESDIR%%/example-ctl-io.o
-%%EXAMPLESDIR%%/example-example.o
-%%EXAMPLESDIR%%/example-geom.o
-%%EXAMPLESDIR%%/example-main.o
-%%EXAMPLESDIR%%/example.c
-%%EXAMPLESDIR%%/example.scm
-%%EXAMPLESDIR%%/example.scm.in
-%%EXAMPLESDIR%%/geom.c
-%%EXAMPLESDIR%%/main.c
-%%EXAMPLESDIR%%/run.ctl
+%%PORTDOCS%%%%DOCSDIR%%/advanced-user.html
+%%PORTDOCS%%%%DOCSDIR%%/basic-user.html
+%%PORTDOCS%%%%DOCSDIR%%/developer.html
+%%PORTDOCS%%%%DOCSDIR%%/guile-links.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/license.html
+%%PORTDOCS%%%%DOCSDIR%%/user-ref.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/.deps/example-ctl-io.Po
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/.deps/example-example.Po
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/.deps/example-geom.Po
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/.deps/example-main.Po
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/.libs/example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.am
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.in
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ctl-io.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ctl-io.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example-ctl-io.o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example-example.o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example-geom.o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example-main.o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.scm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.scm.in
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/geom.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/main.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/run.ctl
%%DATADIR%%/base/class.scm
%%DATADIR%%/base/ctl.scm
%%DATADIR%%/base/extern-funcs.scm
@@ -59,7 +59,7 @@ lib/libctlgeom.so.3
@dirrm %%DATADIR%%/utils
@dirrm %%DATADIR%%/base
@dirrm %%DATADIR%%
-@dirrm %%EXAMPLESDIR%%/.libs
-@dirrm %%EXAMPLESDIR%%/.deps
-@dirrm %%EXAMPLESDIR%%
-@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/.libs
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/.deps
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%