aboutsummaryrefslogtreecommitdiff
path: root/science/libgeodecomp
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-12-09 11:07:41 +0000
committerThierry Thomas <thierry@FreeBSD.org>2020-12-09 11:07:41 +0000
commit376636fda5a230de7d7dcd1ccccc128cd51a8474 (patch)
treed8079db1fc2d5809bb5fd0812fe55b80fde9d98b /science/libgeodecomp
parent932a4703bcabb15576d4d5e9ef6f814de22a4153 (diff)
downloadports-376636fda5a230de7d7dcd1ccccc128cd51a8474.tar.gz
ports-376636fda5a230de7d7dcd1ccccc128cd51a8474.zip
Modify cad/scotch to install shared libraries.
Chase these libraries to the consumers ports.
Notes
Notes: svn path=/head/; revision=557366
Diffstat (limited to 'science/libgeodecomp')
-rw-r--r--science/libgeodecomp/Makefile4
-rw-r--r--science/libgeodecomp/files/patch-CMakeModules_FindSCOTCH.cmake12
2 files changed, 12 insertions, 4 deletions
diff --git a/science/libgeodecomp/Makefile b/science/libgeodecomp/Makefile
index fe9dc83bd2f7..d43af7ef88d1 100644
--- a/science/libgeodecomp/Makefile
+++ b/science/libgeodecomp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libgeodecomp
PORTVERSION= 0.4.0
-PORTREVISION= 20
+PORTREVISION= 21
CATEGORIES= science devel
MASTER_SITES= http://www.libgeodecomp.org/archive/
@@ -35,7 +35,7 @@ SILO_LIB_DEPENDS= libsiloh5.so:science/silo
SILO_CMAKE_BOOL= WITH_SILO
SCOTCH_DESC= Enable graph partitioning based on Scotch/Scotch-PT
-SCOTCH_BUILD_DEPENDS= ${LOCALBASE}/lib/libscotch.a:cad/scotch
+SCOTCH_LIB_DEPENDS= libscotch.so:cad/scotch
SCOTCH_CMAKE_BOOL= WITH_SCOTCH
.include <bsd.port.mk>
diff --git a/science/libgeodecomp/files/patch-CMakeModules_FindSCOTCH.cmake b/science/libgeodecomp/files/patch-CMakeModules_FindSCOTCH.cmake
index a5a5911f53c7..cafbd9109f96 100644
--- a/science/libgeodecomp/files/patch-CMakeModules_FindSCOTCH.cmake
+++ b/science/libgeodecomp/files/patch-CMakeModules_FindSCOTCH.cmake
@@ -1,6 +1,14 @@
---- CMakeModules/FindSCOTCH.cmake.orig 2020-09-20 01:42:12 UTC
+--- CMakeModules/FindSCOTCH.cmake.orig 2014-10-28 09:12:48 UTC
+++ CMakeModules/FindSCOTCH.cmake
-@@ -121,6 +121,7 @@ endif()
+@@ -114,13 +114,14 @@ find_library(PTSCOTCHERR_LIBRARY
+ )
+
+ #set(SCOTCH_DEBUG 1)
+-set(SCOTCH_LIBRARIES ${PTSCOTCH_LIBRARY})
++set(SCOTCH_LIBRARIES ${SCOTCH_LIBRARY} ${SCOTCHERR_LIBRARY} ${PTSCOTCH_LIBRARY})
+ if (PTESMUMPS_LIBRARY)
+ set(SCOTCH_LIBRARIES ${SCOTCH_LIBRARIES} ${PTESMUMPS_LIBRARY})
+ endif()
set(SCOTCH_LIBRARIES ${SCOTCH_LIBRARIES} ${PTSCOTCHERR_LIBRARY})
# Try compiling and running test program