aboutsummaryrefslogtreecommitdiff
path: root/science/libgridxc
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2021-01-13 23:03:31 +0000
committerMark Linimon <linimon@FreeBSD.org>2021-01-13 23:03:31 +0000
commitf86c964117b6a3ebf2cbf7bb69821dfb8a74f1c2 (patch)
treedee6818341bc298df429631dc617ddfaf949f1e5 /science/libgridxc
parent671839de5f6867f1f9e48aa527390d7495cbb750 (diff)
downloadports-f86c964117b6a3ebf2cbf7bb69821dfb8a74f1c2.tar.gz
ports-f86c964117b6a3ebf2cbf7bb69821dfb8a74f1c2.zip
Update GCC_DEFAULT from 9 to 10.
A few (mostly Fortran-based) ports need to be patched because GCC 10 is stricter. A handful of ports need to be restricted to GCC 9 because they fail with 10. 5 ports still fail with GCC 10. However, seeing as this work has been ongoing since 2020-05-24, it is simply time to make the commit and notify the affected maintainers. While here, pet portlint (Makevar order). PR: 246700 Submitted by: gerald Approved by: antoine (after many, many, -exp runs)
Notes
Notes: svn path=/head/; revision=561520
Diffstat (limited to 'science/libgridxc')
-rw-r--r--science/libgridxc/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/science/libgridxc/Makefile b/science/libgridxc/Makefile
index 594fe5d60206..4cb5dc277961 100644
--- a/science/libgridxc/Makefile
+++ b/science/libgridxc/Makefile
@@ -37,6 +37,12 @@ LIBXC_MAKE_ENV= WITH_LIBXC=1
LIBXC_LIB_DEPENDS= libxc.so:science/libxc
LIBXC_BROKEN= Fails to build with libxc-5.0.0: https://bugs.launchpad.net/libgridxc/+bug/1899578
+.include <bsd.port.pre.mk>
+
+.if ${GCC_DEFAULT} >= 10
+BROKEN= fails to build with GCC 10: Type mismatch between actual argument at (1) and actual argument at (2) (INTEGER(8)/INTEGER(4)).
+.endif
+
post-patch:
@${MKDIR} ${BUILD_WRKSRC}
@${CAT} ${WRKSRC}/../extra/fortran.mk \