aboutsummaryrefslogtreecommitdiff
path: root/science/libint
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-09-25 11:04:02 +0000
committerJohn Marino <marino@FreeBSD.org>2014-09-25 11:04:02 +0000
commit2c24dc6b57d2dec99573b9bcef3e4592f16943d8 (patch)
tree06166b9765b1b84ad5ba7d0fa10a61c076a5a467 /science/libint
parenta319ae32b4b7efb3d025dea06f64e85163c95f7c (diff)
downloadports-2c24dc6b57d2dec99573b9bcef3e4592f16943d8.tar.gz
ports-2c24dc6b57d2dec99573b9bcef3e4592f16943d8.zip
science: Fix mpqc, libint and unbreak ghemical, and libghemical atomically
science/ghemical would not link because libghemical.so (from science/ libghemical port) had never been properly linked. Links to all mpqc "SC" libraries were added to LDFLAGS to rectify this. The configure breakage and solution is described below. After the version of lang/gcc was bumped from 4.7 to 4.8, science/libghemical ceased to configure and it was marked broken. After recreating the conftest, it was discovered that two versions incompatible versions of libgcc_s.so were getting pulled in by the realtime linker: the base version and the gcc48 ports version. The base version was getting pulled in by science/libint. To unbreak libghemical, libint is now built with lang/gcc. It was necessary to force libtool to link with LDFLAGS that Mk/bsd.gcc.mk sets so that the runpaths match across libraries used by libghemical. When science/mpqc was staged, it utilized libtool which renumbered all the library versions from 8.0.1 to 7.1.0. This was caused by the age component being greater than 0. By patching configure.in with a new version, we can generate major SHLIB of 8 again. While here, fix the bin/sc-config tool to remove a bad include cflag. With this fixes, science/ghemical builds successfully. Bump all 4 of these ports, remove any BROKEN designation and remove redundant @dirrm in pkg-plist
Notes
Notes: svn path=/head/; revision=369236
Diffstat (limited to 'science/libint')
-rw-r--r--science/libint/Makefile12
-rw-r--r--science/libint/pkg-plist3
2 files changed, 10 insertions, 5 deletions
diff --git a/science/libint/Makefile b/science/libint/Makefile
index 95e56607fe80..5edc3d5a0e2d 100644
--- a/science/libint/Makefile
+++ b/science/libint/Makefile
@@ -3,14 +3,21 @@
PORTNAME= libint
PORTVERSION= 1.1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science
MASTER_SITES= http://www.files.chem.vt.edu/chem-dept/valeev/software/libint/src/
MAINTAINER= ports@FreeBSD.org
COMMENT= Evaluate the integrals in modern atomic and molecular theory
+# USE_GCC=yes is required because libint is used with mpqc which is built
+# by gfortran48 (from lang/gcc) and these two libraries each try to pull in
+# a different version of libgcc_s.so which fails. Forcing this port to
+# build with lang/gcc as well resolves the conflict that manifests in
+# science/libghemical
+
USES= perl5 gmake libtool
+USE_GCC= yes
USE_LDCONFIG= yes
ALL_TARGET= # empty
@@ -18,7 +25,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
post-patch:
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's| -rpath|${LDFLAGS} -rpath|g' \
+ ${WRKSRC}/src/lib/MakeVars.in
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so
diff --git a/science/libint/pkg-plist b/science/libint/pkg-plist
index e366e807a2f4..d633a2e0005f 100644
--- a/science/libint/pkg-plist
+++ b/science/libint/pkg-plist
@@ -15,6 +15,3 @@ lib/libr12-stable.so.1
lib/libr12-stable.so.1.0.0
lib/libr12.a
lib/libr12.so
-@dirrm include/libderiv
-@dirrm include/libint
-@dirrm include/libr12