aboutsummaryrefslogtreecommitdiff
path: root/science/libkml
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-25 18:47:55 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-25 18:47:55 +0000
commitae43a789b3fd259e573f11ea87d4537ab654d00c (patch)
tree5deaa62a75cef25189f27c192d9e52cf25debd8c /science/libkml
parent896ccebde2555524166d8caf4876f45b2ef61ec8 (diff)
downloadports-ae43a789b3fd259e573f11ea87d4537ab654d00c.tar.gz
ports-ae43a789b3fd259e573f11ea87d4537ab654d00c.zip
- Add SWIG option
PR: ports/172660 Submitted by: Rainer Hurling <rhurlin@gwdg.de>
Notes
Notes: svn path=/head/; revision=355264
Diffstat (limited to 'science/libkml')
-rw-r--r--science/libkml/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/science/libkml/Makefile b/science/libkml/Makefile
index 69e12205f50c..e5afc6a9404e 100644
--- a/science/libkml/Makefile
+++ b/science/libkml/Makefile
@@ -15,13 +15,18 @@ LICENSE= BSD3CLAUSE
BUILD_DEPENDS= ${LOCALBASE}/bin/curl-config:${PORTSDIR}/ftp/curl \
${LOCALBASE}/include/expat.h:${PORTSDIR}/textproc/expat2
-CONFIGURE_ARGS= --disable-java --disable-python --disable-swig \
+OPTIONS_DEFINE= SWIG
+
+CONFIGURE_ARGS= --disable-java --disable-python \
--with-expat-include-dir=${LOCALBASE}/include \
--with-expat-lib-dir=${LOCALBASE}/lib
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USES= gmake libtool
+SWIG_BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
+SWIG_CONFIGURE_OFF= --disable-swig
+
post-patch:
@${REINPLACE_CMD} -e '/SWIG_VERSION:4/ s|:4|#*.*.|' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name Makefile.in -exec ${REINPLACE_CMD} 's|-Werror||; s| -ansi -pedantic||' '{}' \;