aboutsummaryrefslogtreecommitdiff
path: root/science/libkml
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-04-28 16:42:55 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-04-28 16:42:55 +0000
commitd575e3f5c0aaa600bb32b3e71050403aee70eab3 (patch)
tree80e2c8f4b74d342dda577f4e2b94d2e303e0c2d4 /science/libkml
parenta7416deae0b139a66c2b7dba85fbd4477c6a020c (diff)
downloadports-d575e3f5c0aaa600bb32b3e71050403aee70eab3.tar.gz
ports-d575e3f5c0aaa600bb32b3e71050403aee70eab3.zip
Notes
Diffstat (limited to 'science/libkml')
-rw-r--r--science/libkml/Makefile15
-rw-r--r--science/libkml/distinfo4
-rw-r--r--science/libkml/files/patch-configure.ac20
-rw-r--r--science/libkml/files/patch-src-kml-base-file_posix.cc (renamed from science/libkml/files/patch-src_kml_base_file__posix.cc)2
-rw-r--r--science/libkml/files/patch-third_party-Makefile.am66
-rw-r--r--science/libkml/pkg-descr8
-rw-r--r--science/libkml/pkg-plist1
7 files changed, 102 insertions, 14 deletions
diff --git a/science/libkml/Makefile b/science/libkml/Makefile
index 7ff54cb529da..1059361972c9 100644
--- a/science/libkml/Makefile
+++ b/science/libkml/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= libkml
-PORTVERSION= 1.2.0
-PORTREVISION= 2
+PORTVERSION= 1.2
+PORTREVISION= 3
CATEGORIES= science
-MASTER_SITES= GOOGLE_CODE
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Library for parse, generate, and operate on KML
@@ -23,13 +22,17 @@ CONFIGURE_ARGS= --disable-java --disable-python \
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-USES= gmake libtool
+USES= autoreconf gmake libtool
+
+GH_ACCOUNT= google
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= release-${PORTVERSION}
+USE_GITHUB= yes
SWIG_BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
SWIG_CONFIGURE_OFF= --disable-swig
post-patch:
- @${REINPLACE_CMD} -e '/SWIG_VERSION:4/ s|:4|#*.*.|' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name Makefile.in -exec ${REINPLACE_CMD} 's|-Werror||; s| -ansi -pedantic||' '{}' \;
+ @${FIND} ${WRKSRC} -name Makefile.am -exec ${REINPLACE_CMD} 's|-Werror||; s| -ansi -pedantic||' '{}' \;
.include <bsd.port.mk>
diff --git a/science/libkml/distinfo b/science/libkml/distinfo
index 984ac18af95e..6a2523815a28 100644
--- a/science/libkml/distinfo
+++ b/science/libkml/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libkml-1.2.0.tar.gz) = fae9085e4cd9f0d4ae0d0626be7acf4ad5cbb37991b9d886df29daf72df37cbc
-SIZE (libkml-1.2.0.tar.gz) = 9041987
+SHA256 (google-libkml-1.2-release-1.2_GH0.tar.gz) = 98b0808ac243390c09288bbc90c248879572ca7455f22dc4610aab32848d130d
+SIZE (google-libkml-1.2-release-1.2_GH0.tar.gz) = 8784768
diff --git a/science/libkml/files/patch-configure.ac b/science/libkml/files/patch-configure.ac
new file mode 100644
index 000000000000..936d3bcf3a4c
--- /dev/null
+++ b/science/libkml/files/patch-configure.ac
@@ -0,0 +1,20 @@
+--- configure.ac.orig 2010-02-19 15:52:05 UTC
++++ configure.ac
+@@ -6,7 +6,7 @@ AC_PREREQ(2.57)
+ AC_INIT(libkml, 1.2.0, http://code.google.com/p/libkml/issues)
+ AC_CONFIG_SRCDIR(README)
+ AC_CONFIG_AUX_DIR(config)
+-AM_INIT_AUTOMAKE(-Wall -Werror)
++AM_INIT_AUTOMAKE(-Wall subdir-objects)
+
+ AC_PROG_CPP
+ AC_PROG_CXX
+@@ -88,7 +88,7 @@ if test "x$enable_swig" != xno; then
+ AC_CHECK_PROG(SWIG, swig, swig)
+ if test "x$SWIG" != x; then
+ SWIG_VERSION=`swig -version 2>&1|grep Version|cut -d" " -f3`
+- if test ${SWIG_VERSION:4} -lt 35; then
++ if test ${SWIG_VERSION#*.*.} -lt 35; then
+ AC_MSG_WARN([You have SWIG $SWIG_VERSION installed, but libkml requires at least SWIG 1.3.35. The bindings will not be built.])
+ SWIG=
+ fi
diff --git a/science/libkml/files/patch-src_kml_base_file__posix.cc b/science/libkml/files/patch-src-kml-base-file_posix.cc
index fa6efde6aead..9dad7ba5b4c4 100644
--- a/science/libkml/files/patch-src_kml_base_file__posix.cc
+++ b/science/libkml/files/patch-src-kml-base-file_posix.cc
@@ -1,4 +1,4 @@
---- src/kml/base/file_posix.cc.orig 2010-01-14 00:16:30.000000000 +0000
+--- src/kml/base/file_posix.cc.orig 2010-02-19 15:52:05 UTC
+++ src/kml/base/file_posix.cc
@@ -29,6 +29,7 @@
#include "kml/base/file.h"
diff --git a/science/libkml/files/patch-third_party-Makefile.am b/science/libkml/files/patch-third_party-Makefile.am
new file mode 100644
index 000000000000..7a754cf8c22d
--- /dev/null
+++ b/science/libkml/files/patch-third_party-Makefile.am
@@ -0,0 +1,66 @@
+--- third_party/Makefile.am.orig 2010-02-19 15:52:05 UTC
++++ third_party/Makefile.am
+@@ -16,24 +16,24 @@ libminizip_la_SOURCES = \
+ libminizip_la_LDFLAGS = -lz
+
+ liburiparser_la_SOURCES = \
+- $(uriparser)/lib/UriCommon.c \
+- $(uriparser)/lib/UriCommon.h \
+- $(uriparser)/lib/UriCompare.c \
+- $(uriparser)/lib/UriEscape.c \
+- $(uriparser)/lib/UriFile.c \
+- $(uriparser)/lib/UriIp4.c \
+- $(uriparser)/lib/UriIp4Base.c \
+- $(uriparser)/lib/UriIp4Base.h \
+- $(uriparser)/lib/UriNormalize.c \
+- $(uriparser)/lib/UriNormalizeBase.c \
+- $(uriparser)/lib/UriNormalizeBase.h \
+- $(uriparser)/lib/UriParse.c \
+- $(uriparser)/lib/UriParseBase.c \
+- $(uriparser)/lib/UriParseBase.h \
+- $(uriparser)/lib/UriQuery.c \
+- $(uriparser)/lib/UriRecompose.c \
+- $(uriparser)/lib/UriResolve.c \
+- $(uriparser)/lib/UriShorten.c
++ uriparser-0.7.5/lib/UriCommon.c \
++ uriparser-0.7.5/lib/UriCommon.h \
++ uriparser-0.7.5/lib/UriCompare.c \
++ uriparser-0.7.5/lib/UriEscape.c \
++ uriparser-0.7.5/lib/UriFile.c \
++ uriparser-0.7.5/lib/UriIp4.c \
++ uriparser-0.7.5/lib/UriIp4Base.c \
++ uriparser-0.7.5/lib/UriIp4Base.h \
++ uriparser-0.7.5/lib/UriNormalize.c \
++ uriparser-0.7.5/lib/UriNormalizeBase.c \
++ uriparser-0.7.5/lib/UriNormalizeBase.h \
++ uriparser-0.7.5/lib/UriParse.c \
++ uriparser-0.7.5/lib/UriParseBase.c \
++ uriparser-0.7.5/lib/UriParseBase.h \
++ uriparser-0.7.5/lib/UriQuery.c \
++ uriparser-0.7.5/lib/UriRecompose.c \
++ uriparser-0.7.5/lib/UriResolve.c \
++ uriparser-0.7.5/lib/UriShorten.c
+ liburiparser_la_LDFLAGS = -version-info 1:5:0
+
+ boost_root = boost_1_34_1
+@@ -79,13 +79,13 @@ libboostconfigplatforminclude_HEADERS =
+
+ googletest = googletest-r108
+ libgtest_la_SOURCES = \
+- $(googletest)/src/gtest.cc \
+- $(googletest)/src/gtest-death-test.cc \
+- $(googletest)/src/gtest-filepath.cc \
+- $(googletest)/src/gtest-internal-inl.h \
+- $(googletest)/src/gtest-port.cc \
+- $(googletest)/src/gtest-test-part.cc \
+- $(googletest)/src/gtest-typed-test.cc
++ googletest-r108/src/gtest.cc \
++ googletest-r108/src/gtest-death-test.cc \
++ googletest-r108/src/gtest-filepath.cc \
++ googletest-r108/src/gtest-internal-inl.h \
++ googletest-r108/src/gtest-port.cc \
++ googletest-r108/src/gtest-test-part.cc \
++ googletest-r108/src/gtest-typed-test.cc
+
+ EXTRA_DIST = \
+ expat.win32/expat.h \
diff --git a/science/libkml/pkg-descr b/science/libkml/pkg-descr
index 906c064ef53a..aea0aa9e2366 100644
--- a/science/libkml/pkg-descr
+++ b/science/libkml/pkg-descr
@@ -1,5 +1,5 @@
-libkml is a library for use with applications that want to
-parse, generate and operate on KML. It is an implementation
-of the OGC KML 2.2 standard.
+This is Google's reference implementation of OGC KML 2.2. It also includes
+implementations of Google's gx: extensions used by Google Earth, as well as
+several utility libraries for working with other formats.
-WWW: http://code.google.com/p/libkml/
+WWW: https://github.com/google/libkml
diff --git a/science/libkml/pkg-plist b/science/libkml/pkg-plist
index 34ef290e68e5..a157e7985db2 100644
--- a/science/libkml/pkg-plist
+++ b/science/libkml/pkg-plist
@@ -182,4 +182,3 @@ lib/liburiparser.a
lib/liburiparser.so
lib/liburiparser.so.1
lib/liburiparser.so.1.0.5
-@dir lib/libkml