aboutsummaryrefslogtreecommitdiff
path: root/science/liboglappth
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2008-08-20 22:35:40 +0000
committerMaho Nakata <maho@FreeBSD.org>2008-08-20 22:35:40 +0000
commitc07fcd01fb8bf9022ca4fde342cfeef8a19142fe (patch)
tree8b4756ccc5495894ec7f692a37f48ebc017f9cc6 /science/liboglappth
parent82029848539035102687696899cb15235c7054a8 (diff)
downloadports-c07fcd01fb8bf9022ca4fde342cfeef8a19142fe.tar.gz
ports-c07fcd01fb8bf9022ca4fde342cfeef8a19142fe.zip
liboglappth is a support library packages for science/ghemical
Notes
Notes: svn path=/head/; revision=218929
Diffstat (limited to 'science/liboglappth')
-rw-r--r--science/liboglappth/Makefile25
-rw-r--r--science/liboglappth/distinfo3
-rw-r--r--science/liboglappth/pkg-descr6
-rw-r--r--science/liboglappth/pkg-plist14
4 files changed, 48 insertions, 0 deletions
diff --git a/science/liboglappth/Makefile b/science/liboglappth/Makefile
new file mode 100644
index 000000000000..f64010eed307
--- /dev/null
+++ b/science/liboglappth/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: liboglappth
+# Date created: 2008/8/21
+# Whom: Nakata Maho <maho@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= liboglappth
+PORTVERSION= 0.98
+CATEGORIES= science
+MASTER_SITES= http://www.uku.fi/~thassine/projects/download/current/ \
+ http://bioinformatics.org/ghemical/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= maho@FreeBSD.org
+COMMENT= Support libraries of science/ghemical port
+
+GNU_CONFIGURE= yes
+
+USE_GL= glut
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ CXXFLAGS="-I${LOCALBASE}/include" \
+ CFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/science/liboglappth/distinfo b/science/liboglappth/distinfo
new file mode 100644
index 000000000000..407989a4571e
--- /dev/null
+++ b/science/liboglappth/distinfo
@@ -0,0 +1,3 @@
+MD5 (liboglappth-0.98.tar.gz) = dd280286a51fcba6a47264a383a2f1fe
+SHA256 (liboglappth-0.98.tar.gz) = 1ec5964bb281215d5c6e58dee7e5a1a8bcaef2e07df4ac1336ec404b701a11c1
+SIZE (liboglappth-0.98.tar.gz) = 326755
diff --git a/science/liboglappth/pkg-descr b/science/liboglappth/pkg-descr
new file mode 100644
index 000000000000..45cdb4682a1d
--- /dev/null
+++ b/science/liboglappth/pkg-descr
@@ -0,0 +1,6 @@
+libghemical is a support library packages for science/ghemical
+This is for the OpenGL stuff.
+See also:
+http://www.bioinformatics.org/pipermail/ghemical-devel/2007-September/000688.html
+
+WWW: http://www.uku.fi/~thassine/projects/ghemical/
diff --git a/science/liboglappth/pkg-plist b/science/liboglappth/pkg-plist
new file mode 100644
index 000000000000..1834ac4f5656
--- /dev/null
+++ b/science/liboglappth/pkg-plist
@@ -0,0 +1,14 @@
+include/oglappth/oglv3d.h
+include/oglappth/base_app.h
+include/oglappth/base_wnd.h
+include/oglappth/base_wcl.h
+include/oglappth/ogl_objects.h
+include/oglappth/ogl_camera.h
+include/oglappth/ogl_lights.h
+include/oglappth/transparent.h
+lib/liboglappth.so.2
+lib/liboglappth.la
+lib/liboglappth.a
+lib/pkgconfig/liboglappth.pc
+@dirrm include/oglappth
+@dirrm lib/pkgconfig