aboutsummaryrefslogtreecommitdiff
path: root/science/libxc
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-10-26 10:10:10 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-10-26 10:10:10 +0000
commit6ebf053fb0514f5168dbac5b9a6d9807e73b55c8 (patch)
tree85c3eb7d83f7ff3dc4a1fce7715dbdc4be981425 /science/libxc
parent2be6af5e75859102d972a4874ede998dcbc5b035 (diff)
downloadports-6ebf053fb0514f5168dbac5b9a6d9807e73b55c8.tar.gz
ports-6ebf053fb0514f5168dbac5b9a6d9807e73b55c8.zip
Add a port of Libxc, a library of exchange-correlation functionals for
density-functional theory. PR: 201266 (modified) Submitted by: Johannes Dieterich
Notes
Notes: svn path=/head/; revision=400179
Diffstat (limited to 'science/libxc')
-rw-r--r--science/libxc/Makefile33
-rw-r--r--science/libxc/distinfo2
-rw-r--r--science/libxc/pkg-descr9
-rw-r--r--science/libxc/pkg-plist14
4 files changed, 58 insertions, 0 deletions
diff --git a/science/libxc/Makefile b/science/libxc/Makefile
new file mode 100644
index 000000000000..340ad73c0022
--- /dev/null
+++ b/science/libxc/Makefile
@@ -0,0 +1,33 @@
+# Created by: Johannes Dieterich <dieterich@ogolem.org>
+# $FreeBSD$
+
+PORTNAME= libxc
+PORTVERSION= 2.1.2
+CATEGORIES= science
+MASTER_SITES= http://www.tddft.org/programs/octopus/download/libxc/
+
+MAINTAINER= dieterich@ogolem.org
+COMMENT= Library of exchange-correlation functionals for DFT
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= fortran gmake libtool perl5
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-shared
+USE_LDCONFIG= yes
+
+INSTALL_TARGET= install-strip
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^pkgconfigdir =/s,libdir),prefix)/libdata,' \
+ ${WRKSRC}/build/Makefile.in
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000034
+LIB_DEPENDS+= libml.so:${PORTSDIR}/math/ldouble
+LDFLAGS+= -lml
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/science/libxc/distinfo b/science/libxc/distinfo
new file mode 100644
index 000000000000..d88c6f4246f2
--- /dev/null
+++ b/science/libxc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libxc-2.1.2.tar.gz) = 6c866168fa6245e6777cec8a1da257975e2e4cf410681416e248fbff2b03e55d
+SIZE (libxc-2.1.2.tar.gz) = 724139
diff --git a/science/libxc/pkg-descr b/science/libxc/pkg-descr
new file mode 100644
index 000000000000..8fa3db40f265
--- /dev/null
+++ b/science/libxc/pkg-descr
@@ -0,0 +1,9 @@
+Libxc is library of exchange-correlation functionals for density-functional
+theory. The aim is to provide a portable, well tested and reliable set of
+exchange and correlation functionals that can be used by all the ETSF codes
+and also other codes.
+
+In libxc you can find different types of functionals: LDA, GGA, hybrids,
+and mGGA (experimental).
+
+WWW: http://www.tddft.org/programs/octopus/wiki/index.php/Libxc
diff --git a/science/libxc/pkg-plist b/science/libxc/pkg-plist
new file mode 100644
index 000000000000..f365ff3edaf9
--- /dev/null
+++ b/science/libxc/pkg-plist
@@ -0,0 +1,14 @@
+bin/xc-info
+include/libxc_funcs_m.mod
+include/xc.h
+include/xc_config.h
+include/xc_f90_lib_m.mod
+include/xc_f90_types_m.mod
+include/xc_funcs.h
+include/xc_unconfig.h
+include/xc_version.h
+lib/libxc.a
+lib/libxc.so
+lib/libxc.so.1
+lib/libxc.so.1.1.2
+libdata/pkgconfig/libxc.pc