aboutsummaryrefslogtreecommitdiff
path: root/science/maeparser
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-25 07:24:36 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-25 07:24:36 +0000
commit540b0cdd6eb884d608654bc3ac8547f6a801902e (patch)
tree01c289ca6140735e9df2d9ca59c64cfb275babd3 /science/maeparser
parent34daf565f1b401eecb35419cbaab1bf4735324da (diff)
downloadports-540b0cdd6eb884d608654bc3ac8547f6a801902e.tar.gz
ports-540b0cdd6eb884d608654bc3ac8547f6a801902e.zip
New port: science/maeparser: Parser for Schrodinger Maestro files
Notes
Notes: svn path=/head/; revision=482957
Diffstat (limited to 'science/maeparser')
-rw-r--r--science/maeparser/Makefile21
-rw-r--r--science/maeparser/distinfo3
-rw-r--r--science/maeparser/pkg-descr7
-rw-r--r--science/maeparser/pkg-plist8
4 files changed, 39 insertions, 0 deletions
diff --git a/science/maeparser/Makefile b/science/maeparser/Makefile
new file mode 100644
index 000000000000..6ef605c40892
--- /dev/null
+++ b/science/maeparser/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= maeparser
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.1
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Parser for Schrodinger Maestro files
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/dynamic_bitset.hpp:devel/boost-libs
+
+USES= cmake:outsource compiler:c++11-lang
+USE_GITHUB= yes
+GH_ACCOUNT= schrodinger
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/science/maeparser/distinfo b/science/maeparser/distinfo
new file mode 100644
index 000000000000..112e8e26bbfb
--- /dev/null
+++ b/science/maeparser/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1540451819
+SHA256 (schrodinger-maeparser-v1.0.1_GH0.tar.gz) = 8251e93ac06b2915a21516cb16741a3c6d139e9557027aa371f17875668f2a18
+SIZE (schrodinger-maeparser-v1.0.1_GH0.tar.gz) = 26285
diff --git a/science/maeparser/pkg-descr b/science/maeparser/pkg-descr
new file mode 100644
index 000000000000..7c9ca10ddc98
--- /dev/null
+++ b/science/maeparser/pkg-descr
@@ -0,0 +1,7 @@
+maeparser is a parser for Schrodinger Maestro files.
+
+Structure files (.mae,.maegz,.mae.gz) can contain multiple structures
+delimited by "f_m_ct". See MaeConstants.hpp for standard block and property
+names.
+
+WWW: https://github.com/schrodinger/maeparser
diff --git a/science/maeparser/pkg-plist b/science/maeparser/pkg-plist
new file mode 100644
index 000000000000..d34ebda66141
--- /dev/null
+++ b/science/maeparser/pkg-plist
@@ -0,0 +1,8 @@
+include/maeparser/Buffer.hpp
+include/maeparser/MaeBlock.hpp
+include/maeparser/MaeParser.hpp
+include/maeparser/MaeParserConfig.hpp
+include/maeparser/Reader.hpp
+lib/cmake/maeparser-config-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/maeparser-config.cmake
+lib/libmaeparser.so