aboutsummaryrefslogtreecommitdiff
path: root/science/mbdyn
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-08 15:52:33 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-08 15:52:33 +0000
commitedd57deff8b804e841b8eeec02cd2a608b672415 (patch)
treeb46d91d9bbc33e7b0224a08059be055e77fb3b01 /science/mbdyn
parentb83919bc93342dd37893d7731dde30f67e58ea7e (diff)
downloadports-edd57deff8b804e841b8eeec02cd2a608b672415.tar.gz
ports-edd57deff8b804e841b8eeec02cd2a608b672415.zip
science/mbdyn: fix build on powerpc64*
In file included from bulk.cc:35: In file included from ./dataman.h:47: In file included from ./mbpar.h:107: In file included from ./../../libraries/libmbutil/parsinc.h:108: ./../../libraries/libmbutil/parser.h:275:3: error: expected identifier FIRSTARG, ^ /usr/include/machine/frame.h:112:18: note: expanded from macro 'FIRSTARG' ^ 1 error generated.
Diffstat (limited to 'science/mbdyn')
-rw-r--r--science/mbdyn/Makefile1
-rw-r--r--science/mbdyn/files/patch-libraries_libmbutil_parser.h11
2 files changed, 11 insertions, 1 deletions
diff --git a/science/mbdyn/Makefile b/science/mbdyn/Makefile
index db85665031c5..00691d9627c9 100644
--- a/science/mbdyn/Makefile
+++ b/science/mbdyn/Makefile
@@ -13,7 +13,6 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_powerpc= Does not compile on powerpc
-BROKEN_powerpc64= fails to compile: libraries/libmbutil/parser.h:275:3: error: expected identifier
BUILD_DEPENDS= libatomic_ops>0:devel/libatomic_ops
LIB_DEPENDS= libltdl.so:devel/libltdl \
diff --git a/science/mbdyn/files/patch-libraries_libmbutil_parser.h b/science/mbdyn/files/patch-libraries_libmbutil_parser.h
new file mode 100644
index 000000000000..fc33a9adaf1e
--- /dev/null
+++ b/science/mbdyn/files/patch-libraries_libmbutil_parser.h
@@ -0,0 +1,11 @@
+--- libraries/libmbutil/parser.h.orig 2021-11-08 01:16:41 UTC
++++ libraries/libmbutil/parser.h
+@@ -272,7 +272,7 @@ class HighParser { (public)
+ UNKNOWN = -1,
+
+ DESCRIPTION,
+- FIRSTARG,
++ MBDYN_FIRSTARG,
+ ARG,
+ LASTARG,
+ NOARGS,