aboutsummaryrefslogtreecommitdiff
path: root/science/mbdyn
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-07-14 18:42:04 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-07-14 18:42:04 +0000
commitffb7170399b77f34a48875ad6468eb796f00aed3 (patch)
tree3a1e4c5d813ec945366f43d48f94fa325ba0ead9 /science/mbdyn
parentc60af5b21ccf5bfc632b51afe126bbc7dac29ddd (diff)
downloadports-ffb7170399b77f34a48875ad6468eb796f00aed3.tar.gz
ports-ffb7170399b77f34a48875ad6468eb796f00aed3.zip
Modernize LIB_DEPENDS
With hat: portmgr
Notes
Notes: svn path=/head/; revision=361812
Diffstat (limited to 'science/mbdyn')
-rw-r--r--science/mbdyn/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/science/mbdyn/Makefile b/science/mbdyn/Makefile
index 7709d61728ee..1feacee0da19 100644
--- a/science/mbdyn/Makefile
+++ b/science/mbdyn/Makefile
@@ -12,8 +12,8 @@ COMMENT= A MultiBody Dynamics analysis system
LICENSE= GPLv2
-LIB_DEPENDS= arpack:${PORTSDIR}/math/arpack \
- umfpack:${PORTSDIR}/math/suitesparse
+LIB_DEPENDS= libarpack.so:${PORTSDIR}/math/arpack \
+ libumfpack.so:${PORTSDIR}/math/suitesparse
GNU_CONFIGURE= yes
USES= fortran gmake
@@ -39,22 +39,22 @@ BROKEN= Does not compile on powerpc
WITH_BLAS?= reference
. if ${WITH_BLAS} == reference
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas \
- lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas \
+ liblapack.so:${PORTSDIR}/math/lapack
CONFIGURE_ARGS+= --with-blas=blas
LAPACK_LIBS= -llapack
.elif ${WITH_BLAS} == gotoblas
-LIB_DEPENDS+= goto:${PORTSDIR}/math/gotoblas
+LIB_DEPENDS+= libgoto.so:${PORTSDIR}/math/gotoblas
CONFIGURE_ARGS+= --with-blas=goto --with-goto=goto2
LAPACK_LIBS= -lgoto2
.elif ${WITH_BLAS} == atlas
-LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
CONFIGURE_ARGS+= --with-blas=atlas
LAPACK_LIBS= -lalapack
.endif
.if ${PORT_OPTIONS:MMPI}
-LIB_DEPENDS+= mpich:${PORTSDIR}/net/mpich2
+LIB_DEPENDS+= libmpich.so:${PORTSDIR}/net/mpich2
CONFIGURE_ARGS+= --with-mpi=yes --enable-schur
CPPFLAGS+= -I${LOCALBASE}/include
. if ! ${PORT_OPTIONS:MMETIS}
@@ -65,7 +65,7 @@ CONFIGURE_ARGS+= --with-mpi=no
.endif
.if ${PORT_OPTIONS:MMETIS}
-LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis4
+LIB_DEPENDS+= libmetis.so:${PORTSDIR}/math/metis4
CONFIGURE_ARGS+= --with-metis=yes
CPPFLAGS+= -I${LOCALBASE}/include/metis
.else
@@ -80,7 +80,7 @@ CONFIGURE_ARGS+= --with-chaco=no
.endif
.if ${PORT_OPTIONS:MGINAC}
-LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis4 \
+LIB_DEPENDS+= libmetis.so:${PORTSDIR}/math/metis4 \
ginac:${PORTSDIR}/math/GiNaC
CONFIGURE_ARGS+= --with-ginac=yes
CPPFLAGS+= -I${LOCALBASE}/include/metis
@@ -90,7 +90,7 @@ CONFIGURE_ARGS+= --with-ginac=no
.if ${PORT_OPTIONS:MTCL}
IGNORE= you enabled Tcl-support, which is not implemented yet
-LIB_DEPENDS+= tcl84:${PORTSDIR}/lang/tcl84
+LIB_DEPENDS+= libtcl84.so:${PORTSDIR}/lang/tcl84
CONFIGURE_ARGS+= --with-tcl=yes
CPPFLAGS+= -I${LOCALBASE}/include/tcl8.4
.else