aboutsummaryrefslogtreecommitdiff
path: root/science/minc2
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-04-30 12:05:08 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-04-30 12:05:08 +0000
commit26c255eb054c2b34cb29a14cce1c806b1bff2008 (patch)
treeb953b3ef03ef35e115a57e397381f07c0a9d4102 /science/minc2
parentfdd1538a7b54ae17bbed6d63febbf87797a3a0ef (diff)
downloadports-26c255eb054c2b34cb29a14cce1c806b1bff2008.tar.gz
ports-26c255eb054c2b34cb29a14cce1c806b1bff2008.zip
Add science/minc2.
MINC (Medical Imaging NetCDF) is a medical imaging data format and an associated set of tools and libraries. MINC was created in 1993 by Peter Neelin at the McConnell Brain Imaging Centre of the Montreal Neurological Institute. Many others have contributed to the design and implementation MINC over the years. PR: ports/93495 Submitted by: Jason Bacon <bacon (at) smithers.neuro.mcw.edu> Repocopied by: marcus
Notes
Notes: svn path=/head/; revision=160899
Diffstat (limited to 'science/minc2')
-rw-r--r--science/minc2/Makefile25
-rw-r--r--science/minc2/distinfo6
-rw-r--r--science/minc2/pkg-plist21
3 files changed, 31 insertions, 21 deletions
diff --git a/science/minc2/Makefile b/science/minc2/Makefile
index ec961a33e97e..41ed616e2b81 100644
--- a/science/minc2/Makefile
+++ b/science/minc2/Makefile
@@ -16,24 +16,27 @@
# Of course, the netcdf port must be installed first.
PORTNAME= minc
-PORTVERSION= 1.4
-PORTREVISION= 1
+PORTVERSION= 2.0.09
CATEGORIES= science biology
-MASTER_SITES= http://www.bic.mni.mcgill.ca/software/distribution/packages/ \
+MASTER_SITES= http://www.bic.mni.mcgill.ca/users/bert/ \
http://www.neuro.mcw.edu/~bacon/Ports/distfiles/
MAINTAINER= bacon@smithers.neuro.mcw.edu
COMMENT= Medical Imaging NetCDF
-LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf
+LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf \
+ hdf5.0:${PORTSDIR}/science/hdf5
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_GCC= 3.2+
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --enable-static=yes --enable-shared=yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --enable-shared=yes --enable-static=yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+CONFLICTS= minc-1*
+LATEST_LINK= minc2
MAN1= dcm2mnc.1 \
ecattominc.1 \
@@ -42,12 +45,15 @@ MAN1= dcm2mnc.1 \
mincaverage.1 \
minccalc.1 \
mincconcat.1 \
+ mincconvert.1 \
minccopy.1 \
mincdiff.1 \
mincedit.1 \
mincexpand.1 \
mincextract.1 \
+ mincgen.1 \
mincheader.1 \
+ minchistory.1 \
mincinfo.1 \
minclookup.1 \
mincmakescalar.1 \
@@ -69,10 +75,9 @@ MAN1= dcm2mnc.1 \
voxeltoworld.1 \
xfmconcat.1 \
xfminvert.1
-
MAN3= ParseArgv.3
post-install:
- @${CAT} ${PKGMESSAGE}
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/science/minc2/distinfo b/science/minc2/distinfo
index c73ee7c2269b..59fb4e5c7afd 100644
--- a/science/minc2/distinfo
+++ b/science/minc2/distinfo
@@ -1,3 +1,3 @@
-MD5 (minc-1.4.tar.gz) = 873a6deed8109f95d29a197bad9f6070
-SHA256 (minc-1.4.tar.gz) = a07c9523f232c823f38275bc8bb23011e70a29a0a45071dad0dec81317a75c4f
-SIZE (minc-1.4.tar.gz) = 1213768
+MD5 (minc-2.0.09.tar.gz) = 8a8606163852f91d6dc66dbcc3fde4ee
+SHA256 (minc-2.0.09.tar.gz) = b55907a5dd26c1b98b39f6cb81133336d7c794d4f7d4ad38b02561a9cc489390
+SIZE (minc-2.0.09.tar.gz) = 1418085
diff --git a/science/minc2/pkg-plist b/science/minc2/pkg-plist
index 293bf89a7dff..c1d540edba89 100644
--- a/science/minc2/pkg-plist
+++ b/science/minc2/pkg-plist
@@ -5,11 +5,14 @@ bin/minc_modify_header
bin/mincaverage
bin/minccalc
bin/mincconcat
+bin/mincconvert
bin/minccopy
bin/mincdiff
+bin/mincdump
bin/mincedit
bin/mincexpand
bin/mincextract
+bin/mincgen
bin/mincheader
bin/minchistory
bin/mincinfo
@@ -36,6 +39,8 @@ bin/xfmconcat
bin/xfminvert
include/ParseArgv.h
include/minc.h
+include/minc2.h
+include/minc_compat.h
include/minc_simple.h
include/nd_loop.h
include/time_stamp.h
@@ -57,12 +62,12 @@ include/volume_io/vol_io_prototypes.h
include/volume_io/volume.h
include/volume_io/volume_cache.h
include/voxel_loop.h
-lib/libminc.a
-lib/libminc.la
-lib/libminc.so
-lib/libminc.so.1
-lib/libvolume_io.a
-lib/libvolume_io.la
-lib/libvolume_io.so
-lib/libvolume_io.so.0
+lib/libminc2.a
+lib/libminc2.la
+lib/libminc2.so
+lib/libminc2.so.2
+lib/libvolume_io2.a
+lib/libvolume_io2.la
+lib/libvolume_io2.so
+lib/libvolume_io2.so.2
@dirrm include/volume_io