aboutsummaryrefslogtreecommitdiff
path: root/science/minc
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-02-12 15:30:03 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-02-12 15:30:03 +0000
commit3b5fa65f18da8fe6046d6fb6324ebd08df638180 (patch)
tree13d6a3ccaeeca8015a73c7994548cf44e4343ad4 /science/minc
parentd446f531b35791798c65cdfe7b40d5698934b33b (diff)
downloadports-3b5fa65f18da8fe6046d6fb6324ebd08df638180.tar.gz
ports-3b5fa65f18da8fe6046d6fb6324ebd08df638180.zip
Notes
Diffstat (limited to 'science/minc')
-rw-r--r--science/minc/Makefile80
-rw-r--r--science/minc/distinfo3
-rw-r--r--science/minc/pkg-descr10
-rw-r--r--science/minc/pkg-message8
-rw-r--r--science/minc/pkg-plist66
5 files changed, 167 insertions, 0 deletions
diff --git a/science/minc/Makefile b/science/minc/Makefile
new file mode 100644
index 000000000000..a9bc2faa5917
--- /dev/null
+++ b/science/minc/Makefile
@@ -0,0 +1,80 @@
+############################################################################
+# New ports collection Makefile for: minc 1.x (Medical Imaging NetCDF)
+# Date created: 21 Dec 2005
+# Whom: jbacon
+#
+# $FreeBSD$
+#
+
+############################################################################
+# http://www.bic.mni.mcgill.ca/software/minc/
+# is the ultimate source for MINC, and will always contain the latest
+# source release. If this port is not up to date enough for you,
+# you can download the latest sources and build manually. On FreeBSD,
+# you must configure with the environment variable LDFLAGS set to
+# ${LOCALBASE}/lib so that the configure script will find libnetcdf.
+# Of course, the netcdf port must be installed first.
+
+PORTNAME= minc
+PORTVERSION= 1.4
+CATEGORIES= science biology
+MASTER_SITES= http://www.bic.mni.mcgill.ca/software/distribution/packages/ \
+ http://www.neuro.mcw.edu/~bacon/Ports/distfiles/
+
+MAINTAINER= bacon@smithers.neuro.mcw.edu
+COMMENT= Medical Imaging NetCDF
+
+LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf
+
+INSTALLS_SHLIB= yes
+
+USE_AUTOTOOLS= libtool:15
+
+# Build parameters
+#WRKSRC= ${WRKDIR}/minc-${PORTVERSION}
+
+MAN1= dcm2mnc.1 \
+ ecattominc.1 \
+ invert_raw_image.1 \
+ minc_modify_header.1 \
+ mincaverage.1 \
+ minccalc.1 \
+ mincconcat.1 \
+ minccopy.1 \
+ mincdiff.1 \
+ mincedit.1 \
+ mincexpand.1 \
+ mincextract.1 \
+ mincheader.1 \
+ mincinfo.1 \
+ minclookup.1 \
+ mincmakescalar.1 \
+ mincmakevector.1 \
+ mincmath.1 \
+ mincpik.1 \
+ mincresample.1 \
+ mincreshape.1 \
+ mincstats.1 \
+ minctoecat.1 \
+ minctoraw.1 \
+ mincview.1 \
+ mincwindow.1 \
+ mnc2nii.1 \
+ nii2mnc.1 \
+ rawtominc.1 \
+ transformtags.1 \
+ upet2mnc.1 \
+ voxeltoworld.1 \
+ xfmconcat.1 \
+ xfminvert.1
+MAN3= ParseArgv.3
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-shared=yes --enable-static=yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/science/minc/distinfo b/science/minc/distinfo
new file mode 100644
index 000000000000..c73ee7c2269b
--- /dev/null
+++ b/science/minc/distinfo
@@ -0,0 +1,3 @@
+MD5 (minc-1.4.tar.gz) = 873a6deed8109f95d29a197bad9f6070
+SHA256 (minc-1.4.tar.gz) = a07c9523f232c823f38275bc8bb23011e70a29a0a45071dad0dec81317a75c4f
+SIZE (minc-1.4.tar.gz) = 1213768
diff --git a/science/minc/pkg-descr b/science/minc/pkg-descr
new file mode 100644
index 000000000000..9e5380b9987a
--- /dev/null
+++ b/science/minc/pkg-descr
@@ -0,0 +1,10 @@
+MINC (Medical Imaging NetCDF) is a medical imaging data format and an
+associated set of tools and libraries. MINC was created in 1993 by Peter
+Neelin at the McConnell Brain Imaging Centre of the Montreal Neurological
+Institute. Many others have contributed to the design and implementation
+MINC over the years.
+
+WWW: http://www.bic.mni.mcgill.ca/software/minc/
+
+Port maintainer: Jason W. Bacon
+ bacon@smithers.neuro.mcw.edu
diff --git a/science/minc/pkg-message b/science/minc/pkg-message
new file mode 100644
index 000000000000..645690e94543
--- /dev/null
+++ b/science/minc/pkg-message
@@ -0,0 +1,8 @@
+=============================================================================
+For questions or comments regarding this port, please contact the
+port maintainer: bacon@smithers.neuro.mcw.edu
+
+For MINC usage, please visit the MINC WEB site at
+
+http://www.bic.mni.mcgill.ca/software/minc/
+=============================================================================
diff --git a/science/minc/pkg-plist b/science/minc/pkg-plist
new file mode 100644
index 000000000000..95cdcace1c14
--- /dev/null
+++ b/science/minc/pkg-plist
@@ -0,0 +1,66 @@
+bin/dcm2mnc
+bin/ecattominc
+bin/invert_raw_image
+bin/minc_modify_header
+bin/mincaverage
+bin/minccalc
+bin/mincconcat
+bin/minccopy
+bin/mincdiff
+bin/mincedit
+bin/mincexpand
+bin/mincextract
+bin/mincheader
+bin/minchistory
+bin/mincinfo
+bin/minclookup
+bin/mincmakescalar
+bin/mincmakevector
+bin/mincmath
+bin/mincpik
+bin/mincresample
+bin/mincreshape
+bin/mincstats
+bin/minctoecat
+bin/minctoraw
+bin/mincview
+bin/mincwindow
+bin/mnc2nii
+bin/nii2mnc
+bin/rawtominc
+bin/transformtags
+bin/upet2mnc
+bin/voxeltoworld
+bin/worldtovoxel
+bin/xfmconcat
+bin/xfminvert
+include/ParseArgv.h
+include/minc.h
+include/minc_simple.h
+include/nd_loop.h
+include/time_stamp.h
+include/volume_io.h
+include/volume_io/alloc.h
+include/volume_io/arrays.h
+include/volume_io/basic.h
+include/volume_io/def_math.h
+include/volume_io/files.h
+include/volume_io/geom_structs.h
+include/volume_io/geometry.h
+include/volume_io/internal_volume_io.h
+include/volume_io/multidim.h
+include/volume_io/progress.h
+include/volume_io/string_funcs.h
+include/volume_io/system_dependent.h
+include/volume_io/transforms.h
+include/volume_io/vol_io_prototypes.h
+include/volume_io/volume.h
+include/volume_io/volume_cache.h
+include/voxel_loop.h
+lib/libminc.a
+lib/libminc.so
+lib/libminc.so.1
+lib/libvolume_io.a
+lib/libvolume_io.so
+lib/libvolume_io.so.0
+@dirrm include/volume_io