aboutsummaryrefslogtreecommitdiff
path: root/science/msms
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-10 05:53:46 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-10 05:53:46 +0000
commitfb69f61156b584999beb5e4d612f578072a64b3a (patch)
tree543b9170ef392688262b8e253ecc8b9cca7285dc /science/msms
parentd009c5a8486bec36977dabec21e6736df7374f76 (diff)
downloadports-fb69f61156b584999beb5e4d612f578072a64b3a.tar.gz
ports-fb69f61156b584999beb5e4d612f578072a64b3a.zip
New port: science/msms: Program to efficiently compute molecular surfaces
Notes
Notes: svn path=/head/; revision=479360
Diffstat (limited to 'science/msms')
-rw-r--r--science/msms/Makefile41
-rw-r--r--science/msms/distinfo-amd643
-rw-r--r--science/msms/distinfo-i3863
-rw-r--r--science/msms/files/extract-license.awk21
-rw-r--r--science/msms/pkg-descr8
5 files changed, 76 insertions, 0 deletions
diff --git a/science/msms/Makefile b/science/msms/Makefile
new file mode 100644
index 000000000000..59b85e32b6a2
--- /dev/null
+++ b/science/msms/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= msms
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.6.1
+CATEGORIES= science
+MASTER_SITES= http://mgltools.scripps.edu/downloads/tars/releases/MSMSRELEASE/REL${DISTVERSION}/
+DISTNAME= ${PORTNAME}_${ARCH_MSMS_DIST}Linux2_${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Program to efficiently compute molecular surfaces
+
+LICENSE= MSMS_LICENSE
+LICENSE_NAME= MSMS License
+LICENSE_FILE= ${WRKSRC}/license.txt
+LICENSE_PERMS= no-auto-accept no-dist-mirror no-pkg-mirror # No redistribution is allowed.
+
+ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS_REASON= Binaries available only for ${ONLY_FOR_ARCHS}.
+
+RESTRICTED= No commercial use, only for use by individuals
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+ARCH_MSMS_DIST= ${ARCH:S/amd64/i86_64/:S/i386/i86/}
+ARCH_MSMS_FILE= ${ARCH:S/amd64/x86_64/:S/i386/i86/}
+
+DISTINFO_FILE= ${MASTERDIR}/distinfo-${ARCH}
+
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
+
+post-extract:
+ @${AWK} -f ${FILESDIR}/extract-license.awk < ${WRKSRC}/README > ${LICENSE_FILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}.${ARCH_MSMS_FILE}Linux2.${DISTVERSION}${ARCH:S/amd64/.staticgcc/:S/${ARCH}//} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/science/msms/distinfo-amd64 b/science/msms/distinfo-amd64
new file mode 100644
index 000000000000..f0b22d028e90
--- /dev/null
+++ b/science/msms/distinfo-amd64
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536557816
+SHA256 (msms_i86_64Linux2_2.6.1.tar.gz) = 5f0ca50360b5938e74c538e0399d582abc4a40ef4cf410e66f31a1f91e6e3e1f
+SIZE (msms_i86_64Linux2_2.6.1.tar.gz) = 593147
diff --git a/science/msms/distinfo-i386 b/science/msms/distinfo-i386
new file mode 100644
index 000000000000..3dccf5c247a7
--- /dev/null
+++ b/science/msms/distinfo-i386
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536557847
+SHA256 (msms_i86Linux2_2.6.1.tar.gz) = ab4f9e60df6fe18a5ac05550bf074b287792638a818a047697ead049d8737caf
+SIZE (msms_i86Linux2_2.6.1.tar.gz) = 112762
diff --git a/science/msms/files/extract-license.awk b/science/msms/files/extract-license.awk
new file mode 100644
index 000000000000..c702a5f0dc4e
--- /dev/null
+++ b/science/msms/files/extract-license.awk
@@ -0,0 +1,21 @@
+
+BEGIN { in_licence = 0 }
+
+{
+ if (!in_licence && $2 == "LICENSE") {
+ in_licence = 1
+ print prev_line
+ del_count = 1
+ } else if (in_licence) {
+ if ($1 == "############################################################################") {
+ del_count = del_count+1
+ if (del_count > 2)
+ in_licence = 0
+ }
+ }
+
+ if (in_licence)
+ print $0
+
+ prev_line = $0
+}
diff --git a/science/msms/pkg-descr b/science/msms/pkg-descr
new file mode 100644
index 000000000000..e7b6f2264c74
--- /dev/null
+++ b/science/msms/pkg-descr
@@ -0,0 +1,8 @@
+MSMS computes, for a given probe radius, the reduced surface of a set of
+spheres. An analytical description of the solvent excluded surface is
+computed from the reduced surface. Special attention is paid to the proper
+handling of self-intersecting parts of the surface called singularities.
+This analytical model of the solvent excluded surface can be triangulated
+with a user specified vertex density.
+
+WWW: http://mgltools.scripps.edu/downloads#msms