aboutsummaryrefslogtreecommitdiff
path: root/science/netcdf-cxx
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-03 03:18:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-03 03:18:06 +0000
commit017ef2c90bc23d2ebe9e7de6b2cd698f7007bbe5 (patch)
tree805311156e8324608ee3fa9a60f2d3ca3a254d44 /science/netcdf-cxx
parenta63f38bc0640a4068bb75f3a47549443f2934040 (diff)
downloadports-017ef2c90bc23d2ebe9e7de6b2cd698f7007bbe5.tar.gz
ports-017ef2c90bc23d2ebe9e7de6b2cd698f7007bbe5.zip
- Add netcdf-cxx 4.2.1
NetCDF (network Common Data Form) is an interface for array-oriented data access and a library that provides an implementation of the interface. The netCDF library also defines a machine-independent format for representing scientific data. Together, the interface, library, and format support the creation, access, and sharing of scientific data. The netCDF software was developed at the Unidata Program Center in Boulder, Colorado. Git repository: https://github.com/Unidata/netcdf-cxx4 WWW: http://www.unidata.ucar.edu/software/netcdf/
Notes
Notes: svn path=/head/; revision=352856
Diffstat (limited to 'science/netcdf-cxx')
-rw-r--r--science/netcdf-cxx/Makefile30
-rw-r--r--science/netcdf-cxx/distinfo2
-rw-r--r--science/netcdf-cxx/pkg-descr11
-rw-r--r--science/netcdf-cxx/pkg-plist33
4 files changed, 76 insertions, 0 deletions
diff --git a/science/netcdf-cxx/Makefile b/science/netcdf-cxx/Makefile
new file mode 100644
index 000000000000..df9195506609
--- /dev/null
+++ b/science/netcdf-cxx/Makefile
@@ -0,0 +1,30 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
+# $FreeBSD$
+
+PORTNAME= netcdf-cxx
+PORTVERSION= 4.2.1
+CATEGORIES= science
+MASTER_SITES= https://github.com/Unidata/${PORTNAME}4/archive/v${PORTVERSION}.tar.gz?dummy=/ \
+ LOCAL/sunpoet
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= C++ library for machine-independent, array-oriented data access
+
+LIB_DEPENDS= libnetcdf.so:${PORTSDIR}/science/netcdf
+
+CONFLICTS= netcdf-3.* netcdf-4.[0-2].*
+
+CPPFLAGS+= -I${LOCALBASE}/include -fPIC -DPIC
+GNU_CONFIGURE= yes
+LDFLAGS+= -L${LOCALBASE}/lib
+USE_LDCONFIG= yes
+USES= pathfix
+WRKSRC= ${WRKDIR}/Unidata-${PORTNAME}4-b477274
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libnetcdf_c++4.so.1
+
+regression-test test: build
+ cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
+
+.include <bsd.port.mk>
diff --git a/science/netcdf-cxx/distinfo b/science/netcdf-cxx/distinfo
new file mode 100644
index 000000000000..e2a5afe63010
--- /dev/null
+++ b/science/netcdf-cxx/distinfo
@@ -0,0 +1,2 @@
+SHA256 (netcdf-cxx-4.2.1.tar.gz) = 03c639e7834302adc98934ea0e81821143e62e721533f0e111dcb38ae1ca49e4
+SIZE (netcdf-cxx-4.2.1.tar.gz) = 456691
diff --git a/science/netcdf-cxx/pkg-descr b/science/netcdf-cxx/pkg-descr
new file mode 100644
index 000000000000..1f7942b39ec5
--- /dev/null
+++ b/science/netcdf-cxx/pkg-descr
@@ -0,0 +1,11 @@
+NetCDF (network Common Data Form) is an interface for array-oriented
+data access and a library that provides an implementation of the
+interface. The netCDF library also defines a machine-independent
+format for representing scientific data. Together, the interface,
+library, and format support the creation, access, and sharing of
+scientific data. The netCDF software was developed at the Unidata
+Program Center in Boulder, Colorado.
+
+Git repository: https://github.com/Unidata/netcdf-cxx4
+
+WWW: http://www.unidata.ucar.edu/software/netcdf/
diff --git a/science/netcdf-cxx/pkg-plist b/science/netcdf-cxx/pkg-plist
new file mode 100644
index 000000000000..423b2c5e6a81
--- /dev/null
+++ b/science/netcdf-cxx/pkg-plist
@@ -0,0 +1,33 @@
+bin/ncxx4-config
+include/ncAtt.h
+include/ncByte.h
+include/ncChar.h
+include/ncCheck.h
+include/ncCompoundType.h
+include/ncDim.h
+include/ncDouble.h
+include/ncEnumType.h
+include/ncException.h
+include/ncFile.h
+include/ncFloat.h
+include/ncGroup.h
+include/ncGroupAtt.h
+include/ncInt.h
+include/ncInt64.h
+include/ncOpaqueType.h
+include/ncShort.h
+include/ncString.h
+include/ncType.h
+include/ncUbyte.h
+include/ncUint.h
+include/ncUint64.h
+include/ncUshort.h
+include/ncVar.h
+include/ncVarAtt.h
+include/ncVlenType.h
+include/netcdf
+lib/libnetcdf_c++4.a
+lib/libnetcdf_c++4.la
+lib/libnetcdf_c++4.so
+lib/libnetcdf_c++4.so.1
+libdata/pkgconfig/netcdf-cxx4.pc